Sign in with
Sign up | Sign in
Your question

External Enclosure with SATA drive - shows up, but files won't move!

Last response: in Storage
Share
September 26, 2007 3:25:23 PM

I use Vista, but I'm not positive this is a Vista problem...

External Enclosure (SATA) in Vista - when I try to copy files to/from the drive, it says: "Could not find this item"

I recently put a 400 GB Samsung Spinpoint SATA drive into an External Enclosure. The drive worked fine when it was in my desktop (and still does when I transfer it back), but when I put it into the enclosure, strange things happen.

When I try to copy to or from the external (in Vista), it says "You must provide administrator permission to copy this folder."

You think "That's what Vista always does - make you click as many buttons as possible at all times." but on my roommate's external HD (an Element, not an ext. enclosure), Vista doesn't say I require permission to read/write.

Anyway, on my enclosure, it asks for permission, so I click "Continue" and then the screen comes up where it says "Windows needs your permission to continue" (more permission) - and THEN, it says "Could not find this item. This is no longer located in G:\Pictures\School. Verify the item's location and try again."

But nothing moved, nothing was unplugged, it just suddenly forgets where the item is.

If I put the same HD back into my PC (internally) right afterwards, it shows up and everything is accessible.

Any ideas?
September 26, 2007 5:21:49 PM

Have you tried to turn off the user account controls?

I really don't have any ideas but i'm sure this is more helpful than "flush vista down the toilet" junk
September 26, 2007 5:55:40 PM

bc4 said:
I really don't have any ideas but i'm sure this is more helpful than "flush vista down the toilet" junk
I don't know about that, I like the idea. DIE VISTA DIE!
Related resources
September 26, 2007 7:08:06 PM

Hahah! I actually tried it on my PC too and remember it having some sort of problem.

True though, I hate Vista. Is the downgrade to XP good?
September 26, 2007 7:26:26 PM

Also - is it... permanent?
!