Sign in with
Sign up | Sign in
Your question

System freezes when copying files from and to harddisk

Last response: in Storage
Share
September 29, 2007 3:05:04 PM

Hi!

I've got a problem with a very simple 'server' 2003 setup.
It's an Asrock 775i65G mainboard, intel 865G chipset.
Onboard video, audio and gigabit lan.
CPU: Celeron 3.0GHz ( yeah! lol, I said it was a simple server :)  )
A second intel gigabit network card has been installed.

There is one harddisk present in the system: a Maxtor 6Y200P0 (200GB IDE) drive as master on the primary IDE channel, running at UDMA-5.
And one CD/DVD reader as master on the secundairy IDE channel, running at UDMA-2.

Nic 1 is connected to a cable modem/router and nic 2 to the internal network.
The system is running as a domain controller with filesharing and routing/remote access.

The problem:
Whenever I copy files from or to the internal harddrive, the whole system freezes from time to time.
With freezing I mean: everything stops except mouse movement.
On-screen animations from webpages stop animating, I'm unable to click, drag or do whatever else with any open window, no response whatsoever when I click on something. Even ctrl-alt-delete doesn't do a thing.
The duration of the freeze is several seconds, mostly around 5 or 6.
After the freeze, everything works normal again untin the next freeze 30 or 40 seconds later.

It seems that it happens more often with large files (200MB or more) but it also happens when I copy a bunch of small files .. as long as the total size is a few 100 MB's.
It DOESN'T happen when I copy files over the network from one external source to another.

To be sure, I've reinstalled the OS twice and the problem is always the same.
It doesn't matter if I install any of the mobo drivers, nic drivers, gfx, or whatever.
The problem is always the same.
Even tried a bios update: no luck.

The strangest thing is, that when I install windows 2000 or windows XP, there is no problem at all!
With 2000 and XP, I can copy gigabytes of information from and to the drive without any freeze.

So in short: help!?

Grunchlk
September 29, 2007 10:53:15 PM

Try running seatools on it to see if there is any bad sectors or something, I had pretty much the same problem on a old Maxtor disk not long ago, however, I only tested it running XP, turned out to be a bad sector resulting in a more or less useless hard drive.. it works, as long as it doesn't have to read/write a lot of data. :/ 
September 30, 2007 12:23:11 PM

Thanks for your reply Albenza,
I've run the long test with success: Read scan passed.
So at least I now know it's not the drive itself that has a problem.

I've also played with settings like the 'enable write behind cache' and such.
Still no solution.

I can't imagine this being a hardware problem.
Maybe driver related?
Or is windows server not so happy with low budget hardware?

Regards,
Grunchlk
!