Sign in with
Sign up | Sign in
Your question

SATA in AHCI - Unbearable Performance, NEED HELP

Last response: in Storage
Share
October 10, 2007 11:40:51 AM

Hey guys,


Before all else: Great page, great forum. ;) 

Now straight to my dilemma.
I searched the hole net and dozens of newsgroups and forums but couldn't find anyone even mentioning this problem.

I built a new rig two months ago but used the old WinXP-Pro installation due to a lack of time. Still after a few tweaks here and there everything ran smoothly and absolutely flawless.
Now after two months on the old system I used an extended weekend for a fresh and clean XP installation.
I took advantage of this opportunity to install in AHCI-Mode right away and BOOM! Here comes trouble.

After three days the whole system was configured and tuned to my liking.
I started working and discovered this problem:

While maximum write transfers (like copying large files or extracting an DVD ISO-Image) parallel working on the same disk is unbearable.
I first noticed it while extracting a few .rars while listening to music. It started to stutter and clicking noises appeared.
Also switching tracks in the playlist takes like 2-5 seconds depending on the disk position. Videos stutter as well and seeking in them takes forever.
Even for parallel copying small files like 5MB I have to wait 30 seconds.

Just if both processes happen on the disk and just in AHCI-Mode!
In IDE-Native- and IDE-Legacy-Mode none of this is happening.
I thought multi-user-tasking was exactly what NCQ was about to speed up?!

I already reinstalled Windows twice, tried different versions of the Intel Matrix Storage driver.
Both drives are perfectly partitioned, formatted in NTFS and report a fragmentation level of nearly 0%. (I use O&O Defrag btw.)


"Just use IDE-Emulation" you might say, but only with NCQ activated I can burn DVDs while still being able to extract images and copy large files simultaneously.
In IDE-Mode the Read-Buffer runs out every minute. And I don't want the burner to pause the process 15 times per disc.
Besides I don't like the idea of anything being emulated on my system in the first place and AHCI is the way SATA is supposed to run in.


Again, everything else (Video-Conversion, Photoshop, Audio-Ripping, Gaming and any other single HDD app) runs just fine so I'm positive the components itself are okay.
I already tried 2 different WD Caviar SE16s and one Seagate 7200.10. No difference.
Firmware and all drivers are up to date.

I'm out of ideas! :whistle: 

Any support is really appreciated!!!


Components:

- Gigabyte GA-P35C-DS3R (Intel P35 and ICH9-R)
- Intel Core 2 Duo E6750 @ 3,00 Ghz
- A-DATA Vitesta EE Kit 2048MB PC2-6400U @ CL4-4-4-12, 900Mhz
- BFG GeForce 8800 GTS OC, 320MB
- Western Digital Raptor 73.4GB 16MB SATA (WD740ADFD) (System Drive)
- Western Digital Caviar SE16 400GB SATA II (WD4000AAKS) (Documents)
November 17, 2007 8:15:36 AM

Is the write cache activated? If not, go to device manager, double click your hard-drives under "disk drivers", go to "policies" tab and mark "Enable write caching for this disk".
November 20, 2007 2:42:59 PM

I have a similar system as the OP and am having the EXACT SAME PROBLEM. Of course, I tried several wipe and reloads, several different Intel drivers, etc. I upgraded to the current system from a 4800X2 based system and noticed that the "new" system was slower in multitasking than the old one. Of course, I've been running the new system for several months now and just lived with the poor multitasking performance.

I noticed the problem more with Vista 32/64 than XP, but its still awful.

Have you made any progress on the situation, Gentle?
Related resources
November 20, 2007 3:50:36 PM

I had exactly the same problem, but it went away immediately when I installed the 8.3.3 inf chipset drivers and the iata76 drivers. Ever since my computer performs awesome and better than ever before. However, I believe that it is the combination of 8800/Raptor(s)/ICH8-9R.

Before fixing the problem this way, I tried changing the jumpers on my Raptors so that NCQ was disabled and this also fixed the problem. But now I have these On.
November 20, 2007 6:16:38 PM

Steffato, I'm actually running a 500GB WD drive, so I'm thinking its just an early implementation of NCQ on the WD drives. I've got two newer 500GB WD drives in the same system (firmware 4-5 versions newer) and they both perform incredibly well, but are only used for archive purposes (non-raid, btw).

I've tried several versions of the INF and SATA drivers, but no dice.

Thanks for the feedback, though. I'm a desktop support tech, so having a problem like this at HOME that I couldn't solve was getting kinda discouraging. I blame people for "user error" everyday, and here I was thinking I was hosing my system. ;) 
March 18, 2010 11:48:58 PM

I am having this exact same issue, XP with AHCI, WDC WD6400AAKS drive. Has anyone found a fix?
!