Sign in with
Sign up | Sign in
Your question

GA-P35C-DS3R RAID Rebuild problem

Last response: in Motherboards
Share
August 17, 2007 2:56:53 AM


A few days ago I built myself a new computer using the Gigabyte GA-P35C-DS3R Motherboard.
I installed 4x 320gig Western Digital HDD's in a RAID 5 setup and proceeded to install Windows Vista onto the RAID.

All went fine. The computer was working nicely. I ran Windows update, part way through the system locked up. I waited about 15mins for it to do something and it still did nothing, so I hit the reset button.

On resetting I noticed the RAID no longer said its normal everything is ok type message in green, the message was "Initializing" in yellow. I didn't really pay much attention to it and the message disapeared as it proceeded to boot into Windows.
It sat at the loading screen for about 5 mins. I thought this is weird. I tried to push numlock and such and realised it had crashed.
I rebooted and tried again. Same problem.
I tried booting into safemode and again it crashed.

I put the install CD in and tried a recovery. That also crashed.

I decided to remove one drive from the array to see if that could force it to rebuild. The status changed to i think it was "Deficient" and it proceeded to boot windows,, where it crashed at the loading again.

I plugged the drive back in and the status changed to "Rebuild".
Windows crashed again on boot.

I went into the Intel RAID controller setup and saw it said "drives marked with 'rebuild' will be rebuilt within the operating system'. I can't boot into the OS so that was going to be hard.

I installed a 5th drive and installed Vista.
At this point I could browse any of the files on the array, which makes me wonder why I couldn't boot from it.

I installed the Intel Matrix Storage Manager software and it gave me an alert saying the array needed to be rebuilt with a non member drive.

I selected the drive that I unplugged and plugged back in, this was the only non member drive. It gave me a message saying

Rebuild RAID Volume Wizard
The volume cannot be rebuilt to the selected hard drive due to one of the following reasons:
- The hard drive contains system files or is the system hard drive
- The hard drive is not large enough to be used for the rebuild action
- The hard drive has reported a SMART event
- The hard drive has reported a failure

I thought maybe it had some previous information on it. So i formatted it. Still no go.
I removed the drive letter assignment. Still no go.

The drive is the same as all the others.
The drive has no files on it so it cant be a system drive
The drive was working fine until windows crashed so I doubt its a SMART or failure.

How can I check the SMART status anyway just in case? The Intel software doesn't seem to report anything apart from the drive is fine.
It formatted fine also.


Does anyone have any ideas at all what is going on?

More about : p35c ds3r raid rebuild problem

October 6, 2008 2:07:47 PM

I'm having problems with my RAID setup as well. Recently I replaced the ASUS P5N32-SLI mobo with this Gigabyte GA-X48-DQ6. That wasn't the only change, as I also upgraded to quad core, replaced the graphics board, etc. Previously (using Nvidia's chipset controller) I was setup with a RAID-0 for performance, on this upgrade I went to RAID5. Should be noted I also installed Vista for the first time.

Since the upgrade I've had nothing but problems with the RAID. Oftentimes they'd go to "Degraded" for seemingly no reason at all, requiring 3-5 hours to fix and suffering degraded performance the entire time. Worse, so far in the last 4 months since the upgrade, I've had to do total rebuilds of the RAID volumes, and those took an average of 36 hours to complete! This last rebuild came just 2 weeks since the previous one. :fou: 

Either I have one or more drives going south, or the ICH9R really is just an utter POS when it comes to RAID. I'm about ready to go to just a regular non-RAID setup. RAID doesn't seem to be really recommended for data protection anyway, and I'm questioning whether, as a home user, if I need it. For me the issue is uptime, not redundancy - there's really no data on the drive that's ultra precious, and what is I backup to DVD or flash when I can.

As it stands, it's rebuilding now . . . . again . . . . . and once finished maybe I can use either the Windows utility, or fdisk, to see if I've a drive going down. Otherwise, I'm going to back up what I can and get rid of the RAID.
Related resources
October 10, 2009 1:52:10 AM

I have a GA-P35-DS3R, and am using RAID5 with six 500GB drives. This board has an ICH9R controller with six ports and a Realtek controller with two ports.

EVERY TIME (or almost every time; I don't want to exaggerate and I don't know for sure) I connect a drive to the Realtek controller via rear-panel eSATA ports, usually either a Blu-ray drive or rotated external storage, the RAID starts rebuilding.
a c 177 V Motherboard
October 10, 2009 2:51:20 PM

HD_Tune here:
http://www.hdtune.com/download.html
should let you read SMART, but you will need to 'break' the RAID to do it, drive by drive - can't read SMART off an array (unfortunately)...
May 4, 2010 1:34:58 PM

Dear Community!

I had to download the latest Intel Raid Storage driver and console from the Intel's webpage and after a restart rebuilding RAID 1 became OKAY, when with the previously inserted HDD was told to be broken.. (bad smart, boot, not large enough etc..)

I previously used the default driver came with ASUS P5QC motherboard driver disc on Windows XP 32 bit..

Sincerely,
eSzeL
May 4, 2010 1:39:58 PM

Driver likes this:

a c 177 V Motherboard
May 4, 2010 3:16:10 PM

Hungarian?? Eeek - I'm game! By the way - your english is very good [:bilbat:5]

Click on the Manage button at the top ("Kezelés"?)

Next, click on the failed drive at the upper right - the one showing the "!"

I cannot show this, as I have no failed drive, but, in the text to the left, an underlined link should appear that says someting like 'Reset disk to normal' ("orrgazdaság korong -hoz szabályos"??)


The link should appear in the red enclosed area...

If the drive has not actually gone bad (fizikai megbukik?), the software will attempt to rebuild the array, and will show a "percent complete" ("százalék kiegészít"?) for some time (hours) as it fixes itself. If this does not work, you will have to 'break' the RAID to diagnose the drive itself, or just replace it...

Another thought - is this a new install, or has it worked before? I have never seen a 3 drive RAID1 - did not know this was possible. If new install, software may just be telling you 'can't RAID 3 drives!'
!