Sign in with
Sign up | Sign in
Your question

802.11 connection failed due to status code 10

Last response: in Wireless Networking
Share
December 23, 2008 3:10:34 AM

I just got a cheap acer laptop with a atheros ar5b91 wireless nic. It's supposed to work with wireless n, but it won't connect. It works fine with g.

I went to the event viewer. Here's a copy of the report...

Helper Class (RNWF MSM Helper Class) Event:

Wireless Diagnostic Helper Class Event

For complete information about this session see the Wireless Diagnostic Informational Event.

Helper Class: Native WiFi MSM
Initialize status: Success

Information for connection being diagnosed
Interface GUID: a6b408b2-7f2d-4f54-b303-55b3d877abfd
Interface name: Atheros AR5B91 Wireless Network Adapter
Interface type: Native WiFi
Profile: Rose
SSID: Rose
SSID length: 4
Connection mode: Infra
Security: Yes
Connect even if network is not broadcasting: No

Result of diagnosis: Problem found

Root cause:
Windows cannot connect to "Rose"
The capabilities of the wireless network adapter on this computer don't support the requirements of this network.

Detailed root cause:
802.11 connection failed due to status code 10: Cannot support all requested capabilities in the Capability Information field

Repair option:
If you set up or own this network, you might be able to fix the problem by changing the settings on the wireless router or access point to be compatible with the wireless network adapter on this computer
Contact the network administrator for "Rose" or your hardware manufacturer for further assistance.



Event Verbosity:0



Suggestions?
Anonymous
a b F Wireless
December 23, 2008 1:20:25 PM

My understanding is that 802.11n is not actually an official standard so may not work with different brands. Of course the router may not even be 11n.

I doubt if you'll notice any performance difference anyway if you're only using it for the internet.
December 23, 2008 10:42:38 PM

The router of course if wireless n. I will definitely notice the difference in networking and I made sure I got a notebook with n, so if it won't work it's pretty gay.

I have a feeling there are some adjustments I can make in the router settings?
Related resources
Anonymous
a b F Wireless
December 24, 2008 8:13:40 AM

Certainly have a look at the router's user interface and make sure that 11n is selected as wireless mode. I would also turn off wireless encryption and access list and see if that helps.


I take your point about networking speed.

On compatibility, I'd say that presently is safest using 11n router and 11n wireless adapter of same brand.
December 30, 2008 4:13:20 PM

I would agree ... Also depending how old the router is and what level of firmware... I have some early 802.11n soho draft gear and had similar issues. Also check channel bonding if its on or not.
December 30, 2008 5:31:32 PM

The router is a Rosewill RNX-N4. I already tried turning off encryption, and of course I turned n on. I had it set at mixed g/n and noticed it was only connecting at g speeds. Then I switched to n only, and it wouldn't connect.
I have media center extenders that connect at n speeds with this router also.
March 23, 2009 1:28:49 PM

I have the same problem. The error message also states "does not satisfy requirements."

Both the laptop and DLink router were purchased in the lest few months.

Wireless adapter Atheros AR5B91 does not connect in 11N mode.
The wireless adapter works fine in 11G but not in 11N with new DLink router.

The laptop is an Aspire 4530 running Vista Home Premium. The driver version for the adapter is 7.6.1.204. This is the lastest driver. There are no apparent BIOS configuration parameters for the AR5B91.

Tests show that wireless G operates at about 1.3 Mbps. This is well below the 1.9 Mbps of the last cheaper DLink that reset every 2 minutes.

The router is a DLink DIR 615, just new out of the box.
The hardware version is C1 and the firmware version is V3.01. This is the latest firmware for this hardware version.
This router holds a stable wireless connection.

The wireless (router) settings are:
Wireless network name: set, as is the Pre-Shared key
Mode: 802.11n only
Autochannel scan: enabled.
Channel width: Auto 20/40 MHz (also tried at 20 MHz as well)
Visibility Status: visible.
Security Mode: WPA-Personnal
WPA-Mode: WPA Only
Cypher Type: TKIP
Group Key Update Interval: 7200
Connections are set for DHCP.
June 14, 2009 1:59:09 AM

I have the same problem with the atheros ar5b91.
This is the only N card that I have, so I can't test and see if it is the router
June 22, 2009 1:21:52 PM

Exact same problem here. Atheros ar5b91 with an Acer 4730z. Router is a Dlink dir-615 Will connect on G but will not connect on N. When I just send out the N signal, I can locate the signal with my laptop, but it will not connect. It comes back "The capabilities of the wireless network adapter on this computer don't support the requirements of this network." I have tried every conceivable configuration with no luck. Let me know if anyone finds a solution.
June 23, 2009 3:07:09 AM

I have since been able to get my Acer 5535 with the Atheros ar5b91 to connect at N speeds.

1. change encryption to none or WPA2
2. change router to broadcast at 20 mhz not 20/40
3. change router to broadcast at N only.
4. remove the old connectoid and start a new connection
5. create new connection with the settings that you know that the router is set for.


Try it.

I have connected at 130 mb/sec but currently am connected at 65 MB/sec

TP
June 23, 2009 3:31:36 AM

Thanks tpuckett99 for the reply. I will try it and let you know how if it works for me.

Anonymous
a b F Wireless
May 19, 2010 5:48:14 AM

I have exactly that same problem. I have Atheros ar5b91 Wlan card and D-Link 615 router and N speed does not work at all!
Is there is some kind of fix available?

mjhombre: Did you tried that tpuckett99 solution ?
!