Sign in with
Sign up | Sign in
Your question

Bioshock demo crashes on my 8800 ultra & Vista

Last response: in Graphics & Displays
Share
August 21, 2007 12:38:21 PM

Just wanted to know if anyone else had issues with Bioshock Demo on Vista using a 8800 ultra?

I downloaded the latest beta drivers from nvidia as suggested and when it crashes, Vista says my nvidia drivers stopped responding.

I bought the game and I hope when I get home from work today that I dont have the same problem with it. I am thinking of uninstalling the drivers and going with the non beta.

Help!!!!
August 21, 2007 1:17:04 PM

I am having the same issue with the demo and the non-beta nvidia drivers on my 8800GTX. The game won't even start. I see the bio shock splash screen then the monitor goes dark like the game is about to load, then nothing happens...
August 21, 2007 1:21:49 PM

Mine loads and plays fine and then randomly stops and vista says video driver is not responding. The game takes me back to the desktop while the sound and games seems to still be playing but no video.
Related resources
a c 169 U Graphics card
a b \ Driver
a b Î Nvidia
August 21, 2007 1:35:04 PM

to julest and rayzor , what drivers are u using ? and also vista 64 or 32 ?
August 21, 2007 1:36:30 PM

vista 32-bit and the latest beta drivers that were recommended. 163.44
August 21, 2007 1:58:12 PM

I get the same thing on my 8800 gts 320MB. The first time I tried it I just got a black screen and had to reboot; the second time it just gave me the Bioshock.exe has stopped responding message.

I have the latest 163.44 drivers and the Steam version of the demo on Vista 32 bit.
August 21, 2007 2:18:45 PM

crap, that article doesnt help because I have that version of the driver. Vista just stinks, that is the problem.

I am using the fileplanet version of the bioshock and I haven't tried my full steam version yet since we still have a few hours for activation.

If I go to play the full version and it does this, I will not furious! What does the beta driver give? If it is just performance then I will uninstall and go back to the latest non beta because I can't go without play all night tonight.

August 21, 2007 2:32:13 PM

Sure glad my Geforce 6800 GT runs it, although, not exactly smoothly with the settings on high.
August 21, 2007 2:35:20 PM

Have you guys gotten that patch that anandtech reviewed about a week ago? It is a patch to chill the memory usage by windows when using high end cards. I can't remember all the tech specs buy you should all install that. You all have a big card with lots of memory and it really depends on the rest of your system. Microsoft has hidden this patch and is not making it easy to get. Go check anandtech.com and find the patch. It is something in there about a hotfix. It was call hotfix ........ whatever those numbers are and I just woke up and am lazy so you need to go find it yourselves but that seems to be the problem. You 2 gigers on vista 32 with a GTX definitly will run into problems without this patch. Probably is everyone's problem here because usuage was getting worse as time went on; I'm not as sure about you people who crash right away. Don't know enough about your configs.


In my ramblings I forgot to mention it was something microsuck released a few weeks ago or a week ago: something like that. Anyhow, find out that patch. Its not your graphics driver either. It is something to do with vista's memory usage, like your system mem. I don't want to give specs on it cause I don't remember at all but it sounds like the exact same problem. Good luck guys
August 21, 2007 2:52:19 PM

I do remember two patches being release a couple weeks ago, and you can very well be right. I will definately try that when I get home. I just built this rig and I would be very unhappy if I had problems. And yes Vista is crap and I wouldn't use it if it wasnt for DX10.

August 21, 2007 3:01:39 PM

I have both of those patches and I still get this crap. Just a black screen when I try to run it and I have to press the power button on my computer, at which point windows shuts down properly like nothing is wrong.

Also my gts only has 320MB of VRAM, so memory usage is likely not the culprit. Thanks for the suggestion though.

Full specs:
Athlon 64 X2 3800+ @2.5GHz
2GB DDR-400 @208MHz 2.5-3-3-7-T2
eVGA 8800gts 320MB @ 600/900
Cheapo sound card
120GB Western Digital HDD
BenQ DVD burner
Memorex CD burner
XCLIO Goodpower 500W
Vista x86
August 21, 2007 3:04:29 PM

Well mine plays but then goes back to the desktop and says video driver not responding and the game is still running with the sound but no video of the game just the desktop which still responds. I can actually end the task and run again
August 21, 2007 3:47:51 PM

Does anyone have an 8800 and Vista without any problems in the game?
August 21, 2007 4:19:33 PM

i was getting the same issue with x1800xt until i upgraded driver. now my x1800xt runs the game perfectly maxed out at 1280*1024 with the newest drivers It must be the nvidia drivers causing the problem because i had to upgrade my ati drivers to fix this issue.
August 21, 2007 4:37:27 PM

Ok, I applied all patches and hopefully when I get home from work, all will work well. Thanks for the information everyone.
August 21, 2007 4:59:32 PM

There is a beta driver from Nvidia that fixes issues with bioshock. Go download it here. http://www.nvidia.com/object/winvista_x64_163.44.html
that link is for the 64 bit drivers, however there are drivers for xp as well in both 32 and 64 bit flavors.

Edit: Didn't read you already had the new drivers, disregard this post.
August 21, 2007 5:06:42 PM

So I applied the permerance patch, the two hotfixes that require support and I have the latest nvidia drivers. I hope that is all I need.

I just build this

Quad 2.6ghz
MSI 8800 Ultra OC
4GB Dominator Mem
150GB Raptors
Dell Ultrasharp 24" 16:10 Display

I am ready to play
August 21, 2007 5:08:42 PM

Samething happened to my 8800gts 640. for lost planet before, and now the bioshock. Exchanged the card to a 2900xt yesterday, and both of the games working fine now
August 21, 2007 5:50:59 PM

nvidia drivers and vista were having issues for a while now. I think some people have been able to run the game using DX9, but it's a shot in the dark at this point.
August 21, 2007 6:03:19 PM

Homerdog your problem sounds like it is caused by your powersupply because I am not sure about the wattage. You have your cpu overclocked plus a power hungry graphics card. What is the amps on the 12v rails?
August 21, 2007 6:15:49 PM

Demo surprisingly working fine for me at max settings and I am using a Athlon 64 x2 and a 8800 320MB GC.

I am shocked to say the least -- maybe the 8800 series is better than we have given it credit for.

The Upright'stand corrected'man!
August 21, 2007 6:19:01 PM

Its not the powersupply I got a kickbutt pc power and cooling 750w which equivalent to others 1000w.
August 21, 2007 6:19:41 PM

chances are its those few patches and hotfixes that are not apart of windows updates.

August 21, 2007 6:38:02 PM

I got all recent MS updates and latest/recommend nvidia drivers and it ran first time.

So its all standard stuff
August 21, 2007 7:06:32 PM

theuprightman24 said:
Demo surprisingly working fine for me at max settings and I am using a Athlon 64 x2 and a 8800 320MB GC.

I am shocked to say the least -- maybe the 8800 series is better than we have given it credit for.

The Upright'stand corrected'man!



What resolution are you using?
August 21, 2007 7:07:51 PM

gahleon said:
Homerdog your problem sounds like it is caused by your powersupply because I am not sure about the wattage. You have your cpu overclocked plus a power hungry graphics card. What is the amps on the 12v rails?

It's not my powersupply, I can play any other game including STALKER and Oblivion for hours and run dual prime as well as a video card stability test for days and the 12V rails are rock solid according to speedfan. Just to be sure, I tried taking all of my overclocks off and it didn't help.

I tried rolling back to the last certified driver (162.22) but I still got the same problem. The screen goes black and nothing happens. I have found that if press Esc it sends me back to the desktop just like I never clicked on anything.

I've already played through the demo on my roommates 360 and loved it, but I'm holding off my purchase of the PC version until I'm sure that it'll work. Does this problem exist on the full version or just the demo?
August 21, 2007 7:16:46 PM

masteryoda34 said:
What resolution are you using?



1280 x 1024 --
August 21, 2007 8:00:00 PM

I know this will sound noobish, but did any of u try uninstalling the demo, reinstalling the drivers then reinstalling the demo?

- Just a thought
August 21, 2007 8:48:38 PM

Alright guys I figured it out. You have to update directx. I feel stupid now.
August update
August 22, 2007 12:39:21 AM

Well I got my full steam version and it was doing the same thing. I tried everything so I uninstalled the beta drivers that nvidia rushed out just for this game and installed the latest non beta. And all works great even in DX10 mode. Why they put me through this I will never know.
August 22, 2007 1:01:27 AM

Seems like there isn't one solution. I have the new beta drivers, dx10 and everything runs great.
EDIT: Full game that is
August 22, 2007 1:49:10 AM

Well for me 163.44 beta drivers + August dx update = working demo :) 
August 22, 2007 2:50:56 AM

I can also confirm the DX update. Mine wouldn't even launch at all until I updated DX. Simple fix.
a b U Graphics card
August 22, 2007 3:43:08 AM

I get pretty far into the demo and then it crashes - horrible artifacting, picture splinters into vector shaped wedges. Vista business 32 bit, 8800 gts (640) with latest Nvidia drivers. Testing dx update now.
August 22, 2007 5:42:46 AM

Well I thought mine was good but it still crashes from time to time, we need to make Nvidia aware so they fix this. I been playing for about 6 hours and had to reboot the computer abouit 6 times. I can go an hour before it crashes but other then that it looks and runs great. I love this game!
August 22, 2007 5:48:38 AM

I submitted a QA forum on Nvidia's support page. Please do the same so the more the better and we can get this resolved.
August 22, 2007 7:03:31 AM

I refuse to be a beta tester for MS, Nvidia, unless they pay me for my time. Good luck to you guys.
August 22, 2007 7:15:59 AM

systemlord said:
I refuse to be a beta tester for MS, Nvidia, unless they pay me for my time. Good luck to you guys.



If you don't make yourself part of the problem you can't really complain that it doesn't work.
August 22, 2007 8:14:16 AM

theuprightman24 said:
If you don't make yourself part of the problem you can't really complain that it doesn't work.


Who is complaining??? I just stated that I won't beta test for MS or Nvidia. Its that hard to understand? So If I don't make myself part of the problem then I'm complaning? :heink:  There just isn't any logic in that.
August 22, 2007 8:50:00 AM

I have the retail game. I let it auto update everything BUT the nvidia driver. Game works fine.
August 22, 2007 11:24:20 AM

San Pedro said:
Does anyone have an 8800 and Vista without any problems in the game?


I have a 8800GTX / Vista, and am using the beta drivers that the demo recommended I use. The game runs smoothly at 1920x1080 on maximum settings.
August 22, 2007 1:02:03 PM

its Vista peoples you'll have to wait for some patches to come out.
sorry if this has all ready been posted.
August 22, 2007 1:36:06 PM

Hey! Wait just a minute!!! I thought Vista was supposed to enhance the gaming experience!?!
August 22, 2007 1:48:07 PM

yeah...., they lied, I mean they were hardly going to say "our new operating system that we have been working on for 5 years will take about 10% of your gaming performance off of you in exchange for directx 10 that we probably could have put onto xp with a serivce pack but we are lazy bastards who want your money" were they?
August 22, 2007 1:54:56 PM

Honestly, Vista isn't taking gaming performance away from your system anymore, since Forceware 158.22 I think performance has been on par with XP SP2, the only difference is that you need 2GB of ram to run smoothly. (Which is something gamers aren't really concerned, because any serious gamer probably has 2-4GB of ram now)

I can honestly see DX10 doing some great things, but it will take also a good group of devs that actually put work into it (Like Bioshock), instead of doing a half-assed job like we've seen from the DX10 patches on most games.
a b U Graphics card
August 22, 2007 2:51:35 PM

well I got the latest drivers and the dx update and it still crashes my vista 32/8800 gts 640. I did get pretty far into the demo. Looks good! I just hope it finally works.
August 22, 2007 3:17:53 PM

Installing the latest dx update solved my problem of the game crashing on startup. Playing with 8800GTX and 1680x1050 and it looks and plays AWESOME! This is an incredibly detailed game. If this game is any indicator of the performance we'll get out of the next few "true" dx10 games then I am very happy with my 8800GTX for now! Can't wait to get my hands on Crysis in a couple months...
!