Sign in with
Sign up | Sign in
Your question

[Problem]P5K mouse and sounds freezes during IDE-actitity

Last response: in Motherboards
Share
August 23, 2007 9:10:57 AM

Hello!

I have problems with my new Asus P5K-based system.
For example, while listening music with Winamp the sound freezes for short time (maybe 1/10 seconds or something) but this happens regularly and it's very annoying. I used the same sound card on my previous system and all worked fine! During these short "freezings", the mouse cursor will stop also for a short moment. Music freezes something like "TRRRRR!!" and goes on again...

I think these mouse cursor and sound problems will occur when reading some data on my IDE HDD, which is my primary HDD (os installed on it)

I readed somewhere that the problem could be that the os has been installed on IDE HDD instead of SATA? Is there any sense? Could the P5K's IDE-bus be so poorly working?

I've tried to update drivers to the latest version but nothing seems to help. P5K's onboard sound chip is disabled from BIOS.

This Windows XP install is old, I didn't need to reinstall Windows during hardware update. But everything else seems to work just fine so I don't think that's the problem.
I'd prefer not to install OS and all the programs again on my SATA drive just for testing if the problem could be solved that way, so if you guys have any other idea to solve this annoying problem I would be very thankful!

My system:

Asus P5K (not "deluxe" etc)
Core 2 Duo E6600 @ 3,6GHz (400 x 9)
4 x 1 GB Kingston 667MHz DDR RAM
Club 3D GeForce 8800 GTS 320MB
Seagate 120 GB IDE as primary HDD (OS installed on that)
Seagate 300 GB ATA as storage HDD
Seagate 500 GB ATA as another storage HDD
Soundcard: Terratec Aureon Space 7.1
Windows XP Pro SP2 with all security patches
August 23, 2007 11:04:44 AM

Ok. Easy problem and easy solution.

Problem: Your PnP is set up from within Windows XP, and your XP is from your old system, correct? You said your XP install is old, but you also said "new Asus P5K-based system". You bought this problem when you didn't reinstall Windows from scratch.

Plug and Play is set up through Windows XP, where IRQ's are assigned and your hardware has completely changed, yet windows isn't going to suddenly reallocate everything again. I'm not sure you can even tell windows to reallocate everything all over again without doing a fresh install. A fresh install being installing brand spanking new and not a repair install or install over the old install.

The result you are seeing is your IRQs conflicting. It would appear that your sound card and IDE controller are sharing the same IRQ. When 1 device is using the IRQ, any other device or devices connected via the same IRQ can't do anything except wait until it's done. This conflict used to be VERY common back before PnP. In your case, when you are reading/writing data to the hard disk, you can't also send data to the sound card, nor can the sound card tell you that it's buffer is almost empty. So the sound card runs out of sound and either sticks on the last note it was at, or it just stops the sounds altogether. Regardless of what your sound card does, it just ruins any attempt to listen to music or play games. Your problem might actually be your mouse and your sound card because your having problems with both. Of course, you could also be in a situation where your mouse and another device are sharing IRQ and your sound card and a different device are sharing a different IRQ.

Easiest thing you can do is erase your hard disk and install windows fresh. I ALWAYS install Windows from scratch when I upgrade the motherboard. It gives me a fresh copy to determine if there's any hardware problems, and it removes any doubt that im going to have these 'carried over' problems later.
August 23, 2007 12:34:53 PM

Here's my irq-setup:


I'm not sure if there seems to be serious conflicts?
Related resources
August 27, 2007 7:11:18 AM

Can anyone help me with that?
August 27, 2007 8:34:12 AM

Do you have the Plug and Play option selected in your BIOS?
August 27, 2007 8:42:44 AM

Yes I do (for now), but it didn't seem to do anything.
August 28, 2007 7:09:11 PM

I'm getting hopeless with this :( 
August 31, 2007 12:37:40 PM

Try testing with a different PS.
September 3, 2007 7:29:46 AM

PS = power supply? I don't think that is the problem
September 3, 2007 8:44:56 AM

open up device manager, have it set to device listing, uninstall both ide controllers, restart, see if it still happens, i'm assuming that windows xp has stuck them back in pio mode, the only way to change it is wiht a regedit or wiht a quick uninstall/reinstall, after you uninstall, and restart, they'll automatically reinstall
September 5, 2007 8:09:22 AM

Hooray, I think that I found the problem:

I switched the JMicron IDE-driver to MS standard dual channel IDE driver and the problem seems to disappeared!
November 7, 2007 4:21:03 PM

Hi all

I have the same problem with asus p5k.
i use the on-borad sound, and it freez all the time with the mouse.
i did instaled a fresh xp, but i cant change the jmicron to standard
because i use it with two 250Gb disks raid-0 (strip)
and the system boot from it.

i understand from zibbazabba that the problem is something with
the JMicron.

so what can i do ?

Thnk you.
Rony.
December 4, 2007 8:00:04 PM

i've got the same problem. Mouse is freezing for 1/10 of second when hdd activity i can't watch any movies (youtube,dvd etc.)
help us ! :( 
December 9, 2007 7:21:04 PM

Hello: brought a new MB ASUS P5K with Q6600, Notice that mouse with freeze for fraction of sec without any reason. Can zibbazabba tell me how he changed the seetingd for Jmicron controller. Thannks
December 15, 2007 7:37:11 PM

OK guys, I think zibbazabba is right. Just did as he said and it worked. No more sound pops and mouse is smooth as silk. Just go under Device Manager and from the top menu click View > Resources by type. Then expand Interrupt Request (IRQ) and change all that says “Intel ICH Controller etc. etc” which is shared with the sound card IRQ, right-click them one by one and choose Update Driver, skip the going online stuff, choose "Install from a list or specific location (Advanced)", then choose " Don't search I will choose the driver to install" click Next, Now under the list of compatible hardware you should have 2 choices. Choose the one that says "Standard Universal PCI to USB Host Controller" Click Next to install and reboot when done. I had to do one of them in Safe Mode because the mouse/keyboard kept freezing. I also did it for the one that says “JMicron JMB36X Controller” (on IRQ 16, for me) and used the Microsoft one instead “Standard Dual Channel PCI IDE Controller”.

It’s very annoying to do this but at least it solves the sound pops/mouse freeze problem.
August 19, 2008 10:46:41 PM

Hi, All...
I have just upated the JMicron driver and works fine... ftp://driver.jmicron.com.tw

Edu

JMB36X RAID Driver Release History

---------------------------------------------------------------------------------------------------------------------------------

R1.17.39WHQL (08/01/08')

- Burning disc failed.
- The hotplug of two SATA ODD has problem.
- Removable icon doesn't show for HDD.
- IDE disks are wrongly set as removable.

---------------------------------------------------------------------------------------------------------------------------------

R1.17.38WHQL (06/23/08')

- Fix the failure that serial number offset is -1 in WLK 1.2 "Storage Query Property" test.
- The "safely remove device" disappears after creating PMP RAID.
- Hot plug too fast will make the system hang up.
- W/r the eject button of JMB336 ODD enclosure for HP Voodoo NB.
- Add "Bustype" in inf to pass WLK 1.2 "Storage Query Property" test.
- Work around the issue that S3/S4 will crash if OS is installed in disk connected to eSATA port. (ASUS iCH10)
- It needs more than 15 sec to detect a plug-in ODD.
- Adding subsystem vendor ID 0x90081071 for Mitac.
- CPU utilization is abnormally high when WD Mybook 1TB spins down.
- Some systems can't be shut down if ODD is connected.
- Interface error happens frequently in eSATA port if block size is set as 128KB.
- Adding subsystem vendor ID 0x83521043 for ASUS.
- Only modified inf. Driver is not changed.

---------------------------------------------------------------------------------------------------------------------------------

R1.17.37WHQL

- System freezes for several seconds when turning on the power of hard disks.


August 24, 2008 3:29:13 AM

I have almost the same problem.. except when my sound and mouse freezes it doesn't unfreeze until I reset my computer. Doesn't freeze in safemode though. I installed the latest driver the 22/08/2008 one and it still freezes.

I have:
Intel Q6700 @ 2.66 GHz
2GB of RAM 800Mhz
K5P ASUS Motherboard
nVidia GeForce 8800 GTS

Help please..
September 29, 2008 7:18:57 AM

i have an msi kt6v mobo that i switched to sata.it stuttered so bad that it mad a god awful noise. i updated the drivers from the xp raid drivers to the latest and only available via drivers online. sound and mouse still stuttered but got rid of the god awful sound. so i got my old original floppy from the mobo and forced it to install old drivers. rebooted and it works like a charm.. so people know.. new drivers may not be the answer.
January 14, 2009 12:40:35 PM

>Hi, All...
>I have just upated the JMicron driver and works fine... ftp://driver.jmicron.com.tw

Hi guys! I was having this problem for quite a while. I was trying a lot of things until I came across this topic. Updating JMicron driver fixed the problem for me too! THANK YOU VERY MUCH!!!

January 16, 2010 3:51:19 PM

I have the same problem with windows 7 using asus p5k with jmicron36x in raid0 with latest drivers... don't know what to do :( 
December 8, 2010 9:32:09 AM

Same problem with ASUS P5K winxp pro
Tried to update driver - didn't fix it
Tried to change ICH9 controller to standard one - didn't fix it

I'm going mad with this thing.
Please help.
!