Sign in with
Sign up | Sign in
Your question

Vista not detecting DVD-R/CD-R

Last response: in Storage
Share
November 14, 2007 6:05:38 PM

Ok i've searched thoroughly through these and various other forums for answers, but have found none.

As of recently my DVD/CD drives have disappeared from My Computer under Removable Storage Devices, so all I see are my two HDDs and a floppy drive (by default)

When I first installed Vista a few days ago (NEW RIG) the drives worked fine, so this means that it worked at one point and my BIOS detects it under all the IDE listings. Both drives are IDE and they are set as primary and slave accordingly (Which they had to of been because it worked before).

I'm thinking, maybe after installing the ICH9 drivers for the SATA/IDE controller it might of messed things up so I uninstalled those and it didn't work so I ended up slapping them back on.

It's really a bummer because I bought Crysis today and can't even install it :( 

Here's my rig info if it's any help

GA-P35-DS3R
Intel Q6600 @ Stock 2.4
2GB Mushkin Enhanced DDR2 800
eVGA 8800GTX
Rosewill 750w PSU
Toshiba or Samsung DVD-RW drive (Don't know which)
Liteon 52x CD-RW

Oh ya and both drives have power and can open/close.

More about : vista detecting dvd

November 14, 2007 6:13:13 PM

Oh and also I don't see anything under Device Manager that's labelled DVD/CD drives, under the IDE selection it has a bunch of unnamed things but no exclamation points and yellow triangles, none of those, yet.
November 14, 2007 6:58:19 PM

I recently experienced the same problem, albeit with a much older system than yours (an 8-year old Dell running Windows XP). One day my CD and DVD drives were there, the next they weren't.

I found that if I rebooted the computer ala 'restart', the drives would not show themselves. However, if I shut the computer down completely, waited a few seconds, and then booted back up, the drives would be there. For a couple of months, I resorted to playing a game with the DVD drive, having everything be fine, having the drive disappear as soon as I stopped playing the game and then powering off and rebooting when I wanted to play again. Finally, after about 2 months of this, everything went back to normal. I'm chalking it up to bad connections on the mobo...but who knows.

Sorry that I can't help you fix it, but maybe the 'power down' solution will work for you???
Related resources
November 14, 2007 7:02:26 PM

the reason it does not detect it because vista sucks
November 15, 2007 3:30:16 AM

Hrm thanks a ton sleepyhead for the response, i'll try that.

I'm not exactly sure what the problem is yet and no Vista does not "suck". I actually find it to be better than XP in several ways and all I do is play graphically demanding games (Cuz I can't settle for less :p ) and Vista really helps keep the feel of being up to date (Sounds corny) and it looks fantastic, other than that most of the features are pointless (I'm looking at you MAC ripoff "widgets" and the lame Sidebar.

But back to the issue, i'm still having problems :(  this is taking the word suck and evolving it into the word blow
November 16, 2007 4:45:18 AM

^bump
November 17, 2007 3:12:52 AM

^bump
November 18, 2007 1:02:06 AM

arg
November 18, 2007 2:15:58 AM

This can be fixed by deleting a registry key. I have done it before. Just forgot exactly where is was sorry.
November 18, 2007 2:23:55 AM

yes paq7512 is correct

delete the upperfilters and lowerfilter in the
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

key
November 18, 2007 2:58:34 AM

If the registry hack doesn't solve the problem you can always try the common set of troubleshooting measures...

-Change out IDE cable

-Try an alternate set of molex connectors

-I once had two optical drives that for some reason didn't like each other and worked fine when I switched form cable select to master/slave...you may want to try both ways, adjusting the jumpers appropriately for each

-Try one drive at a time (making the proper jumper adjustments)

-Could be a problem with the PS flaking out on your molex power feed...do you have another PS you could try?

-If the reg edit doesn't solve the problem and if the above troubleshooting tips don't work, could be a more serious problem - malfunctioning IDE motherboard connection bracket failure, or bad soutbridge chip...can happen even with new motherboards (unlikely though)

Good Luck!
November 18, 2007 5:52:06 AM

Changed the IDE cables and deleted the registries, the only thing deleting those registries did was make my iTunes come up with an error and the IDE cables are fine I swapped them out with brand new ones and ones I used before.

My BIOS detects them both as well as my post.
November 28, 2007 6:57:51 AM

1haplo said:
yes paq7512 is correct

delete the upperfilters and lowerfilter in the
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

key

:bounce: 

Thanks
I have a dual boot XP Pro/Vista Home Premium decided last week to go fully Vista. This happened after I installed Photoshop Elements 5.0 plus the Vista patch. System froze P/E 5.00 stopped working. I un-installed it and thought I would re-install unfortunately no DVD Drives, both gone but showing in device manager. Vista also said they were both installed properly when I did an on line driver update.
Deleted lowerfilter (only one showing) as per your advice ;)  abracadabra back they come!!!.

Thanks again
August 13, 2009 3:53:43 PM

Go to devicd manager and unistall the ide controllers and reboot.
When rebooted the computer will reinstall these devices.
When I did this I found out that the wrong drives had some how gotten installed for my ide controllers.
!