Sign in with
Sign up | Sign in
Your question

Problem reading data from a DVD burner (Pioneer DVR-112)

Tags:
  • DVD Drives
  • Windows XP
  • Storage
Last response: in Storage
Share
November 24, 2007 11:22:56 AM

I have a DVD-rom question and it feels like I’ve looked everywhere for the answer.

I recently put together a new system with a new DVD-ROM drive (Pioneer DVR-112) and Windows XP. My problem is that the DVD-ROM in one of my computers is not able to read data from CDs or DVDs while in normal Windows XP mode. It IS able to read CERTAIN CDs or DVDs while in safe-mode, however.

I get two kinds of error messages when trying to read from the discs. I am running Japanese windows, so one of them contains some Japanese, but the other one is all in English. They are:

1. “XXXX is not a valid Win32 application.” (Where XXXX is the name of the application)
2. “Only part of a ReadProcessMemory or WriteProcessMemory request was completed”

The error message I get depends on the kind of disc that I try to read from. Either way, I can neither access the data on the disc nor the icon that is associated with the disc and its title in the My Computer screen.

Another couple of things to keep in mind are that I have tried turning the IDE mode for both the DVD-ROM drive and the hard drive to PIO mode only, and I have installed Windows XP to that machine with no problems reading from disc (obviously, since Windows XP is installed and running perfectly. ) So it is very unlikely that a problem exists with the drive. Flashing the BIOS for the drive would be fine and I’d try it but I don’ have a floppy drive to use for the process.

So what I’m thinking is that the problem lies somewhere in how Windows XP is looking at the drive, and somehow not allowing it to read data from the disc.

Any help with this would be greatly appreciated!

More about : problem reading data dvd burner pioneer dvr 112

November 24, 2007 12:27:39 PM

The problem has been identified by Pioneer and a fix is available on their web site.

I think that the fix is a new firmware...

Good luck...!
November 24, 2007 1:49:21 PM

You should be able to update the firmware (what you are calling the BIOS) for the drive from within windows. Make sure you change back from PIO to DMA.
October 15, 2008 9:27:02 AM

I have the exact same problem and have tried to update my firmware but it says it's latest version

Any help appreciated
!