radeon x1650 resource issue, need some major help pls!

Well, I got my system build got the board drivers installed and updated, but i have a problem.

My radeon x1650 pro agp card drivers wont install properly/the card cant find enough resources, or so it says, to run correctly.

so, first things:

When i try to use the cd that comes with the card i get an error message saying "Setup couldn't complete. Please use standard vga driver then continue the setup."

not sure wtf that means, but its annoying.


i tried the driver download from the ati site, the one with catalyst in it, it complained abou not having frame work 2.0 (requires sp2 and I have a prescott processor and havent updated my bios yet).

when i use the driver only installer, it seems like its going to work, but after the restart there are no tests and in the device managerit shows a ! by the x1650.

and it has the message of:

This device can not find enough resources (Error Code 12).

Please disable some onboard devices If you want to use this device."

I checked, its on irq 10, and its not conflicting with anything else, but it still says it cant get enough for some reason.

heres what i have right now:




comp specs:

FIC P4-875P MAx mother board
p4 478 socket prescott 3.4 ghz processor
4 gigs of OCZ 3200 ram (3.47 total usable)
apevia beast power supply
Ati radeon x1650 Pro agp
Sound blaster x-fi extreme gamer fatal1ty pro edition
1 dvd/cd rw
1 200 gig 7200 rmp ide hard drive
windows xp sp1

for the life of me i cant get the damn thing to work right, and im starting to think i might have done something tot he card while installing it >.<

please, i really need some help, ati sucks for support as they dont have my card in their product list for some reason -_-.
7 answers Last reply
More about radeon x1650 resource issue major
  1. Try uninstalling the vga drivers,then reboot into safe mode,and then install the drivers while in safe mode.I believe your problem might very well be a driver configuration issue.Do you have an anti-virus program installed?If so that could very well cause the issue.it is also quite likely that SP2 is required for the latest ATI drivers to work correctly.Un-install all video drivers.Install SP2,Then try installing drivers.If it works,great.If not,then go to my first suggestion and boot into safe mode to install the drivers.Keep us appraised.Goodluck.

    Dahak

    M2N32 SLI DELUXE MB
    ATHLON64 X2-5600+
    EVGA 7950GT KO
    THERMALTAKE 850WATT PSU
    2X1GIG DDR2 800 MEMORY
    WD SATA2 80/250GIG HD
    RAIDMAX SMILIDON GAMING CASE
    XP MEDIA CENTER EDITION
  2. alright, then i am going to try flahing the bios to get the prescott issue taken care of, thatnks for the reply!

    ill try that right now before i go to work (the safe mode bit) then the sp2 when i get home if it doesnt work.

    going to keep my fingers crossed in both cases xD
  3. so here is whats going on.

    I think my x-fi sound card is comflicting with my x1650 card.

    I took the sound card out booted and the vid card was perfect, no resource errors of any kind, was able to install the drivers ect.

    i put the sound card back in to install the drivers for it and the graphics card craped out again witht the cant get ehough resources message.

    so, how can i get both the cards in there?
  4. I ould manually set the IRQ'a for your two devices. Or you may have IRQ steering turned of in the BIOS. IRQ steering, if you can even access some sort of option for it, is very important in modern systems.
  5. ok, I have Phoenix award bios, and in the irq settings, i can either set it to auto or reserved, but thats it.

    strangely, my SB live 24 bit card works fine with the x1650, but the x-fi causes trouble.

    I managed to get sp2 installed by using an patch from MS and i got the drivers for the vid card fully installed, but im still having this issue. >:\
  6. more info:

    When ever I have the radeon pluged in by itself or with the 24 bit live, it uses irq 16.

    if i plug in the x-fi it uses irq's 18 or 23 depending on what slot it is in.
  7. alright i fixed the problem.

    what i had to do was uninstall the sound card, **** down, remove it, restart the computer, shut down, put the card back in, boot to safe mode, install the sound card drivers, then restart normally, reinstall the vid drivers then restart it again.

    after all that it finally worked.

    now my only problem is that catalyst control center refuses to operate correctly and i get this error message:

    ---------------------------

    ---------------------------
    Could not load file or assembly 'MOM.Implementation, Version=2.0.2764.39730, Culture=neutral, PublicKeyToken=90ba9c70f846762e' or one of its dependencies. The system cannot find the file specified.
    ---------------------------
    OK
    ---------------------------
    -_-
Ask a new question

Read More

Radeon Components