Sign in with
Sign up | Sign in
Your question

Hard drive will store data, but can't boot OS off of it...

Last response: in Storage
Share
December 2, 2007 8:10:29 AM

In my 8 years as a computer tech I've never came across a problem like this, maybe you guys can help me out...

Well for starters, the hard drive in my laptop died, so I found an old 40GB 2.5" drive laying around, popped it into the laptop, installed Fedora, restarted, wouldn't boot...tried XP, same result.

So I installed the drive in my main machine(not to boot off of, still booted off my regular drive), did an error scan, everything came back fine. Then loaded up 40GB of data on it, all the data remained fine, let it run a couple days periodically checking on the data, no corruption. So I try to install an OS on the drive with it in my main machine, same result, won't boot an OS.

Any ideas?
December 2, 2007 9:04:25 AM

Ah, the dreaded "wont boot no matter how many times i isntall, and yet the data is there" problem


well for me it has happened a few times (i fix computers for a living) and it has always been discrepancies betwen MOBO's bioses and the hard disks

one fine example is a hp computer that came with a 40gb disk, one of those hitachi ones, well after it failed we replace dit with a newer western digital wd800 (80gb) disk

it would jus tnot boot, data was stored correctly but woudl never boot
problem was solved after in the bios i disabled an option "use hdd block prefecth"

in another particular case, an old biostar socket a 7ncg motherboard, was replaced with a new 250GB western digital "white label" hard disk (cheap refurbished) the problem was the same , but the solution came in a tricky way

in auto detect mode, it gave a certaibn number for HEADS CYLS and CLUSTER etc data, shown greyed out below the "auto" setting, but when changing to CHS, it was exactly the same data, and when moving the setting to LBA, it showed completly diferent numbers, manualy set to LBA made the disk boot properly

i hope this helps on your crusade and try out these mehtos and get that bugger working ;D
December 5, 2007 10:08:49 PM

Its not set as a slave is it?
December 6, 2007 6:30:51 PM

I had a similar problem with a 120GB WD drive when i was upgrading from a 40GB. During the WinXP install it wouldn't boot it on the restart. Booted to the 40GB to use the WD disk tools and it worked as a data driver. Then i had the idea to installed linux and had no problem booting. I talked to WD support and they said the MBR must be bad. After the MBR fix didn't work, WD just replaced the driver. The new drive worked(s) fine.

Sorry if this is not much help, but i spent a month trying to get it working when i just should have RMA'd it. You may not have this option, but is your time worth the $45 cost to replace it with a new drive.
Related resources
!