Sign in with
Sign up | Sign in
Your question

Problems with router (d-link dir 100)

Last response: in Networking
Share
May 28, 2008 11:29:01 AM

Greetings and hello to everyone.

I've been using mentioned router (d-link dir 100) for some time already without any problems, but recently I started having some troubles with my connection and I suspect router is to blame. The connection fails every now and then, I cannot open any webpage, and the only way to "repair" that is to reboot the router (I just save the settings - unchanged - through web interface). After that the connection works for some time, but usually not too long (several minutes) before it fails again. When I try to connect directly without using a router everything works okay. I tried to reset and reinstall the router, but it didn't help.

I have some kind of DHCP connection (ISP requires MAC adress), and two computers connected to the router (both have connections set to "Get IP adress from DHCP server automatically).

So, am I doing something wrong? Is there any way to overcome the problem? Or is my router faulty?
May 29, 2008 6:25:18 PM

I would recommend that you update the firmware on the Router. You also should check to see if your ISP (DSL or Cable Modem) are issuing you a private IP address, 192.168.1.x or 192.168.0.x. If your Router is getting an IP address on the same subnet as it is issuing IPs via DHCP, then you will have the same issues you are having. I see this a lot. Hope it helps.
May 30, 2008 7:33:58 PM

Some ISP modems come with a built in router/wireless setup. Friends DSL modem was like this.
If it has the router setup built in all you need to do is get a switch to plug into the router or just turn off dhcp on your add-on router and use it like a switch.
Related resources
Anonymous
December 5, 2009 7:36:50 PM

The DNS relay on this router is completely broken, i figured out. Even so on the latest firmwares, 1.12b etc. It seems the routers' DNS cache bails out. So turn the DNS relay off and it is likely that your router will get stable.
February 1, 2010 5:52:05 PM

I have exactly the same problem.
The router worked fine for a few years, with continuous operation.
All of sudden the DNS relay function is broken. But I had a short circuit in another network device close by. Mayby that fried a chip in the DIR-100.

!