Sony vaio usb ports not working

im not sure if i put this in the right forum topic so if i did please let me know were to repost this.


my girlfriend bought a sony vaio recently, after about a month the usb ports stopped working. ive tried removing the drivers turning the pc off and taking thebattery out for a few minutes, it seemed to fix it for about 5 minutes then it stopped working again. ive tried updating the drivers and bios as well, no usb options in bios and all drivers were up to date. im considering rolling back the drivers but decided to ask for help first lol. if any of you have any suggestions i would really appreciate it.
the modle number is VPCEG3WFX
10 answers Last reply
More about sony vaio ports working
  1. I would have it replaced or repaired because it might be a hardware issue.
  2. install the chipset drivers from the sony vaio support site
  3. AlienTechGod said:
    install the chipset drivers from the sony vaio support site

    Hey Alien, the OP made it clear that had already been tried ;)
  4. so i contacted sony support, the person i had the chat with ended up taking remote access and checking everything, he said there was no hardware problem replaced all drivers and it worked again, for a day or 2, now its broke again. i have a spare version of windows 7, do you think replacing sonys version that came with the laptop would help in anyway?
  5. You have a hardware problem; Sony support just does not want to find it ;)

    You cannot perform a full hardware check from within Windows. For example, you could have bad memory, and the only way you can check ALL memory is to boot up to a CD with memory test software such as MemTest86.
  6. I know this is an old thread, but I might have the answer.

    Go to Device Manager > USB
    Find the Router Hubs at the bottom and go to the Power Management tab in each of them. Unclick the box that says "Allow Windows to turn off this device to save energy".

    I might be paraphrasing, but there are only a couple of check boxes there.

    I then powered the thing off, yanked all cords and removed the battery before restarting. It seemed to work after that.

    Best of luck, Sony users.
    Full disclosure, I did find this n the Sony community forum site, but it didn't work for the OP.
  7. Thank you Professor59!
  8. I had same problem and the only solution worked for me is to disable USB 3.0 option from BIOS
  9. Any instructions on that? I'm guessing you'd have to catch it during bootup and look around for that setting.
Ask a new question

Read More

Drivers USB Sony Vaio Apps