Sign in with
Sign up | Sign in
Your question

Detection delay Mtron SSD with ICH9R in AHCI/RAID

Last response: in Storage
Share
December 30, 2007 5:04:35 PM

Just got myself 2x Mtron MSD 3000 (32GB SATA) SSD disks. Yeah, I know they will cost about a 4th of what they do today in a few months. But I like testing what the future will bring, and had the money ;) 

Ok. Here is the technical setup of my system (the important parts with this issue):

2x SSD products from Mtron:
- MSD-SATA3025 (Firmware: 0.16AR1) (Serial: 2007450000xxx)
- MSD-SATA3025 (Firmware: 0.16AR1) (Serial: 2007450000xxx)

Motherboard/diskcontroller:
- ASUS P5K-E/WIFI-AP (BIOS: 09.01)
- Controller (built-in): Intel P35/ICH9R (ROM: v7.5.0.1017)

The problem/feature is when the BIOS gets to detecting the HD's. Here is how BIOS looks at this stage:

If the BIOS options for SATA is set to AHCI or RAID there will be a 45 seconds detection/delay/hang. This is consistent all the time. After this it continues without problems. Here is the status screen from ICH9R chipset (just after continuing):

I have tried to "reset/default" all BIOS options, and only doing RAID or AHCI:

Still same problem. 45 seconds before continuing. Only way to avoid delay is to set it to IDE. Then there's no delay. Screen looks like this:

I have tried the "SATA Detect Time Out" option when RAID is configured:

Tried 0, 5 & 10. Still the hang/timeout is consistent on 45 seconds anyway. Also made sure machine had been really powered down after setting it. Still same delay.

So for the people with only one Mtron disk, setting it to IDE avoids the problem. But I'm running it in RAID0 to get a boost in performance. Anyone with the same problem ? Any tips ?

BTW: Got 100MB/s read on single MTron disk / ICH9R with HDTach. And with ICH9R at 32K stripe RAID0 I get 180MB/s. I love those results :) 

January 2, 2008 8:52:14 PM

It's probably a low-level driver/firmware issue. I would wager that the motherboard controller is sending a startup command or some other kind of query command to the MTron drives during initialization, and the MTron drives aren't responding to the query. The controller then just has to wait and time out before continuing.

Fixing this would require either a firmware update to the MTron drives, a work-around firmware update to the motherboard controller (BIOS), or a different controller.

There is also the possibility that the MTron drives could be configured to respond properly to this command set and they currently aren't. The configuration might be with an enabling jumper or with a special software tool from MTron.

The people to ask about this is MTron, they would know if their drives have this issue specifically with certain SATA controllers.
January 3, 2008 12:27:09 AM

Get a Raid Card. There are certain cards that have been tested. If you spring for ssd's, get the card.
http://www.dvnation.com/
This site can give you the compatible/tested devices.
January 5, 2008 11:22:14 PM

Sveinan

I have bnearly the same computer config with you with the same motherboard but with 1 Mtron SSD (Though a 16GB one).

My Mtron lags the BIOS by roughly 20 second in AHCI mode. So I'd say your 2 will lag it by around 40 seconds.

This has created a huge problem for me. I have had problems of enabling AHCI mode in my existing Windows Vista and Windows XP installations. Despite trying many of the suggestions and reported working fixes in migrating either Vista or XP from IDE mode to AHCI mode, I have had no succes. (Getting BSOD all the time).

My suspicion is that Mtron's delay and my bootloader being in Mtron had caused various problem. I even begin to think Mtron's support of AHCI is incomplete.

The computer would fail to boot because the BIOS times out and say there is no bootable media. Vista Setup even fails to find Mtron if AHCI mode is enabled.

As a result, I am stuck with IDE mode.
Some people had Mtron and AHCI working fine. So I think the ICH9 on the Asus P5K-E is also partly to be blamed. Though I am not too sure.
AHCI mode should boost Mtron's performance from the 80MB/s ceiling reported by Anandtech.com
January 11, 2008 12:53:00 PM

@Annihilato r-X-

Interesting. I'm not alone then. Although it's not a problem I wish on others. Must admit I never actually tried to install a single Mtron drive in only AHCI mode. I went straight to RAID with 2x. And except for the 45sec delay I've had not a single problem with the installation or the OS (Windows XP, not Vista).

I do have a e-mail/case exchange going with tech support at Mtron. But it has gone 'silent' now for a week. I've sent them all the information I've described here. But if their HD's, especially S-ATA, do not support AHCI, and firmware update requires physical exchange of disks. I expect them to go 'silent', and ignore the issue :/ 

I can live with the 45sec lag. Not perfect, most annoying when first installing the systems (hint: Windows Update, reboot, repeat ...) ;) 

I'll report any updates or progress if I get something from Mtron.
January 27, 2008 3:33:41 PM

Any luck yet? I'm actually in almost the exact situation you are.

* ASUS PK5-E, 2x MTron MSP-SATA7035 (32gb) drive in RAID-0.

Not only am I getting the same boot delay, I can't even get the drives to boot in RAID-0 at all! I'm in the process of troubleshooting right now.
February 3, 2008 1:51:53 PM

Not really any improvements. I did get a new reply from Mtron after my last post. Essentially they said they are aware of the situation, also they seem to have replicated it. They are working on it, but have no solution at the moment. As told, I can live with it. It's the reboots when doing the initial OS installation that is a pain.

Over to your RAID-0 problems. Your motherboard is 100% identical to mine (except the WiFi). So guess the disk chips/controllers are the same. Only difference then is really that you got the Pro vs Mobi editions from Mtron. All settings in BIOS is described in post above. Other than that, think i connected the 2 disks to SATA1 & SATA2 on motherboard. Configured the 32K stripe. I am using Windows XP as OS. One 'special' thing I did was using NLite (http://www.nliteos.com/) to slipstream SP2 and the RAID/AHCI Intel Matrix Storage Drivers 7.6.0.1011 into a new installation CD (don't have a floppy for XP/F6 disk drivers). Thats about it. After that it all went in without problems. Except the BIOS boot delay :/ 

PS: Have tried latest BIOS 10.02 from ASUS. No difference.
February 3, 2008 2:49:03 PM

Thank you for the suggestion to slip stream. My problem first occurred when trying to install Vista onto a RAID-0. Vista won't recognize the drives in raid-0.

Since my last post, one SSD is in the process of being exchanged. Mtron believes the drive was faulty. In the mean time, I imaged my current install of XP Pro to a single SSD with my data on another set of mechanical HDs in Raid-1. Therefore, the ICH9R is in RAID mode in the bios. Even though the SSD is not raided, with the southbridge in RAID mode, HD Tach is reporting 112.8MB/s on average for the single SSD. No 80MB/s cap as had been reported elsewhere. Most interesting, there isn't any of the above mentioned boot-up delay either.

I noticed Mtron.net has a firmware update utility for the 7000 series drives. However, its not available at the moment. Hopefully that bodes well for the future.
February 3, 2008 6:34:31 PM

Lets hope it was just a technical problem with one of the drives. Would probably be the best outcome. Interesting result with the 'no delay' through RAID BIOS, but no disks in RAID. Guess it might be that in this mode AHCI is not active or something.

And thanks for the tip about the 'revoked' firmware utility on Mtron's site. That little entry passed me by. Will now keep a watch and see when it is reposted. Just hope that my Mobi disks are firmware upgradable through software, and not only the Pro models.

112.8MB/s in absolute silence :)  Just wait until you double that ;)  Problem is, when you eliminate both sound and seek, you find the next thing making noice in your PC case. Also you realise that the boot process in XP/Vista is not that efficient, and that it's probably components/modules with timeouts/startups and so on that makes up much of the wait. The painfull road to progress :p 
February 11, 2008 8:39:12 AM

The firmware updates on the site had been pulled out for 2 months. I am not too sure about that.
Mtron staff had told me AHCI is not supported on my Mtron Mobi drive, which is weird because other sites had it working fine.
e.g. http://forum.tabletpcreview.com/showthread.php?t=11666
My best guess it's something to do with the motherboard.

Well to be honest I am happy with the IDE mode because of the non-existent detection delay. 80MB/s vs 100MB/s I don't really mind. Trying to get AHCI to work in Asus P5K-E is too much of a pain.

The boot up time of my Vista is around 40 seconds including login. The Vista load up bar loops for 7 iterations. It doesn't sound fast, but I have seen how Vista loads up in other machines.
February 24, 2008 6:22:07 PM

I finally got my drive back. Configured in RAID-0 with Windows Vista as OS. Installation was smooth; no issues other than the boot delay. Once booted however, OS and apps are quick/instant! HD Tach doesn't work in Vista, but booting from another drive into XP, I got 141MB/s to SSD RAID-0.
March 5, 2008 1:46:07 PM

Hi Guys, happy to find this thread..

I think it is not only a Mtron issue.

I am building Workstations with SSDs from different (as far as they have different brand names) manufacturers and on different boards (MSI/ASUS) and as soon as they are connected via SATA, it is a nightmare.

if they are detected or not depends maybe on weather or I don't now

I changed then to SSDs with IDE interface and they work and boot like a charm.

Explanation --- none unfortunately

I hope the next BIOS releases of MSI and others will fix that
March 5, 2008 2:20:52 PM

Technically the Mobi 3000 drives are not supported in raid and will cause this problem. I have done testing with the Sandisk, Samsung, and mtron drives. I have had best luck with the Sandisk ones as they seem to heave the best firmware so far of the ones I have tested. The Mtron 7000 series are raid ready and dont seem to have that same problem but they are more expensive. I have not had a chance to do any of my own testing with those yet. I did testing using the on board controller and with an Adaptec 31605 SAS/SATA controller.
March 6, 2008 8:17:44 PM

Well. It may be that Mobi 3000 is not 'supported' in RAID officially. But all the marketing and hype surrounding SSD in general is a lot about 'pure' 2x 3x performance when RAID-0. Especially in the desktop sector. PcklTckle in this thread have the Mtron 7000 models and gets the same problem. The problem also happens with a single Mobi 3000, when set to AHCI mode.

I've never had this problem with normal mechanical drives (Seagate, Hitachi, WD). Now, I cannot be sure if this is the fault of immature firmware on the Mtron disks, or BIOS support/tweaking from motherboard producers (like ASUS). But I don't care. If I were a consumer with zero technical experience of computers. Reading about this fantastic SSD technology. Then buying these disks at a premium. I'd sure expect them to work as equal to normal mechanical harddisk. Not getting my experience destroyed by compatibility issues on the communication/interface side.

Enough ranting from me ;)  As said, except for the delay, it's working 100% for me.

BTW: @PcklTckle
See you get 141MB/s on RAID-0. One tip. I tried different stripe sizes, and ended up with the 180MB/s with 32K stripes. Of course this will vary with what combination of OS / HD controller / drivers. But you might try to vary it to check what works best.
March 13, 2008 5:21:00 AM

Hey, I'm using 2 Mtron Mobi SSDs under ASUS P5B-E and they works just fine.

I connected them to Jmicron SATA ports and there were no delay, and no other problems said above.

I was surprised that Mobi has RAID problem, because I'm currently using it!

March 13, 2008 9:43:06 PM

Thats an idea I hadn't though of. Using the JMicron JM363 controller to test out RAID through that. Looks a little unpractical though. I see the JM363 controller on ASUS P5B-E is wired for one internal SATA port and one external eSATA on the backplane. How do you connect the 2nd disk in RAID ? Through eSATA to SATA cable through PC case ?

Would be even more unpractical on my motherboard (ASUS P5K-E/WIFI-AP). It has the JMicron JM363 controller wired to 2x eSATA on backplane. No internal ports. Also this solution is limited to 2x RAID-0 SATA. No chance for 3x.

But thanks for the tip. Although we still have the problem with ICH9R controller in AHCI/RAID.
April 9, 2008 8:21:05 AM

Good news. I got an early copy of a firmware a few days ago from Mtron. It is supposed to be released to the public in a week or two. It fixes a few things, among them the detection delay on Intel ICHxR chipsets.

I have tested this firmware against my disks and can confirm that it solved the delay with my ICH9R in RAID mode. Firmware on disks went from 0.16R1 to 0.17R1.

When it comes to more info. I'll leave that to Mtron when they release details on their web site. But got to give them credit for solving the problem.

NOTE: When the upgrade gets here, read the upgrade instructions, and follow them !
May 13, 2008 6:56:15 PM

Just discovered the new firmware was posted, but getting an HTTP 404 for the guide. Can you post the instructions?
May 31, 2008 6:24:51 PM

Hi,

I am also having those 45 seconds per drive detection delay on an P35+ICH9R motherboard (Gigabyte EP35-DS3P) with 2x Maxtor DiamondMaxPlus9 SATA150 hard drives in RAID0 mode.

Except these 90 seconds delay on each boot/reboot (starting to get annoying) I have no other problems at all, system is running nicely.

I get excellent R/W performances on that RAID0 array under windows XP by the way (it's my system drive).

I dont think I will contact Maxtor to get a firmware update for my drives as I might lose my RAID0 array in the operation*, but if annyone has another work-around...

Thank you ;) 

*not sure about that, but last time I had to upgrade a HDD's firmware, I remember seeing several "backup all of your data before upgrading"
November 1, 2008 10:13:00 PM

Anyone tried to update to the latest firmware v18? I successfully updated to v17 previously, but now that I'm trying to update to v18 I'm getting an "FW Update Failed" error.
!