Sign in with
Sign up | Sign in
Your question

EMM386 Hangs my netbook

Tags:
  • DOS
  • Apps
Last response: in Apps General Discussion
Share
May 19, 2012 2:46:08 AM

I've been gaming in DOS since I was a kid. Had my last 486 about 6 years ago, and DOSbox just doesn't cut it for me. Virtualbox was nice for a while, but I wanted to boot into real DOS, not an emulator or virtual environment.

I found out the other day that with Qemu I was able to point to a physical drive to use as my virtual hdd. I decided to try installing FreeDOS onto my SD card, and fought with disgustingly slow installations, programs not being installed and an inability to actually boot from it (not a problem when using a linux liveusb, or in my case, live sd card).

So, almost thinking I was hosed, I thought I would try IMGing my DOS 6.22 install disks and try it just for giggles. I didn't think it would actually work! It installed just fine, and what's even better is the card is bootable. Instant DOS system anywhere I go. My only problem with it so far is memory. It will detect up to 64Mb of RAM, which is more than plenty, but for some strange reason, no matter what configuration I've tried, which memory addresses I include or exclude, EMM386 hangs my system. I tried to use JEMM386 and JEMMEX with worse results.

I thought there might be hardware issues, but I didn't think my biggest hurdle so far would be upper memory blocks and expanded memory.

Any Ideas?

More about : emm386 hangs netbook

!