Sign in with
Sign up | Sign in
Your question
Closed

I can't install Catalyst anymore

Last response: in Graphics & Displays
Share
September 18, 2007 11:06:06 PM

I just got back a new video card of Radeon X1650 because my old one broke and now I went to install Catalyst again. I went to add/remove programs and took it out. Then I downloaded it again and installed it and I got this message.

"Another version of this product is already installed. Installation of this version cannot continue. To configure or remove the existing version of this product, use Add/Remove Programs on the Control Panel."

I did use add and remove programs after unsuccessfully installing it and then I reinstalled it again and it still said the same thing. I can get the driver but not the Catalyst to work. How do I fix this?
a b U Graphics card
September 18, 2007 11:08:30 PM

Use Driver Cleaner Pro.

Follow instructions and should be ok.
September 18, 2007 11:09:55 PM

Where can I get that? Never heard of it before.

Do I have to pay for it, because I do not want something that I have to pay for.
Related resources
September 18, 2007 11:18:17 PM

Here's a hint.
September 18, 2007 11:34:57 PM

Grrr!!! :fou:  :fou: 

This making me very angry. I used that Driver Cleaner Pro thing and that still didn't fix it. I still get the message. I have restarted 50 damn times already and I'm sick and tired of it!!!!!! :fou:  :fou:  :fou: 

And Anoobis, what are you talking about? I don't take spam for an answer!!!!! :fou:  :fou:  :fou: 

Someone, please help me!!!
September 19, 2007 12:05:08 AM

UPDATE:

Ok, so I did an indivisual uninstallation with just Catalyst and nothing else and I reinstalled it without that error. After it tells me to restart, I do so but then I get something else. This time it says "You do not have permissions to change Catalyst Control Center settings. Please contact your administrator for further" or something like that.

First of all, I am the administrator, I installed the program myself, so I should have rights to that program, what's going on?
September 19, 2007 12:41:01 AM

Maybe try unistalling it is safe mode, Probably wont do squat but might get lucky.
September 19, 2007 12:51:32 AM

I don't think that worked either, I think I did something like that last night.

You can't seem to install drivers in safe mode regarding ATI, said it wouldn't let me.
September 19, 2007 1:31:52 AM

Did you follow the uninstallation process with Driver Cleaner?...Uninstalling the catalyst package with "add or remove programs"...Then restarting right into safe mode. Cleaning the drivers then restart as normal. Run the installation package and install..Restart...should work.
September 19, 2007 1:53:39 AM

If you still haven't gotten it, Anoobis is hinting at using Google.

Otherwise others have given good advice, follow it and report back.
a c 130 U Graphics card
September 19, 2007 2:13:26 AM

If you're still having problems, try the following steps:

1) Download the latest Microsoft .NET Framework 2.0
2) Install .NET Framework 2.0
3) Download the latest drivers from AMD/ATI for your card
4) Reboot your system into Safe Mode.
5) Open Control Panel's Add/Remove Programs
6) Remove the ATI Software Uninstall Utility (this runs the programs and *should* remove all installed software.
7) Reboot your system, allowing it to boot normally.
8) Windows *should* prompt you with New Hardware Found prompts. Cancel these.
9) Install the graphic drivers you downloaded in step 3.
10) Reboot your system.

If these steps fail, then you should attempt to run driver cleaner as step 6.5.

Hope this helps

-Wolf sends
September 19, 2007 3:40:54 AM

After you "Remove" in Add or Remove Programs have you gone to My Computer_Local Disk (C)_Program Files_ATI Technologies ?

The ATI Catalyst Control Center folder is in there or should be if it is still installed. Also an .exe folder _"Uninstallall".

If this helps great if not keep trying.
September 19, 2007 5:35:24 AM

I don't care if you don't take spam for an answer. I don't either. I gave you a hint on how to find Driver Cleaner Pro. It's not hard to figure out and lo and behold you found it somehow.

Wolfshadw is definitely on track, but try here?:

http://support.ati.com/ics/support/default.asp?deptID=8...

Make sure to uninstall all ATI software.
a b U Graphics card
September 19, 2007 6:37:32 AM

Go through your registry and delete all ATI related stuff, but export your registry first just in case ;) 

Actually before you try that, maybe go to the device manager and uninstall the device in there, if it is there.
September 19, 2007 7:15:53 AM

DSM86 said:
UPDATE:

Ok, so I did an indivisual uninstallation with just Catalyst and nothing else and I reinstalled it without that error. After it tells me to restart, I do so but then I get something else. This time it says "You do not have permissions to change Catalyst Control Center settings. Please contact your administrator for further" or something like that.

First of all, I am the administrator, I installed the program myself, so I should have rights to that program, what's going on?


Are you using Vista by any chance?

I had this same message after my install of Vista and the only way around it was to reinstall Vista after a bios update for my mobo.
a c 130 U Graphics card
September 19, 2007 9:11:02 AM

Are you by any chance trying to install version 7.9 we had a thread on here at release time quite a few people had probs with it i personaly gave up and reinstalled version 7.8 :) 
Mactronix
September 19, 2007 9:58:31 AM

This problem has been around in catylyst for years. I've had it loads of times on loads of different systems. At one point I had it with every new release. I would even get a hard crash on boot.

Remove everything including ATI unistall utility and delete any ATI related files. Then download an old version of Catylyst like 6.9 or before nothing after 7.0. They are on the website find them yourself. This might work certain versions work and some don't.

I tried driver cleaner and every other way to sort it out but the problem will never go away.

There is one guaranteed way to remove this problem. Format and reinstall windows with the new card plugged in. Then you can instal the latest catylyst. The problem will never come up again until you change the graphics card again.
August 19, 2010 10:03:16 AM

1745904,1,294843 said:
I just got back a new video card of Radeon X1650 because my old one broke and now I went to install Catalyst again....quotemsg]

Hi there,

My video card is Sapphire HD 4830 512 MB. I went to update the installed Catalyst with the newer 10.7 version. I have tried a lot of different methods without any success for example: went to add/remove programs and tried tooking it out; started the update setup file and tried to uninstall it ,but both ways I got an error message.
"Another version of this product is already installed. Installation of this version cannot continue".
I did use add and remove programs but unsuccessfully

Solution: Start -> Run -> msconfig -> startup

and disable any ATI/Catalyst components. Reboot and run installation setup file again. Result -> Installation complete.

P.S. Be sure BOOT protection mode on the motherboard is NOT active and the option to boot drivers for display from sleep mode (S3) is disabled.
a c 271 U Graphics card
August 19, 2010 10:07:35 AM

!