Sign in with
Sign up | Sign in
Your question

ati2dvag Blue Screen problem

Last response: in Graphics & Displays
Share
September 20, 2007 11:42:28 AM

Hey Tom's forums!

A while back some people on this forum gave me some very good advice when i wanted to upgrade my graphics card.

I purchased a Sapphire Radeon X1950 PRO 512MB card, and i love it.

Yesterday, i wanted to upgrade my Catalyst driver (Maybe i was missing out on sweeeeet new features :kaola:  )

After removing all my old ATI software with Add/Remove programs, i installed the newest catalyst drivers (7,9).

All seemed good, and i rebooted. Just when the log-in screen usually appears, i get a BSOD ( Guessing when it loads the driver).

The error tells me that "ati2dvag.dll" has started an infinite loop, and that i need to reboot in safe mode to fix the problem.

I googled around, and i can find no solid solution for the problem.
What i tried:

Uninstalling with Driver Cleaner (in AND out of safe mode)
Installing Catalyst 7.5-7.9

Any will be much appriciated.
September 20, 2007 11:45:04 AM

Oh, and i'm running Windows XP with SP2.
September 20, 2007 11:47:37 AM

Uninstall it again, then in safe mode use driver cleaner pro and select ATI. This hopefully will get rid of all remaining ati files, and you may be able to install an older version (or have another bash at 7.9).
Related resources
September 20, 2007 11:50:57 AM

I'll give it another go,and report back.

Thanks for the reply, blade.
September 20, 2007 12:18:53 PM

After removing everything in safe mode, i rebooted and installed the 7,9 drivers. Now i get no signal at log-in.. Any other suggestions?
September 20, 2007 2:38:03 PM

and this was using driver cleaner pro aswell?

maybe you should just use an older version of the driver (the one you were using before all this issue)

September 20, 2007 3:32:14 PM

This was using driver cleaner pro aswel, yes.

I would go back to my old driver if i remembered wich version it was. But chance is, i already tried. Since i tried installing every driver down to 7.4, i'm sure i have had my old version installed, even tho i don't know wich one.

It's something permanent, "stuck" in the system. Driver cleaner is supposed to clear it all, so i really don't get it.

I googled around some more, and found that the service that fails (ati2dvag.dll) is part of ATI's SMARTGART application. Supposedly, it checks the compatibility of various AGP functions (Fast Write, AGP x4/x8) on startup. I tried disabling SMARTGART in my services.msc, but no luck.

Think i should post this in the graphics forums, aswel as just the ATI subforum?
September 20, 2007 4:53:25 PM

Solved : After doing a VERY deep search for everything ATI on my harddrive, and rolling back to 7,4 (one version lower then the ones i tried so far) i can now boot correctly.

Odd.
September 20, 2007 7:10:09 PM

lol

i say you stick with it...till the another driver comes out
September 20, 2007 7:59:21 PM

nobel said:
Solved : After doing a VERY deep search for everything ATI on my harddrive, and rolling back to 7,4 (one version lower then the ones i tried so far) i can now boot correctly.

Odd.


May also want to make sure you have your motherboards latest chipset drivers, specifically, the agp drivers. I would suggest getting the latest drivers that the motherboard maker has on their website as opposed to getting the latest drivers from the chipset maker.

I haven't had any luck with anything newer than the 7.1 Catalyst drivers myself. Omega drivers and ATI Tray tools haven't helped either.
!