Sign in with
Sign up | Sign in
Your question

Photoshop very laggy!

Last response: in CPUs
Share
September 6, 2007 11:33:49 PM

Specs:
q6600
vista HP 64bit
8800gtx
4gb RAM
150g Raptor

When I am on photoshop CS3 extended it becomes very laggy doing the simplest of things I will get a paint brush to like 200px and make a stroke and it will lagg badly. Also when I just click on paint brush I will sometimes get the loading circle for a few secs. I will look at taskmanager and my cpu usage and it will use 100% sometimes. Also I will look at cpu-z and it goes from like 1.5 I forgot the actual number to 2.4 in like for a little then back. Like I will do a laggy brush stroke and right after it is done it will go back to 1.5. Is it just a vista problem or what. I can't believe my computer will lag so bad :cry:  I am sad. Please help!

More about : photoshop laggy

September 7, 2007 2:36:42 PM

But still even if it is only 32bit I don't think I should be lagging like this. BTW thank you for your reply.
Related resources
September 7, 2007 2:41:08 PM

Try disabling your page file, you have enough RAM.

PS - Your system kicks complete ***
September 7, 2007 3:54:40 PM

After searching around for a while, I caught wind of it being printer related, more specifically the printspooler service in windows. I had recently moved and not hooked up one of my networked printers. After removing the offline printers (and printer that was trying to connect but would time-out) Photoshop opened files and created new ones with a snap!! I’m very glad to have resolved this issue, it was getting very annoying having Photoshop lag on a Quad Core system running 4gb of DDR2 on a Rapter! Anyways, glad to have it cleared up! For anyone out there having this same issue, remove any offline printers or ones that cannot connect!
September 8, 2007 3:26:39 AM

Ok I have network printer sharing off on my network and sharing center. I don't have any printers connected to my pc right now. Also is disableing pagefile possible on just photoshop or do I have to turn it off completely.

PS: thank you so much for your help and thanks for the complements!
September 8, 2007 4:59:10 AM

antonwalker said:
Ok I have network printer sharing off on my network and sharing center. I don't have any printers connected to my pc right now. Also is disableing pagefile possible on just photoshop or do I have to turn it off completely.

PS: thank you so much for your help and thanks for the complements!


With four gigs I really think you can totally disable your pagefile through windows. If you encounter problems just re-enable it.
September 8, 2007 8:26:50 PM

Ok I think I remember seeing how to turn it off, but I forgot so where do I go?
September 8, 2007 8:29:57 PM

I think I found it I went to system and on the side it said advanced system settings then I go to the advanced tab and then go to performance and then it shows virtual memory and you can open it and it says automatically adjust virtual memory and you can check yes or no and if i check no I can turn paging off. So is that what I do??


Also in that same general area it says allow romote access and it is on, do I want to turn that off for security.
September 8, 2007 9:57:21 PM

Yes, turn remote access off, it's useless.

I don't think disabling virtual memory is going to do a thing for you, but... you simply turn paging (virtual memory paging) off.
September 10, 2007 4:29:47 AM

Any other ideas???

Anyone??
September 11, 2007 10:58:41 PM

Also I dont know if this has anything to do with photoshop being laggy, sometimes when I am playing a game I will get an error message that says bla bla bla has stopped working windows is looking for a solution. After a few secs it will say windows has not found a solution then it will ask to close program.
September 18, 2007 12:56:55 AM

Redline24, you're very wrong, remote desktop is extremely usefull if you know how to use it :) 

As for the OP, don't turn off your pagefile, set it to at least 1GB, just because you "think" you have enough ram doesn't mean Vista thinks you do. Your ram will be used before your pagefile anyway.

Best to kill any unneeded process' first, disable any service you don't need including the print spooler. Then see how it runs. Also make sure your scratch disk is on another drive, not partition. PS3 won't take advantage of Vista or XP 64, but it runs perfectly fine as a 32bit app.

I run PS3 on two Athlon 64 3700+'s with 2GB of ram and RAID 0 Raptors, never once have I had a slowdown with either machine. My wife and I do a LOT of editing with 6-10 megapixel images, my wife regularly has 20 or more images open at any one time.

Let me know if you need anymore help!
!