Sign in with
Sign up | Sign in
Your question

Norton Ghost changed my drive size

Last response: in Storage
Share
January 29, 2008 3:17:03 PM

I bought a new 250GB Western Digital Scorpio SATA laptop drive. I used Norton Ghost 10.0 to copy a partition in order to use this drive as a replacement in a laptop. I verified that Ghost did correctly identify it as a 250GB drive. I selected the options to resize the partition to make full use of the new drive, and to copy the MBR. The partition was successfully copied, but the size of the new drive can only be recognized as 99GB (the size of the original drive that was copied.) The system BIOS will only recognize this drive as 99GB, and any disk utility software I try will only recognize it as 99GB (WD Data Lifeguard Tools, Norton Partition Magic, Acronis Disk Director, DBAN, etc.) Basically, I have not found a single tool that will recognize this drive as anything more than 99GB. I have tried the drive in two computers (a laptop and a desktop) with the same results.

Any suggestions?
January 29, 2008 4:27:28 PM

I had this same issue when trying to upgrade my wife's laptop hard drive from an 80* to 200 gig drive. The problem for you isn't norton ghost, it is the MBR of the computer itself. In my case, the MBR was set up for the main drive, and then a hidden partition that held Dell's little programs. Instead of writing their software to put this partition at the end of whatever drive is in the computer, say the last 5 gigs, they wrote it to put it at 75 Gigs*, and take up the rest of the space on the drive.

On the original drive, that was 5* Gigs. On my new drive, that was 125 Gigs...which is stupid.

I tried everything to get it to work properly, and there is a workaround, but it risked destroying all your data if you goofed, and I wasn't willing to do that. In the end, just format the new drive, and start from scratch. You won't be able to clone this drive and have it work properly. My wife was in the hospital at the time and I had an entire week to screw with it trying to get it to work. It isn't worth your time.

Now, to answer the rest of your question, I had a Hitachi drive, and there is a tool on the Hitachi website (called Feature Tool, if I remember correctly) that you burn to a cd and boot to. It will allow you to reset the drive size to the factory default (and correct) value. Now, you have a WD drive, so I don't know if it will work for you. WD may have a similar tool on their site.

http://www.hitachigst.com/hdd/support/download.htm

Good luck!

January 29, 2008 5:46:06 PM

Thanks for the reply. I've had that same issue you had with the Dell restore partition a few years ago, and I know this isn't the same problem. I've tried a low level format with a couple different tools, but all will simply do a format on the 99GB that is recognized by the BIOS. I was hoping there would be some tool from WD to "reset" the drive, but if there is, it's not available on their support site.

I'm still waiting on a reply from WD. If I don't get this fixed by Friday, I'm going to try and return it to Best Buy.
Related resources
a b G Storage
January 29, 2008 5:58:34 PM

Go into computer management->Disk management and report back to us the partitions that are there and the size.
Norton Partition Magic and Acronis Disk Director can change the size of your partition if there is free space available. Paragon also has software for managing partitions.
January 29, 2008 6:13:54 PM

One partition - 98.71GB. No other free space is recognized by any application, including Partition Magic or Disk Director.
January 29, 2008 6:42:32 PM

same thing happened to me, drive size went from 250 to 80(original drive size). I think i was using Casper. I'm not sure if there's a way to ghost a drive and retain the larger drive size. If there is, i'd love to hear about it. In the end, i had to just start from scratch, new windows installation, the whole shebang.
January 29, 2008 8:45:55 PM

Sounds like the hard drive has been software-resized to 99GB. There is a freeware tool that can unlock and size a drive back to the proper size, it's called HDAT2.

http://www.hdat2.com/

See if this will reset the drive size back to 250GB.

If it does, copy the partition using Partition Magic instead of Ghost, and then re-write the MBR by booting a Windows XP CD to the recovery console and using the fixmbr command.
January 29, 2008 9:14:51 PM

When I re-wrote the MBR using fixmbr, it wouldn't load into windows.

Sorry I couldn't help. Hopefully you get it figured out.
June 15, 2008 11:48:37 AM

I too had the same problem.
Dell Inspiron 6400 laptop supplied with 100Gb HDD.
Ghosted drive like i have done many times without issue. Only this time i was porting stuff to a new 250Gb Seagate drive, rather than restoring to the same drive.
Restored with Ghost and no luck - Windows XP not only stopped at mup.sys (which I discovered in Safe mode), but my drive also started showing up as 98Gb in the BIOS once I booted Windows for the first time.
After spending the whole day reloading stuff over and over and scouring the net to find info about mup.sys and what might be the cause, etc - I now have a solution :)  .

1) Ghost/clone drive
2) Swap drives and load image onto new drive
Make your NTFS partition large enough to fill the rest of the drive if you have a Dell laptop (i.e. the diagnostic and Dell restore partitions stay where they are - at the front and end of the drive)
3) Check BIOS to see if size matches drive size - probably won't if you have tried to boot Windows already
4) Use the Hitachi software mentioned earlier in this thread to reset the drive size if its not correct in BIOS.
The HDAT2 software could also pick up the size discrepancy but didn't allow me to reset the size.
5) Load Windows XP disc - start Repair mode
6) Chkdsk /p
I found errors on my disc. Retry till you have none.
7) Fixmbr
8) Fixboot
Which I threw in for good measure.
9) Load up windows - Voila! :bounce: 
Got a message that Windows had finished installing new hardware and that I needed a reboot. Reboot completed and seems to run smooth so far.
!