Sign in with
Sign up | Sign in
Your question

Can't access USB storage devices in VISTA

Last response: in Windows Vista
Share
February 11, 2011 11:15:17 AM

I have windows vista and my USB storage devices are not working anymore. They use to work fine, now nothing. The devices are recognized and the drivers are up to date. When I go to open the device to access the data a window pops up that says the device needs formatting. I've tried using different devices on different ports and nothing works.

I can access the thumb drive from another computer so I know that it's not the USB thumb drive that is the problem. There is something wrong with my computer where it tells me that I need to format the drive in order to open it. I've tried three different USB thumb drives on different ports of my computer and each time it says that needs to be formatted.

The drive I'm trying to access worked on my computer sometime back and now it does not.
I am able to access the data on my thumb drive by going through a different computer so getting the data is not the problem. It's getting my computer to open USB mass storage again.

Any help is much appreciated.



February 11, 2011 11:55:49 AM

Is your vista install completely up to date? And what filesystem are these usb keys using? Dont double post.....it just looks bad.
m
0
l
February 11, 2011 12:03:08 PM

wanamingo said:
Is your vista install completely up to date? And what filesystem are these usb keys using? Dont double post.....it just looks bad.


Yes, VISTA installed up to date. FAT32.
m
0
l
Related resources
February 11, 2011 12:06:03 PM

Try this to uninstall all USB drivers, even if they are up to date they still might corrupt.

Click Start, click Control Panel, click Performance and Maintenance.
Click System, then click the Hardware tab.
Click the Device Manager button.
Expand Universal Serial Bus controllers.
Click the right mouse button on every device node Serial Bus Controllers, then click Uninstall to remove them one by one.
Restart the computer and then reinstall the USB controllers.
Connect the USB storage removable, then test to verify that the problem is solved
m
0
l
February 11, 2011 12:11:52 PM

I already tried by uninstall all USB drivers and restarted computer. But still having the same problem.
m
0
l
February 12, 2011 9:12:28 AM

wanamingo said:
Alright... try the steps at this site http://social.technet.microsoft.com/Forums/en/itprovist...


Hi, while searching for this issue some where I read that to start computer in SAFE mode, uninstall USB ports and restart computer. I tried this and it seems okay now. Thank you very much for your help.
m
0
l
!