New system build.. mobo wont post

Hi, just here to get a bit of assistance with my new DFI Blood Iron.

Basically, i built a system a week ago using a msi p35 neo-fr, everything ran 100%, but i decided i wasn't content w/the OCing of the board, so i purchased the DFI -BI and transferred everything over lastnight, but when i tried to boot, nothing would startup.. only two amber lights show on the board.. 1 near the power connector, 1 near the expansion slots.. any idea what to do?

I backtracked, taking things out one by one until i got down to just having the psu and cpu hooked into the board.. still the 2 amber lights only and no powering up.. i also reset the cmos jumper on the board(not the backone though) and even popped the bios battery to no avail.
2 answers Last reply
More about system build mobo wont post
  1. To cover a basic but often overlooked step, did you put in the 4 pin power plug for the CPU?
  2. yeah, i tried the 4pin and 8pins(psu has both, (mb takes both).. ill try again when i get home, maybe i had em backwards or something
Ask a new question

Read More

Motherboards