Sign in with
Sign up | Sign in
Your question

Hard Drive letter ordering

Last response: in Systems
Share
September 8, 2007 9:30:43 PM

I got a nasty virus and had to reinstall windows, but the drive I want to put windows on keeps showing up as letter E. I have three HD's, two IDE's (one ancient one that I should probably throw out, gotta be 7-8 years old :pt1cable:  ), and one sata. Of course I want to install windows on the SATA. The partitions on the IDE's are the oldest. So basically what I want to know is, how does windows/bios decide what partition gets what drive letter?

Thanks, if you need more specific info just let me know what.
September 8, 2007 9:40:47 PM

hmm, There's two ways you can go about this. The shortest way is...

Install windows on the sata. When windows is all up just go to "My Computer" on your start menu, right click it and select Manage. Click on Storage in the right window pane, then select Disk Management. Here you will see your sata drive, as E. Right click it and select "Change drive letter and paths" and see if it'll let you change the lettering.

Second method is to see if you have a version of windows installed on that old IDE drive (either another XP, or something older)? This may be causing your lettering conflict cause if you do have a windows installed on that drive, it already has the C: drive letter taken. I'm assuming the newer sata drive is clean and has nothing installed on it (especially another verson if windows cause if it does it is also causing the lettering conflict). Here's what i'd do. Disconnect all the connections you have connected to the IDE drive, from the IDE cable itself (so the mobo won't detect it) to the power cable. Only have your sata drive connected and powered. You can still have the IDE physically in the case but just dont hook it up. Boot up your PC and if this sata drive is new and has not been formated yet windows should, by it's own default, assign windows to be installed on C: instead of E:.
Related resources
September 8, 2007 9:47:55 PM

If none works you can see if the methods mad-dog sent works.
September 9, 2007 9:36:24 PM

You're best bet is to disconnect the 2 IDE drivers and do a clean install on Windows on the SATA. Once Windows is installed reconnect the other drives. Windows installing on other than the C drive generally occurs with there is more than one drive in the computer during the installation. I don't think you can change the drive letter where Windows is installed.
September 10, 2007 7:44:09 AM

OK thanks for the info. That's what I did the last time (unplugged the IDE's). Just didn't know if there was an easier/simpler way of going about it. Guess not, ah well whatever works :) .
September 10, 2007 9:33:04 AM

There is an other way, I had a similar problem.
You go start->control panel->administrative tools->computer management; then you go to the disk management tab
select the disk for witch you want to change the letter an right click, and select change drive letter and change it, that is it
a b B Homebuilt system
September 10, 2007 10:01:59 AM

svileni said:
There is an other way, I had a similar problem.
You go start->control panel->administrative tools->computer management; then you go to the disk management tab
select the disk for witch you want to change the letter an right click, and select change drive letter and change it, that is it

I've done that several times and works every time for me. It's the easiest way to do it.
September 10, 2007 1:06:02 PM

Out of curiousity....What possible difference does it make what the drive letter is.....as long as it boots the way you want it to?
September 10, 2007 2:08:44 PM

It's easy to change a drive letter if the partition does not contain the
active boot windows installation. Otherwise changing the windows drive letter where your windows is
install on requires registry editing and most of the time it just corrupts the
entire OS.

How to change the boot drive letter


If you have a card reader unplug that because sometime it's those
that can be causing the problem.
September 10, 2007 2:47:52 PM

Depending on your motherboard you may be able to disable the IDE's temporarily using BIOS settings...
September 21, 2007 2:01:10 PM

or....change the boot order in the BIOS itself
!