ICH9R hangs in BIOS

I have a problem with my ICH9R. Setting up the array and installing Windows works fine, but whenever the system restarts the raid-bios hangs after detecting the first 3 drives allthough it reports 4 drives is connected. The cursor blinks and the the system will restart with ctrl-alt-del. I have 4 x WD-5000AAKS in raid-5. (Raid-0 gives the same result.)

Since the raid-bios hangs I can not enter BIOS or either of the other configs (2 x sata onboard controller (ctrl-i, ctrl-g)or network)

The only way to get the system going again is to disconnect the failed drive. Connecting the drive to any other port on the ICH9R will not help.

To fix the array I need to connect the disk to another controller and format the disk (or erase it completly with Western Digital Dignostics tool). Now connecting the formated drive to the array I can add it back to the raid-5 array. It will rebuild just fine, but restarting will hang the bios and the cycle continues. Argh!

Testing the drive with Western Digital Dignostics Tool (full scan and SMART) gives the thumbs up.

Any idea on how to resolve this?
4 answers Last reply
More about ich9r hangs bios
  1. Good advice zpyrd, men thats not the case as the drive isn't properly detected and hangs the BIOS. I am not able to enter det BIOS with the failed drive still connected.

    Formating the drive on another controller fixes this as I wrote earlyer.
  2. First: Thank you for such a comprehensive reply!

    Second: All in quote is correct.
    Quote:
    From what you have posted I have gathered you can boot into Windows with three drives attached?
    When you add the fourth drive all is ok?
    While in Windows you can rebuild your array with four drives attached?
    When rebooting after rebuilding the four drive configuration the BIOS hangs while identifying the fourth drive connected?


    Yes, I'm using Intel Matrix Storage, latest edition, but no, I have not upgraded BIOS yet.

    Motherboard is P35-DS3P with Q6600. There are 6 sata ports on the ICH9R controller. I use port 0-3. I've tried other combinations as well. Nothing else is connected to the ICH9R.

    Since this is a new computer with nothing importent data stored on it, I will take everything apart for the N'th time.

    If it's not a seccess I will update the bios.
  3. The problem has been resolved. (Thanks to zpyrd for his advice.)

    One or more of the following has done the trick:

    Updated BIOS to v6.00
    Removed Intel NIC (Intel Pro 1000GT)
    Installed newer Intel Matrix Storage Manager: 7.8.0.10.13 (previous was 7.8.0.10.11 I think)

    I guess the BIOS did the business. So everyone who is planning a Raid-5 array on ICH9R with more than 3 drives - update your BIOS.
  4. I just moved a RAID-1 array from JMicron (JMB63X) to Intel (ICH9R), and want to make sure I've got the latest BIOS/drivers.

    Stranded said:

    Updated BIOS to v6.00


    Do you mean your motherboard BIOS? (Is there a way to upgrade the ICH9R BIOS apart from flashing a new mobo BIOS?)

    Stranded said:

    Installed newer Intel Matrix Storage Manager: 7.8.0.10.13 (previous was 7.8.0.10.11 I think)


    Just wanted to confirm: did you mean 7.8.0.1012? That's the latest MSM version I could find, at least on Intel's official site:

    http://downloadcenter.intel.com/filter_results.aspx?strTypes=all&ProductID=2101&OSFullName=&lang=eng&strOSs=44&submit=Go%21

    Thanks to all for the helpful input.

    System:
    Gigabyte P35-DS4 rev2.1
    Q6600 2.4GHz, 4GB G.Skill DDR2
    2x Seagate Barracuda 7200.11 500GB as RAID1
    Asus GeForce 8500GT 512MB GDDR3 PCIe
    Antec Solo case, Nexus NX-8040 400W Silent PSU
Ask a new question

Read More

NAS / RAID BIOS Western Digital Storage