Can not get IDE DVD drive to work

I have an M61P-S3 board that supports 2 IDE devices. I can not get my IDE dvd burner to work (pioneer 104)
BIOS recognizes it, but when i insert any disc, windows hangs up and will not read the directory. I have tried all configurations of master, slave and cable select. but no luck. Does this board not suppport IDE optical drives? HAs anyone else been able to do this?

2 answers Last reply
More about drive work
  1. Post some more system specs, little more detail.

    I would change ide cable first. Try hooking up to same ide cable as hard drive. Is the proper driver installed for this device? Did you try a different power lead? Blow some air into drive when open, in case you have something in there blocking read/write laser. If your problem continues you probably have a problem with the drive itself. I see alot of failed cd or dvd rw drives often. I prefer to use Lite-On drives myself a good one can be had for $30-$39 for a 20x DVD+-RW.

    Best of Luck

    J. Turner
  2. thanks. I tried a diff cdrw drive and it works fine, i suspect that my dvd drive took a sh*t...
Ask a new question

Read More

Gigabyte DVD Drives Motherboards