Sign-in / Sign-up
Your question

Logitech G5 Problem!!!

Tags:
  • Mice
  • Computer
  • Drivers
  • Logitech
  • Components
Last response: in Components
September 20, 2007 1:53:12 PM

Ok I just got a brand new Logitech G5 from Newegg. I plug it into my USB port, boot the computer and the mouse lights up. As soon as the Windows loading screen comes up, the mouse goes dark. When Windows loads, the mouse does NOTHING!!!


I am running Windows XP Pro 64-bit. I tried installing the drivers from the disk, I tried downloading the 64-bit drivers from their website, I tried it without any drivers, nothing will work!

I have since tried this mouse on my old Gateway P4 running Windows XP (32-bit) and my office computer running the same version of Windows. The mouse responds the same with with all three computers! Has anyone seen this before, is it fixable? Or is my mouse just messed up and needs to be RMA'd?

More about : logitech problem

September 20, 2007 6:19:23 PM

I'm guess this board isn't very active or I just have a broken mouse...
a b \ Driver
September 20, 2007 7:20:56 PM

If you've tried it on multiple computers, I'd say it's dead. I have two G5s, and both worked fine as basic mice just by plugging them in; then I loaded the drivers to get the toys.
Related resources
Can't find your answer ? Ask !
September 20, 2007 7:23:00 PM

Yes I Agree, Sounds like it's dead.
September 21, 2007 12:34:20 PM

Yep, I just can't figure out why it lights up when the bios is booting, dies when Windows screen comes up.
September 21, 2007 1:47:22 PM

One of my friends had a very similar issue with a G5. Exchanged it and the new one worked fine. I would vote dead mouse.