Sign in with
Sign up | Sign in
Your question
Closed

Word 2003 files slow to open on Windows 7 over SBS 2003 network

Tags:
  • Office
  • Windows 7
  • SBS 2003
  • Workstations
  • Servers
  • Apps
Last response: in Apps General Discussion
Share
July 16, 2012 5:46:38 PM

Hello,

I have a Windows 7 workstation (almost new) running Office 2003 over a SBS2003 network. Word documents take 10+ seconds to open if they are server-based. Local files open instantly. Excel files, local or server-based, open immediately. Server-based Word files open instantly on all other (older) workstations on the network.

More about : word 2003 files slow open windows sbs 2003 network

a c 372 $ Windows 7
July 19, 2012 6:09:52 PM

Remove all network drives from the system except the one you are connecting to, did that speed things up? How are you opening the files? From Word or from double-clicking on the file from a folder view? Test how fast they open when you open them from the File > Open method in word.
Score
0
July 22, 2012 6:30:42 PM

Thanks for the suggestion. There is only the one network drive on this computer. Opening a 280K Word doc from the server by double-clicking in Explorer took 23 seconds. Opening the same file via File->Open took 21 seconds. Still way too long. Other thoughts?

Thanks,
-Steph
Score
0
Related resources
July 22, 2012 7:24:55 PM

What about copying the file to your own hard drive? How long does that take?
Score
0
July 22, 2012 11:24:00 PM

Sunius said:
What about copying the file to your own hard drive? How long does that take?


The actual copy takes less than one second. I don't think it is the server since other workstations (all older than this one) can open the file instantly. I think it is Word.

Here is what I have done so far:

  • Repair Word (no change).
  • Reninstall Office (no change).
  • Attempt to open file in Word from another workstation logged in as other user (fast).
  • Attempt to open file in Word from another workstation logged in as user in question (fast).
  • Attempt to open file in Word from workstation in question logged in as other user (slow).
  • Connect workstation in question to network using cable from fast workstation (slow).
  • I tried the thing with the normal.dot that I read about all over the internet (no change). normal.dot is local. And there are no UNC references within the Word file to an old, non-existent server.


    So:

  • It is not the cable since changing the cable to a known fast workstation did not improve anything.
  • It is not the server since the server is able to deliver the file to Word on the other workstations quickly.
  • It is not the userID since all uerIDs on this workstation are slow and all userIDs on the other workstations open the file quickly.
  • It is not Excel because there is not much of a lag when opening server-based spreadsheets.


    I have eliminated just about everything with no reasonable solution.

    Running out of bullets,
    -Steph
    Score
    0
    July 23, 2012 11:11:43 AM

    Sorry for stupid question, but do the workgroups match?
    Score
    0
    July 23, 2012 11:53:48 AM

    Sunius said:
    Sorry for stupid question, but do the workgroups match?


    No workgroups. This is on a domain managed by the SBS2003 box. Remember, it is only Word. Accessing other files on the server presents no problem.
    Score
    0
    a c 372 $ Windows 7
    July 23, 2012 1:23:33 PM

    The only time I have seen slow network files open like this took weeks to find the fix, and it was a network drive that was mapped that was no longer connected. There is no old drive stuck in the system? If you go to "Disconnect Network drives", does anything show up?

    This was a nasty thing to track down, in my case it was a user who was opening a VPN connection to another site, mapped a network drive to it, and disconnected. Whenever she tried to open a document, Office would scan all her drives, and get stuck on the disconnected drive till it timed out.
    Score
    0
    July 23, 2012 1:58:28 PM

    hang-the-9 said:
    The only time I have seen slow network files open like this took weeks to find the fix, and it was a network drive that was mapped that was no longer connected. There is no old drive stuck in the system? If you go to "Disconnect Network drives", does anything show up?

    This was a nasty thing to track down, in my case it was a user who was opening a VPN connection to another site, mapped a network drive to it, and disconnected. Whenever she tried to open a document, Office would scan all her drives, and get stuck on the disconnected drive till it timed out.



    Hmmm. This user does not VPN out of the office, but he does VPN INTO the office from home. When he is on the VPN from home, his local home computer drives are available to his office PC. But when he is not connected, those drives do not show in My Computer on his office PC.

    I guess I am still mystified that the delay is most pronounced with Word files. I was thinking that Word was using the network folder for its temporary files instead of a local folder. Do you know how to ensure that local folders are used for Word's temporary files?
    Score
    0
    a c 372 $ Windows 7
    July 23, 2012 2:41:14 PM

    whatacutup said:
    Hmmm. This user does not VPN out of the office, but he does VPN INTO the office from home. When he is on the VPN from home, his local home computer drives are available to his office PC. But when he is not connected, those drives do not show in My Computer on his office PC.

    I guess I am still mystified that the delay is most pronounced with Word files. I was thinking that Word was using the network folder for its temporary files instead of a local folder. Do you know how to ensure that local folders are used for Word's temporary files?


    It's not the temp files, it's the Open file process that is the issue. The drive may not show up in My Computer, go to Disconnect network drive option and see if there is anything listed there.

    This may be the issue, it sounds a lot like what I worked on, and the fix was to disconnect the drives before shutting off the VPN session.
    Score
    0
    July 23, 2012 2:47:29 PM

    hang-the-9 said:
    It's not the temp files, it's the Open file process that is the issue. The drive may not show up in My Computer, go to Disconnect network drive option and see if there is anything listed there.

    This may be the issue, it sounds a lot like what I worked on, and the fix was to disconnect the drives before shutting off the VPN session.



    Disconnect Network drive? Is that on the outside PC that is VPNing into the office or the office PC that is being accessed remotely? Where do I find this Disconnect Network Drive option?
    Score
    0
    a c 372 $ Windows 7
    July 23, 2012 3:16:53 PM

    If the issue is on the office PC, need to check it there. Should be in the Tools menu in any folder window. Although I don't know the exact location in 7 offhand.
    Score
    0
    July 23, 2012 3:42:17 PM

    hang-the-9 said:
    If the issue is on the office PC, need to check it there. Should be in the Tools menu in any folder window. Although I don't know the exact location in 7 offhand.


    I checked the office PC. To get to the Disconnect Network Drive in Win7, open Computer from the Start menu. If you don't see Tools, then hit Alt and it will appear. Disconnect Network drive will be there under Tools.

    When I tried it, all I saw was the one network drive on the SBS 2003 machine; no others.
    Score
    0
    a c 372 $ Windows 7
    July 23, 2012 4:11:29 PM

    Try OpenOffice, see if that opens faster. Or a different version of Office if you have a copy to use.

    Looks like your only option from what you have tried already is to re-install Windows on this computer and try it again.
    Score
    0
    August 6, 2012 8:26:04 PM

    I fixed it. I had tried a Repair in Control Panel/Add Remove programs for Office 2003. That did nothing. I uninstalled Office 2003 completely and then re-installed it. That fixed the performance issue. So at least I know that the computer, the ethernet cable, switch, and server are all good. A re-install did the trick.

    Thanks all for your assistance.
    Score
    0
    October 18, 2012 12:44:05 PM

    whatacutup said:
    I fixed it. I had tried a Repair in Control Panel/Add Remove programs for Office 2003. That did nothing. I uninstalled Office 2003 completely and then re-installed it. That fixed the performance issue. So at least I know that the computer, the ethernet cable, switch, and server are all good. A re-install did the trick.

    Thanks all for your assistance.


    Another thing to try - should that happen again - is to go to your add/remove programs and look for Microsoft Office File Validation. Close out of all your Office programs and uninstall it. For some reason, that program slows opening files from a network to a crawl.
    Score
    0
    October 19, 2012 10:41:11 PM

    LoganL said:
    Another thing to try - should that happen again - is to go to your add/remove programs and look for Microsoft Office File Validation. Close out of all your Office programs and uninstall it. For some reason, that program slows opening files from a network to a crawl.


    :bounce: 
    Thanks LoganL. Uninstalling Office File Validation showed an immediate improvement to opening files over network. Wow.
    Score
    0
    January 8, 2013 3:51:55 AM

    LoganL said:
    Another thing to try - should that happen again - is to go to your add/remove programs and look for Microsoft Office File Validation. Close out of all your Office programs and uninstall it. For some reason, that program slows opening files from a network to a crawl.



    HOLY CRAP IF YOU WERE HERE I"D TOTALLY KISS YOUR BUTT!!! Thank you thank you thank you!
    Score
    0
    a b $ Windows 7
    January 8, 2013 4:27:52 PM

    This topic has been closed by Mousemonkey
    Score
    0
    !