Sign-in / Sign-up
Your question

CD/DVD won't autoplay correctly

Tags:
  • DVD Drives
  • CD-Rom
  • Storage
Last response: in Storage
March 12, 2008 3:56:54 PM

This is a new on for me. All of a sudden, I am having problems getting my autoplay to work correctly. If I put in a disk with autoplay (such as an install disk for a program), the computer WILL automatically access the disk, but some code will come up on the screen in notepad. I AM able to access the disk through windows explorer. If I hit autoplay there, it's the same result.

I don't know if this is an issue with the drive or XP. To my knowledge I have done no updating in the last couple weeks (it's set to update with permission only). I've checked the autoplay feature, and it's turned on and set to "let me choose...the program to run"

I am running on a Toshiba laptop, A55 with a Matshita DVD-RAM UJ-820S and Windows XP. I have had NO problems with this in 3 years.

I tried running windows' "autofix.exe" for the autoplay, and the result was that it said that errors were found, but it was not able to fix them.

Help?!

More about : dvd autoplay correctly

March 12, 2008 8:47:15 PM

It's definitely NOT a drive (hardware) problem.
I've had this issue a few times but as far as I remember, a reboot fixed it every time.

You say autoplay is enabled, but to rule anything out, check the registry if autoplay is enabled there:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom

The 'AutoRun' value should be 0x00000001 (1)

I see I also have a value there called 'AutoRunAlwaysDisable' and it mentions most of my drives which could be ok because I've disabled the auto-play option for most disc types. Maybe that could give the problem you are having.

And the code you see when you insert a disc, is this 'code' the readable contents of the autorun.inf file on your cd's or just some garbage?

And if the above doesn't help, you could also try to uninstall the cd drive from the device manager, reboot and let it auto-detect your drive again.
That should reset some driver related settings in the registry.

Hope this helps,
Grunchlk
March 13, 2008 3:25:19 PM

Sorry for the delay, and thanks for the response!

No, a reboot didn't do anything. I've tried the usual side things like anti-virus, cleanup, etc.

The autoplay is enabled in the registry as you mentioned.
The code that comes up when a disc is inserted is just the autorun.inf file, as you said. It comes up in notepad everytime.

I had thought about deleting the drive also, as you suggested, but I was leaning to it being more of a windows issue. I've done other searches online and am finding nil. So I'll give it a whirl and hope it doesn't crash other stuff... Here goes.
Related resources
March 13, 2008 4:08:01 PM

No go. I uninstalled the dvd/cd, restarted, and no effect.

Any other ideas?
March 13, 2008 5:19:22 PM

Ok, how about something to do with file associations??? Notepad is bringing up files with .hta extensions. What would I delete/redirect/edit to have this match up correctly? Or is this just an event caused by some other program kicking out the file as inoperable?

I'm really at a loss here. I've looked all over microsoft's site, this forum, and a couple others but am coming up empty. I'm sure someone here has had this? Help!
March 13, 2008 5:27:04 PM

generally it's not a good idea to have autoplay on anyway. what's the point? by turning it off you aren't susceptible to sneaky rootkits or other weird installations, such as sony's debacle a couple of years ago. it's safer to have it manual and it's not like it's a headache, it's usually three mouse clicks.
March 13, 2008 5:27:21 PM

Oops, let me clarify. When I insert a program disc or presentation disc, autoplay engages, but within a few seconds a window from notepad comes up with a specific .hta file code all laid out from the disk. It looks like the auto play info, etc. from the disk. For instance, here is a copy of the window that appears when a Palm software installation cd is inserted (file name at top of Notepad is "index.hta"

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<link rel="stylesheet" href="styles.css" type="text/css" />
<hta:application BORDER="thin" SCROLL="no" maximizebutton="no" WINDOWSTATE="normal" id="PalmInstallerHTA" applicationname="PalmInstallerHTA" caption="yes" icon="images/palmicon.ico" showintaskbar="yes" singleinstance="yes" NAVIGABLE="yes"></hta:application>
<script language="javascript" src="javascript.js" type="text/javascript"></script>
<title>Getting started with your Palm® Centro™ smart device</title>
</head>

<body onload="javascript:SetDefaultSizeAndPosition();SetUpTimer()">

<div id="splash_screen">
<img src="images/splash.gif">
</div>

</body>

</html>


March 13, 2008 5:32:32 PM

Sorry, I'm still not sure I'm being clear...

ALL of my settings in autoplay are set to "Prompt me each time to choose an action." So when I say that "autoplay starts up", that may not be totally accurate.

Probably closer to the mark would be to say that the computer reads the disk inserted and then issues the Notepad stuff... I just assumed that at some level autoplay might be involved, even if it's to recognize that it needs to ask me what to do.
March 13, 2008 5:34:06 PM

browse to the cd and right click on that .hta file. my guess is that something along the way changed how windows handles those files. check to see what windows is using to open the file, it should be internet explorer but i suspect it is something else, possibly notepad. if it's notepad, change it to IE and try it again.

the autorun is very simple, it just tells windows to "run" XXXX file when a cd is put into the drive, HOW windows run's it is up to windows so i'm thinking that the autorun is working fine, it's just that when windows tries to run that file it's using the wrong program.

tell me if that works :) 

Valis
March 13, 2008 10:07:03 PM

Yeah, the association was to notepad, so thinking this was obviously wrong, I clicked to restore it to the default... and it went back to notepad. IE works, but makes you jump through a couple security hoops, depending on your settings.

I checked a co-workers computer and saw that they had "microsoft html application" as the listing for the handling program, tracked it down to c:/windows/ie7/mshta.exe, which the file association type did NOT automatically list.

I set it correctly, and it works great.

Thanks for y'all helping out! Sometimes it just helps to have someone else to bounce stuff off of! May the next guy get the answer faster than I did! :) 
March 14, 2008 3:25:13 PM

great!

sometimes helps to have a fresh pair of eyes taking a look at the problem
May 20, 2008 2:11:26 PM

You have very different problem. I think problem is in your system software I mean in your os or else it may be any kind of virus which corrupting your system software. Better your reinstal the system software.
September 18, 2008 11:42:40 PM

I am having exact same problem, where the autorun turns into a notepad with that extention. I am not a IT guy, so I couldnt' figure out how to get it to open with IE could you give me instructions on xp os, classic view.

contact at truejunkmail at yahoo dot com, i'm not sure replies will go to my email on this as I dont' surf this site at all except for today.
December 23, 2012 12:45:19 PM

Open regedit and navigate to:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
and then,
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Find a key called "NoDriveTypeAutoRun" and it is probably set to 255.
Double click, change this to 145(decimal), then hit OK

Reboot and insert media.
If it does not open automatically but displays AutoPlay options when you right click or on the header, then do the following:
Right click on your media
Open AutoPlay and click on "View more AutoPlay options in Control Panel"
Check "Use AutoPlay for all media and devices"
Click "Save"

Insert your media again.

You should be all set.
December 29, 2012 8:09:42 PM

mutualexcrement said:
Open regedit and navigate to:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
and then,
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

Find a key called "NoDriveTypeAutoRun" and it is probably set to 255.
Double click, change this to 145(decimal), then hit OK

Reboot and insert media.
If it does not open automatically but displays AutoPlay options when you right click or on the header, then do the following:
Right click on your media
Open AutoPlay and click on "View more AutoPlay options in Control Panel"
Check "Use AutoPlay for all media and devices"
Click "Save"

Insert your media again.

You should be all set.


**** Great solution!! Using Vista, I couldn't find the "NoDriveTypeAutoRun" key under

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

but changed it from 255 to 145 under

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

rebooted....Works like a charm. Thanks for your post!!