Sign in with
Sign up | Sign in
Your question
Solved

Driver issue?

Last response: in Applications
Share
July 18, 2012 9:27:20 PM

I am hooking my new cell Phone up and after trying to find a driver, I'm getting No PCI simple Communications Controller and No SM Bus Controller. I looked at drivers on AsRock and am confused. Did I not install something? What should I be looking for? Thanks. :D 

More about : driver issue

Best solution

a b \ Driver
July 19, 2012 12:38:13 PM

Those are chipset drivers. Did you install your motherboard drivers after installing the OS? Look in your device manager for any entries that have a yellow exclamation mark. Those are devices that require drivers.
Share
July 19, 2012 1:43:45 PM

Yes. I looked on the AsRock download section last nite. I downloaded all the drivers on the page. The cif driver says no device found. The inf driver seemed to install fine. I did all this after installing a new copy of windows7 64. Intel driver update utility says my hd 4000 is up to date. Everything else it says to get drivers from manufacturer. I'm trying to figure this out. Thanks for any help.


m
0
l
Related resources
July 20, 2012 6:06:53 AM

Hawkeye22 said:
Those are chipset drivers. Did you install your motherboard drivers after installing the OS? Look in your device manager for any entries that have a yellow exclamation mark. Those are devices that require drivers.

Any other ideas?
m
0
l
July 20, 2012 8:11:41 PM

What kind of phone do you have? Is it a smartphone or a basic phone?
m
0
l
July 27, 2012 3:34:18 PM

Best answer selected by andyvet32.
m
0
l
February 25, 2013 2:29:04 PM

I know someone has already chosen a best answer but its the wrong one.

Here is how to fix your Windows 7 SM Bus Controller issue with ASRock Extreme (mine is 6) series motherboard.

0.1a - Go to Start, Right click the word Computer, then click MANAGE.
0.1b - Click on Device Manager. You should see SM Bus Controller and thats all under the section of unknown devices. It will have a Yellow placard and Exclamation point to indicate drivers are missing.
0.1c - If ANY other devices are listed, right click the icon, and select Install Update, it will go online and I BELIEVE that one of them may be the USB3 controller... for some reason it doesnt install it properly the first time, but gets it the second time.

---Once you have only SM Bus Controller (or tried your hardest to get that way) ----

1. Go to ASRock website for your motherboard, i just googled ASRock Extreme6 and it popped up.
2. Select the downloads section of the site
3. Select WINDOWS 8 64 bit
3a. Yes i know you're NOT using windows 8.. dont care, this works
4. Download the INF file from your nearest country
5. Open the INF folder and double click SETUP
6. Let it install, notice it says NOTHING about windows 8 in the install? Thats because its just chipset drivers.
7. Click next once it has finished installing, and thats it. Now to check that SM Bus Controller is now gone from unknown devices.

8.1 - Go back to the Device Manager window (or repeat steps 0.1a-0.1b)
8.2 - Check to see that all devices are now found.
8.3 - Feel free to share with your friends.
m
0
l
February 25, 2013 2:29:20 PM

I know someone has already chosen a best answer but its the wrong one.

Here is how to fix your Windows 7 SM Bus Controller issue with ASRock Extreme (mine is 6) series motherboard.

0.1a - Go to Start, Right click the word Computer, then click MANAGE.
0.1b - Click on Device Manager. You should see SM Bus Controller and thats all under the section of unknown devices. It will have a Yellow placard and Exclamation point to indicate drivers are missing.
0.1c - If ANY other devices are listed, right click the icon, and select Install Update, it will go online and I BELIEVE that one of them may be the USB3 controller... for some reason it doesnt install it properly the first time, but gets it the second time.

---Once you have only SM Bus Controller (or tried your hardest to get that way) ----

1. Go to ASRock website for your motherboard, i just googled ASRock Extreme6 and it popped up.
2. Select the downloads section of the site
3. Select WINDOWS 8 64 bit
3a. Yes i know you're NOT using windows 8.. dont care, this works
4. Download the INF file from your nearest country
5. Open the INF folder and double click SETUP
6. Let it install, notice it says NOTHING about windows 8 in the install? Thats because its just chipset drivers.
7. Click next once it has finished installing, and thats it. Now to check that SM Bus Controller is now gone from unknown devices.

8.1 - Go back to the Device Manager window (or repeat steps 0.1a-0.1b)
8.2 - Check to see that all devices are now found.
8.3 - Feel free to share with your friends.
m
0
l
February 25, 2013 2:30:32 PM

the site gave me an error saying the site was busy and to come back later, it double posted when i refreshed. moderator could you please work your magic and clear this up for me? <3
m
0
l
!