Sign in with
Sign up | Sign in
Your question

3rd Party RAID on nVidia 680i LT Motherboard

Last response: in Storage
Share
March 19, 2008 4:01:24 AM

Hello all,

I have an eVGA 680i LT motherboard. As some of you found out the hard way, the MediaShield (onboard) RAID sucks pretty bad.

Briefly, I had a history where putting two drives into RAID1 or RAID0 would repeatedly go "Degraded" immediately after they were created. I wasn't using the Windows interface either. After a long troubleshooting spree with eVGA and Hitachi, I got both the board and four Hitachi drives replaced and new drives and a new board did NOT fix the problem. I walked away disappointed and decided to go with a HighPoint Tech 2300 PCIe RAID card.

I don't know if it was a compatibility issue with the drives I was using or something.. but I never did get nVidia RAID working. Yeah, I replaced all of the SATA cables as well. Nothing gave.

Anyways, the gist of my post is that, I have a situation where I'm willing to TRY the nVidia RAID again. There's been a couple BIOS updates, not that they would help.

However, with this HighPoint Tech card installed, I never see the MediaShield BIOS configuration screen.

In addition, I get the following errors:
  1. Warning:Have Option ROM can not be invoke (Vendor ID:10DEh, Device ID:0373h)
  2. Warning:Have Option ROM can not be invoke (Vendor ID:10DEh, Device ID:036Eh)


I did confirm that that vendor ID is nVidia, but I don't know about the Device IDs.

Is this a limitation of this board? Any fix?

Thanks!
April 4, 2008 9:59:07 PM

I have the 680i mainboard and I have had no problems setting up fakeraid with western digital and maxtor drives. I haven't tried raid0 yet but raid1 has been working for quite some time now. I used up all six connectors on the onboard sata controllers and I went out and bought a HighPoint RocketRAID 2300 PCIe card to give me 4 more ports (10 all together).

I had the same problem as you, once the highpoint controller was installed I could no longer access the onboard raid controller's bios screen. The MediaShield screen appears after the highpoint controller screen. But what I was told is that there's only a certain amount of memory available to boot roms. My nvidia raid controller and the onborad nics pretty much used it all up (even though I don't boot with nics), so the highpoint bios was pushing the next controller (MediaShield) out of the rom.

What I did to correct this was to move the highpoint controller out of the pci-e x1 slots into a x16 video slot that I wasn't using (card runs at x1 regardless). I have 3 x16 slots on my board, 2 graphics and one electrical slot. The LT lacks the electrical slot so your only option is to use a x16 graphics slot. The video card should always be in the 1st one, but the other can be used for other devices. If you running SLI on the LT (already using up all of the x16 slots) then I don't know what to tell you.

By moving the highpoint card out of the x1 slots I was able to see the MediaShield screen again but I also got the same errors as you:
Warning:Have Option ROM can not be invoke (Vendor ID:10DEh, Device ID:0373h)

To fix this I downloaded the newest firmware for the controller from highpoint and flashed it using windows (windows is required to access additional features). After you select the firmware you want to load, the "config" button will then be accessible. Click on this before the flash and select:

Reallocate EBDA: disabled
Init 13 Support: disabled

I also changed the "ctrl-h" timeout to 5 seconds because it was taking about 18 seconds to get past the highpoint screen which is way to long.

What this will do is completely remove the bootable features form the highpoint controller - removing the "Have Option ROM can not be invoke..." error.

Now everything works as it should - for me at least. The highpoint rom shows up and then the nvidia rom show up and then it boots from the nvidia controller with no errors.

nVidia:
0.0/0.1 = WD 750GB RAID1 (bootable OS)
1.0/1.1 = WD 500GB RAID1
2.0/2.1 = WD 500GB RAID1

Highpoint
1-1/1-2 = Maxtor 500GB RAID1
2-1/2-2 = WD 250GB RAID1

Hope that helps you out.
April 4, 2008 11:32:39 PM

Thanks for the info. I've got some projects going on, but after that, I may redo my storage configuration. So, setting EBDA and Init13 to Disabled allows MediaShield to boot? That's good to know. While I love having my OS on RAID0, I might just go back to non-RAID OS and a four drive RAID0 on the HighPoint.
Related resources
April 5, 2008 12:32:51 AM

Setting EBDA and Init13 to disabled gets rid of the "Have Option ROM can not be invoke..." error. You may still need to move the card out of the x1 slots to see the MediaShield screen. If you do the above you won't be able to boot from the highpoint controller.

EVGA said I would have to disable my onboard nics or the nvidia RAID controller in order to boot from the highpoint controller. If you disable the nics or nvidia RAID, then you shouldn't have to disable EBDA or Init 13 and it should work in the x1 slots.
October 27, 2008 10:59:01 PM

OK I also have a problem with 680i motherboard. I had a 8800gt and replaced it with 2 9800gt's in sli. here is the issue when I exit multi player games I get blue screen error code 2 different ones first is IRQL NOT LESS OR EQUAL TO AND THE second is Attempted to write to read only memory.I re did windows xp with the latest updated chipset and video drivers realesed october 2008 and still the same issue. I also re- flashed the bio's and totaly re did windows still the same thing. So I have totaly redid every piece of software 2 times , then did a ram mem test passed then did hard drive test passed. I have a Intel e6750 cpu and 4 gigs of Patriot viper mem have manualy set the timmings and voltage for the mem still same issue.the 3dmarks are excellent I score 14,850 in benchmark 06.it is when I quit a multi player game such as COD4 or BF2.microsoft says the error is caused by "blue screen error caused by device or device driver".well have re did every piece of software in th PC 2 times except 1. The new 9800gt is in fact the Identical card as the 8800gt except 1 thing the Bios.is it possible the conflict is in fact the newly flashed BIOS of the 9800gt? or does anyone els have a solution for this problem I am out of ideas.
January 9, 2009 3:54:09 AM

I fixed this on my MSI board by restoring optimized defaults in the BIOS. Prior to that I could not for the life of me clear the error message. Just a heads up for anyone else that stumbles on this from 'teh googles.

-Protonus
!