Sign in with
Sign up | Sign in
Your question

Long hard drive activity, reading a video file

Last response: in Windows Vista
Share
March 22, 2011 10:01:26 PM

Hi! I recently installed Vista x64 Ultimate on my machine. I've been slowly migrating my stuff on to vista. Yesterday I noticed hard drive activity after Vista was on for quite a bit. It was reading a large video file. Resource monitor showed it peaking at 1 Gigabytes per minute, before decreasing and ceasing. Today I started up the machine again and I notice this happen again but for a longer period of time, maybe 10 minutes.

Resource Monitor showed this process reading the video file: svchost.exe (LocalSystemNetworkRestricted), it's IO priority was Background.

The video file is not on the system partition, Indexing and windows search is disabled. System restore is disabled on the partition in which the video file is on. I checked the my 3rd party defragger to see if it was performing an auto defrag...it was not. I ended the process for the defragger to be sure and there was still hard drive activity. Is Superfetch the culprit here? I really don't understand why Vista needs to read the file...

One thing I should note is I opened this video file a few times testing with MPC-HC.

April 1, 2011 1:03:21 AM

Bump :( 
April 3, 2011 7:46:56 PM

What type of file is it and how large? Try backing it up to external media and deleting it... if you're still having issues after that, then it clearly isn't that file.
Related resources
April 4, 2011 3:44:46 AM

This particular file is a 5 gig mkv file. I deleted the file and the hard drive activity stopped. It really does not matter which video file it is. I had another 900mb .wmv file and it reads that too. This happens when I boot up the computer and then for some reason later in the day.

As I said before System restore is disabled on that partition, Indexing and windows search disabled. Is superfetch the cause of this? What purpose is there to read the video file. How can I stop it from doing this?
April 4, 2011 6:28:12 AM

Do you have any antivirus software on your PC?
April 4, 2011 7:04:05 AM

None yet, just Outpost firewall Pro 7.1. The Antispyware portion that comes with it is disabled.

Resource monitor says svchost.exe (LocalSystemNetworkRestricted) is reading the file. No write.
April 4, 2011 7:40:59 AM

Well, I think your first step is to investigate which service is causing the disk access. (svchost.exe is a rather generic process that handles a number of different services.) Have a look at this article which shows you how you can drill down a little. Once you know which service is doing the reads it may be obvious what the problem is. If not come back with further details.
April 6, 2011 2:58:58 AM

Ok Here are the following services under svchost.exe (LocalSystemNetworkRestricted):

AudioEndpointBuilder: Windows Audio Endpoint Builder
EMDMgmt: ReadyBoost
Netman: Network Connections
PcaSvc: Program Compatibility Assistant Service
SysMain: Superfetch
UxSms: Desktop Window Manager Session Manager
WPDBusEnum: Portable Device Enumerator Service
wudfsvc: Windows Driver Foundation -User -mode Driver Framework
April 6, 2011 8:29:13 AM

My bet would be on ReadyBoost. Superfetch only applies to software, so I doubt it's that. You could try disabling the services one-by-one to see which one it is (but I'd be wary about disabling Windows Driver Foundation).
April 6, 2011 5:03:26 PM

But if I don't have any USB device to implement the ReadyBoost is that even possible?
April 6, 2011 8:35:28 PM

I don't know. Why is it running? That service isn't running on my PC. Anyway, why not try disabling the services, as I suggest, to try and see which one is causing the problem?
May 18, 2011 6:58:38 AM

Any more info on this problem? I see the exact same thing. Same constant disk activity on large video file, same svchost.exe (localnetworkrestricted), same ceasing of activity if video file is deleted, also activity ceases if video file is moved to a different folder, also used MPC-HC to open file a couple times.

Any ideas on what this is and/or how to stop it? Thanks.

I just saw this at memphispcguy.com:

Quote:
To Finetune Superfetch

You can also finetune superfetch to only “fetch” certain file types. By default it tries to fetch not only the actual applications, but also the support files they may utilise, like Warhammer Zone and Art files.

Please Note: Editing your registry can have dire consequences if done incorrectly! This is considered an Advanced Technique and should not be taken lightly.

Goto: HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Session Manager\Memory Management\PrefetchParameters
you should see two keys called enable superfetch and enable prefetch, both having the default values of 3.
change both the values according to the below info and your preference.

1: Caches Boot files only.
2: Caches Boot files and Programfiles (this is the best setting for most systems, gives maximum performance with minimum resource hog)
3: Caches all files (Default setting, takes maximum resources)


All other places say that 1=Cache Boot Files Only 2:Cache Program/Applications Only 3: Cache Everything.

So which is it really, Does 2=Cache Boot & Program files or just Program files only? Also, none of the options mention data files like video files or music, yet that is what I see in the high disk activity in the resource monitor. Please help?
!