Sign in with
Sign up | Sign in
Your question
Solved

Wierd Java behavior

Last response: in Applications
Share
August 21, 2012 5:45:37 PM

I didn't know where to ask this, so I'll ask it here. Java applications have been having problems that I find hard to explain. I tried uninstalling all Java stuff then reinstalling, but no change.

First off, I started an app that looks at Minecraft worlds, called "Amidst" and when I hover over a tab inside the application, its contents sometimes don't appear until I hover over where they would be (Ex. I hover over "Map" tab, contents don't appear until I hover over all "Find" "Go To" "Layers" and "Capture". Just like Firefox has "Bookmarks" and "Tools" tabs. After they DO appear, they don't disappear when I hover off of it.

Can someone explain why this happens and what I could do? This started happening a while ago and now it's getting frustrating because some buttons require being hovered over to see them in the Java app (but not in Minecraft THE GAME ITSELF, no problems there).

Thanks! Sorry if it's confusing, but that's the best I could explain it! I can give pictures, but they would not help much.

More about : wierd java behavior

August 22, 2012 12:25:25 PM

Why do you think it's Java and not a bug in the Amidst app?
m
0
l
August 22, 2012 12:49:40 PM

This also happens in another Java application where the buttons to select don't appear until I hover over them
m
0
l
Related resources

Best solution

August 22, 2012 2:59:09 PM

Try uninstalling, running CCleaner to clean out the registry and install a previous Java version. Ideally the version that Amidst state you need.
Share
August 22, 2012 5:33:46 PM

Thanks, I'll try that later. If that doesn't work, I don't know what would.

EDIT: I tried your method and there is no change. I found the right words to describe this, too. The changes in the application are not appearing in real time, so hovering my mouse above it makes it update and show. BUT! This does not work if the screen needs to update and hovering over does not change anything.

I found that when loading a map, the application turn blue (ocean) and then minimizing and maximizing fixes it, thus adding the rest of the biomes' colors. This seems to be a problem with my video card (I assume), but I am replacing it very soon, coincidentally!

Any extra help would be appreciated if this is not a problem with the graphics!
m
0
l
September 1, 2012 9:51:18 PM

Best answer selected by Edonnel.
m
0
l
!