Sign in with
Sign up | Sign in
Your question
Solved

Vista System Recovery / Startup Repair death-spiral

Last response: in Windows Vista
Share
April 27, 2011 12:54:45 AM

Hello,

My daughter's Vista PC is going through a System Recovery death-spiral. Windows will not run, and none of the recovery or Startup Repair tools are working. Vista recovery disk is useless. Trying to boot from a Vista install disk is useless.

Startup Repair log shows a corrupt Boot critical ...System32\...\ecache.sys file. I tried to rename that file so I could replace it with a copy from another PC, but the copy request could not be performed due to an I/O device error.

If my car ran like Windows, I would push it off a cliff.
April 27, 2011 2:55:38 AM

Have you tried booting into safe mode and launching system restore and selecting a date prior to the problem showing up ?
m
0
l
April 27, 2011 10:38:37 AM

Not from safe mode, but I did set the restore point back twice, from Startup Repair. No luck.
m
0
l
Related resources

Best solution

April 27, 2011 3:02:01 PM

Can you boot into safe mode ? Or do you know how to get a DOS boot disk in order to boot the system and copy a file onto the HDD? If so you can try using this copy of the file from my VISTA install ( DOWNLOAD LINK ) -- it needs to be placed in the C:\Windows\system32\ folder - It seems it is a part of the sleep mode files and I have that disabled so this should be an original version of the file right after installation but not positive it will work or if it is machine specific but at this point shouldn't hurt to try (just make a copy of your file by renaming it before placing this one in the folder just in case then you can replace your original if this does not work !)

There is a post on another forum that has someone that recovered from the problem that details the steps he took as follows :

Quote:
> I did resolve the problem last night and was able to get the system
> booted.
> The following series of events resulted in the successful start of the
> system: (01) Installed Vista Ultimate x64 of a secondary machine
> (AMD Athlon 64 laptop)
>
> (02) Installed Vista SP1 on the secondary machine.
>
> (03) Copied the \windows\system32\drivers\ecache.sys file to a thumb
> drive(*Note:* File size after SP1 install was 151 K).
> (04) Booted the ailing machine from a Vista Ultimate x64 DVD
>
> (05) Launched the repair option and let the attempt another automatic
> repair.
>
> (06) Attempted a standard reboot after the repair but the system failed
> again.
>
> (07) Rebooted the system again and exercised the repair option again.
>
> (08) After the repair attempt completed, I closed the window and opened
> a command shell.
>
> (09) Performed an *XCOPY {USB THUMB DRIVE}\ecache.sys
> c:\windows\system32\drivers *command
>
> (10) Rebooted the machine again.
>
> (11) The machine took longer than usual to boot and notified me that
> system restore had rolled back the system to a previous date.
>
> (12) I rebooted again and the shut down took a real long time...(I
> almost powered the machine off because I thought that it was hung). It
> rebooted again and I am not doing analysis on the machine.
> *Note :* -I am not sure if an automatic update corrupted the
> file but I think the restore roll back was a good thing to have done.
> It appears that the original attempt to replace the file came from a 32
> bit version of Vista Ultimate which was unrecognized by the system and
> there is a difference between the file sized for pre and post SP1
> versions of the file.-
>
>
> --
> eunix
Share
April 27, 2011 9:45:28 PM

Most humble and sincere thanks. The Xcopy from memory stick thing did the trick. I got the file from one of my other kids' PCs.
m
0
l
April 27, 2011 9:53:44 PM

rmcculloch said:
Most humble and sincere thanks. The Xcopy from memory stick thing did the trick. I got the file from one of my other kids' PCs.


Glad to hear you got it working !!
m
0
l
May 7, 2011 2:54:19 AM

Best answer selected by rmcculloch.
m
0
l
!