Seagate Barracuda having a hard time

I've been working on this for days now and I'm still stuck. It started with my Seagate SATA going crazy. At some operations (read/write) it froze the system for a while and disappeared, leaving a message that one of the drives has been hot-plugged. It kept on freezing for about 10 sec, than unfreezing and so on. On reboot everything's ok, until it hits that 'sweet spot'. In the meantime I discovered that some of the files are unreadable. It hangs about 1 min that pops up a "You don't have permission" dialog.

Changing privileges/owner didn't solve the issue. I tested with Seatools, but the drive is greyed out, like it's not a Seagate model. Short DST does not start, but passes the Generic Short test. SMART status is ok, drive temperature ok, PSU and cables brand new. Somehow it seemed that it doesen't have any physical problems. So I bought today an identic hard, hoping that by making a RAID-1 array will solve the problem. Well, it didn't. :fou: Couldn't mirror the source hd. Rejected it instantly.

Hope to hear from you. Curious especially why does Seatools read the hd as non-Seagate. The drive in question is a Seagate Barracuda ST3250410AS, 250G, SATA.

Thanks!
6 answers Last reply
More about seagate barracuda hard time
  1. Check the memory with memtest86+.
    Could be the power supply also.
    Tell us more about your setup.
  2. The hd is from a retail shop. Hope still under warranty. I have two 5 year old Seagates, an 60 G which is mostly dead and a 40 G that's still working. This is the boot device, which sometimes fail sometimes pass the Short/Long DST, although it works fine.

    The system is an ASRock 775Dual-VSTA with an Intel Pentium D (dual core) 2,66 GHz on top, 1 G DDR2, Asus EAX1550 256 MB video. The hd config is the following:

    Seagate Barracuda ST340016A PATA 80G (Windows)
    Maxtor 6L300R0 PATA 300G (Music)
    2x Seagate Barracuda ST3250410AS, SATA 250 G (Audio files)

    It runs 24/7 hosting a small community radio station.

    I tried testing the hd, scandisk gave me a "File record segment is unreadable" at some consecutive records, disk surface test are either come up as PASSED or hung at some point. I should note that the software used for testing did not recognize the drive as SATA, rather than a BIOS drive on an unknown controller. Are these test relative, than?
  3. zzzuppermen said:
    Seagate Barracuda ST340016A PATA 80G (Windows)


    Which flavour of Windoze? How are the temperatures in the PC? Is the PC running on a UPS? Have you made any changes in the PC recently? Is any other device sharing the channel with your boot drive?

    Try opening up the box and making sure everything is plugged in correctly.

    UD.
  4. OS is Windows XP SP2, 32 bit. Reinstalled 2 weeks ago. Temperatures are ok. It runs on a 650 VA UPS. The problematic hd is a single master on the first SATA channel. Box is secure and clean. PSU is an Antec EarthWatts 500W, 2 months old.

    It turns out that some sectors are unreadable. When trying to copy from these locations Windows gives a "Cannot copy. Remove write protection" error. Write protection? The file can't be read either, so I'm pretty sure the problem is not with the other drives, since they interact as expected.

    Currently recovering the bad sectors with a program called HDD Regenerator (v1.51). Hope it's gonna make things work.
  5. After hours of hard work (computer) and angry keystrokes (me), here's an update of the situation.

    After getting consecutive "File record segment xxxx is unreadable." of different from scandisk, I assumed I must have some bad blocks. The numbers given were probably from the MFT index, so I couldn't pinpoint them directly to a block. I used then "spare" softwares that did high speed reads (not block-by-block) that will eventually generate a "Could not read sector xxxx" error. Initially used Seatools' 90 sec test and Acronis Disk Director that analyzed the partitions before applying a task (also in the mean time tried copying the partition to the spare drive if no error was encountered, but sadly failed every time). This gave me some sector numbers which I started to correct out with HDD Regenerator 1.51. After all the bad sectors were corrected, I tried to make a RAID 1 mirror to the spare drive but it failed at 40%, or so. I figured, I've missed something, so I ran HDD Regenerator for about the first 100G (occupied space was a low fragmented 70G), popped out 8 new bad sectors in the first 500MB. Tried RAID 1 mirror again, but failed at about 30%. Ok. I guessed I got the 100G limit wrong and because the RAID controller mirrors probably according to MFT that does not stores files as I would my CD collection the problem is somewhere beyond that limit. Hoping to get two jobs done at once, I ran Norton Ghost, trying to create an image of the partition. Failed with "could not read sector xxxx through xxxx" as expected, but inside the 100G tested area. Missed something? Regenerated bad blocks this time grew to about 30. To be sure, I ran scandisk for 3 times, which apparently cleared all errors. To be sure, I ran Norton Ghost again, which failed at 45%, spitting out a sector offset beyond the spurious 100G. Thinking I've found the last problematic sectors, popped up HDD Regenerator and entered the values. It was a nightmare. After hours of operation, I halted a program after it found and corrected about 2300 bad sectors. Now with a motivated suspicion, I checked the previously repaired areas, which sadly still had some bad block, though fewer that before. Last I rechecked the 2300+ bad sector part, but now entering a smaller offset, just to be sure. It found about 1400 bad sectors before the previous offset and continued to find in the previously tested area, too. To be sure that I'm using the right tool, I ran HDAT2 4.53 which failed at the first sector (disk is hung). Getting delayed identifications on the hd at system startup, too it was expected. Checked SMART status, which this time showed a warning on reallocated blocks passing the threshold. Yes, I somewhat expected this after 4000+ bad blocks. Finally, to make sure that the beginning of the partition is ok, I started to test the first 500MB. The first two passes came clean, only small delays at the first 10000 sector. Third pass did not lie anymore. Sector 0 bad, unrecoverable.

    Today at 07.58 AM, the hd died. It's still detectable in BIOS, but has unrecoverable bad sectors.

    Hope you could make suggestions for an eventual 'next time it happens', besides the obvious 'always make backups' that unfortunately didn't came into the picture this time.

    For the sake of a last chance, do you know any program that could recover data from partitions with bad blocks? COPYR.DMA would be nice but it does not work with SATA, yet.

    Thanks and sorry for the long post!
  6. It would be a long shot but years (10-20) ago they made a program called "Wizard on a Wire" problem with the program was it could take days to run its magic, but if the info on the drive is important and you can't afford one of the recovery companys usually starting around $750.00 it might be worth a try.

    Good Luck to you ;)
Ask a new question

Read More

Hard Drives Seagate Storage