Sign in with
Sign up | Sign in
Your question

Gigabyte z68x-ud3h-b3 USB 3.0 Issues

Last response: in Applications
Share
September 14, 2012 5:29:26 AM

Hello folks,
I have researched this problem thoroughly and have tried many things, all to no avail. So I am falling back on the experts; you guys :) 

I need help. And I believe you can help me. First off, the specs:

Gigabyte Z68X-UD3H-B3 Motherboard (Bios F12)
G.Skill Ripjaws 8gb DDR3 1600mhz
Core i7 2600k 3.4ghz
Zotac Geforce GTX 560ti
Windows 7 Home Premium (64-bit)

So basically, system runs awesome. Very fast, smooth.
However, I'm having issues with the usb 3.0 drivers (I presume)

I've had the system for a while but I haven't used the usb 3.0 ports until recently. Turns out, it doesn't work properly. There have been a few threads around the internet, all talking about updating drivers, disabling a few things in bios, etc. So far, no luck.
When I plug in a USB 3.0 bus powered hard drive, (WD, to be exact) my computer either doesn't detect the drive (the light goes on, the disk spins, even the "remove hardware" icon shows up in the system tray) but no dice in windows explorer. OR it detects it, I open it up, start transferring at ~50 mBps, and then very shortly thereafter my system locks up 100%, requiring a hard reboot.

I have no clue where to go from here. Event viewer hasn't shown me any results that I understand, but I do see this..... The driver \Driver\WUDFRd failed to load for the device USB\VID_05AC&PID_1297&MI_00\0. (ID 219, task category 212)

I would love to transfer at a 3.0 USB speed. Granted, this is not necessary, but it's much faster than 10-20 mBps. That matters when trying to backup half a terabyte :) 
Plus it just bugs me that it's something not working 100%. Maybe this is as futile as trying to rid your event viewer of all errors, but it's something I'm striving for nonetheless!

So anyway, I'd love to hear input from you guys :) 
September 14, 2012 7:54:26 AM

Do you have the latest update to the Etron USB 3.0 Driver installed?
m
0
l
September 15, 2012 10:23:04 PM

Hello abekl, sorry about the delayed response as I have not gotten the chance to even touch my computer as of late.

To answer your question, yes. I downloaded and installed the version 1.0.0.112 driver. Funny thing is, when I try installing the 1.0.0.111 driver, it won't run. Nothing even happens, I double click, right click/open, nothing at all. Maybe this is because the .112 is already installed?
Windows device manager claims that this driver is working properly.
m
0
l
Related resources
September 15, 2012 10:56:42 PM

UPDATE:
Turns out there was a .115 version, so I downloaded that. Will install, test out and report back.
m
0
l
September 15, 2012 11:18:56 PM

Ok, looks like the last thing windows event viewer shows before the Kernel-Power is event ID 10: Event filter with query "SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 99" could not be reactivated in namespace "//./root/CIMV2" because of error 0x80041003. Events cannot be delivered through this filter until the problem is corrected.

Source: WMI

I've found steps on how to fix that event ID, but I am hesitant to try it. It involves modifying some registry settings.

Any opinions on whether or not this is related or just coincidence that it happens before the crash? The event viewer shows this error without total freezes elsewhere too.

UPDATE: Running .115 Etron drivers. Each time I plug in the device into a usb 3.0, event viewer shows me the WMI error, followed by a spam of Disk errors (ID 11 and 51).
Works fine on USB 2.0, though. Seems isolated to the 3.0 drivers
m
0
l
September 16, 2012 8:47:22 AM

Hmm. Well, if you're comfortable editing the registry, I'd back it up, and give it a try. With a registry backup on hand, you can't really do any damage.
m
0
l
September 16, 2012 10:41:19 PM

But somehow I don't think WMI is fully at fault. Yes, it happens to fault each time I connect the drive, but it also faults on it's own at different times without freezes.

I should mention that I have a second identical build with the 1.0.0.104 drivers.
Havent tried it with the drive yet. But I can't seem to revert to the .104 drivers, my system tells me I have the .115 drivers already installed, despite having removed them.

The second system is at my brother's place so I'll have to try the drive out over there.
m
0
l
September 17, 2012 5:04:09 AM

Alright, well the drive runs fine on USB 2.0.
So I decided to reformat the drive in case it was at fault. Even after the reformat (using the western digital utility), usb 3.0 throws a bunch of Event ID 51 errors claiming and error was detected on the device during a paging operation.

Is it possible that an error on a drive would only be detected by usb 3.0 (different driver than the 2.0 usbs)?

To rule out drive faults, I'm currently performing a full format using Windows as opposed to the utility, and it's going at a crawl. I'll leave it overnight and once that's done, I'll do a full error-checking for the entire drive.

I've reverted back to a 1.0.0.104 version of the driver, as it seems the most stable. This is the version that came with the motherboard drive CD when purchased.
I will report once I've done all this.
m
0
l
September 17, 2012 11:48:21 PM

Ok. After a painstaking reformat (18 hours, most of which I was sleeping/working, luckily) using the built-in windows utility, it seems to finally work.

All that wild goose chasing was completely unnecessary. I guess what got me started is that no errors were detected on USB 2.0, and it worked fine otherwise with 2.0 which led me to believe 3.0 was at fault.

Thank you abekl for helping out :)  I'll post again if the issue turns up
m
0
l
!