Sign in with
Sign up | Sign in
Your question

Diamond Viper HD2900 XT 512 & VPU Crash

Last response: in Graphics & Displays
Share
November 2, 2007 2:15:20 PM

It's my first time guys so be gentle.
I have read through a bunch of posts and found some very similar ones but not quite the same.
The issue is when I try to play Civ IV I get a VPU crash before i can actually play the game (I can get through the setup screens and splash screen, but exactly when it goes to load the map to play ..VPU crash)
The History:

Last year I knew I wanted A crossfire setup, so i purchased and installed:
MSI K9A Platinum V 1.0
AMD X2 3800+ 65W
ThermalTake Pure Power 750W (which at the time had an ATI logo on it)
Crucial Ballistix 1GB (2x512) PC6400 DDR2
ATI X1300Pro 256mb (manufactured by ATI)

I was happy and i left well enough alone.. until i ran 3dmark06 a few weeks ago and saw how crappy the system was compared to it's potential (and my 19" Acer wide screen would get those sparkleies at high resolution)

I did some research on ATI/AMD recomended products and ordered the following:
Diamond Viper HD2900XT 512
X2 65W 5000+ Black edition
Soundblaster Audigy 24bit
Crucial Ballistix 2GB (2x1024) PC6400 DDR2

I installed last night and it went a lot easier than i expected.
average Case and CPU temepture fluctuated between 40 - 45 C (according to the Bios on the reboots)

First I was an idiot and didn't uninstall the drivers. I wound up having to uninstall them twice.
(I read about a complete driver uninstaller on these posts that i will try tonight when i get home)
Other than that the system runs good enough for me. (although it is one of the lowest scores on (3Dmark)

The only problem I seem to have is a VPU crash when i try to play CIV IV.
Occasionaly it crashes bad enough to give me the BSOD for the ATI2DIAG (i think that's how it's spelled)
I think it's heat related but after reading some posts I wonder if it is possibly a bad card (or bad PSU)?

I am running Windows XP Pro SP2 .. I also run window blinds 6...
I have the (2) 6pin PCI-E plugs in it because this PSU doesn't have a 4/2 pin plug...
This main board also has a molex connector on the board by the PCIE16 slot which i have plugged in as well.
I only have my Processer at a 11.5x or 12x (2.4GHZ) and i did it intentionaly because I wanted to make sure nothing is overheating.
I have (2) 80MM Thermaltake fans in the front, (2) 80MM Thermal take fans in the rear, plus the fans for the Card, PSU and heatsink.

Also, I have run the original SIMS, and the Half Life 2: episode 2 and 3DMark06 with no errors.
My 3DMark Score jumped from 1200 to 8500 with the upgrades and ran the graphics test between 40 - 60 FPS... thought the CPU test was at 1 FPS (i have a bad feeling about that also)

Also, because CPUZ detected that the 2 sets of Ram i got were at diffrent CAS latency's, I took out the orignal instead of adding to it.. hoping for a more stable setup.

Bottom line, I'm nervous about investing time and money with a new PSU if the card is bad.
I've been an AMD/ATI fan for life... not really ready to switch yet....
What am i missing? anyone have a similar Mainboard maybe... bad Bios Settings?

At this point the only thing wrong with my X1300 pro was screen sparkles @ 1400x900... everything else was fine
It drives me crazy that $500.00 later the HD2900XT has no sparkles but has glitches and won't run the only game i actually play on the PC still.

Thanks in advanced for the help everyone.

November 2, 2007 9:31:27 PM

Update:
So i got home from work... I plugged my old ram in and tinkered with the Bios a little bit... set my 5000+ multiplier to 13 so it's running at 2.6GHZ , left the DDR voltage at 1.8 so the memory is not screaming fast, but i have 3gigs in their.
Case tempeture is 39C and cpu temp is again in the low 40C

Everythign is running great, and it dawned on me what the one diffrence between Civ4 and some of the other games was.

I run my res at 1400x900 because I have a 19" Wide screen monitor.
Other games automatically set the res lower, Civ4 allows me to keep it at 1400x900, and Civ at that Res causes the crash. I lowered the res on it and it worked fine.

I guess than it is just a power supply issue. I didn't think w/ a 750watt PSU i would have that problem.. I guess i under estimated how much juice some of these resolutions take to display.
I will tough it out until after christmas (or tax time) and than grab a new PSU, one from the AMD CRossfire recommended list.

I still welcome any comments or advise on the system if anyone has some.
November 2, 2007 9:48:13 PM

I would try it without the Stardock Window Blinds. I would also check to see if there are any updates from 2KGames for Civilizations IV. There could be a patch out that you haven't installed yet.

I would still completely remove the old drivers and use a driver cleaner like (I hope) you have read on these forums and install the latest ATI drivers. Especially with a HD2900XT.
Related resources
November 2, 2007 10:16:43 PM

I've had no such problems with my Diamond Viper Radeon HD 2900XT 512mb OC Edition. I have a few questions for you because I need to get a better idea of how you have your system setup. I know you're not a noob so don't get offended =)

1. What Catalyst Driver version are you using?
2. Did you use the Catalyst uninstaller yet? Heres a link to a fast download:
http://www.visiontek.com/teksupport/drivers/7.10_XP_dri...

3. Do you have both the 6 and 8 pin PCI-E power cables connected to your space heater (the 2900XT)?
4. Is your Civ4 patched to the latest version?

The 2900XT doesn't seem to use more or less watts at different resolutions according to my Kill-A-Watt meter. Its equally inefficient at all resolutions. I run all my games at 1680x1050 (except the Crysis demo, its a monster) and have no problems whatsoever. If my PSU can handle my system, your PSU far exceeds your requirements. You should be able to Crossfire two 2900XT's without a problem. My computer is idling at 322watts as I type this!

PS: My setup is as follows:: Opteron 185 @ 3001mhz 12x250mhz, DFI Lanparty nF4 SLI-DR Expert, Mushkin DDR500, Diamonds HD 2900XT 512mb, Creative Fagality X-Fi Gamer with fuggin useless X-Ram, Seasonic M12 700watt PSU, MACS Monsoon Lite II Themal Electric CPU cooler (150watt draw), 1 ungodly monthly lightbill (~$500 USD).
November 3, 2007 5:56:19 PM

Thank you guys very much.

I have to say, i used the ATI uninstaller utility originally, I ASSumed that would be enough.

After you guys posted i decided to give it one last shot and this time i used first the Catalyst uninstall tool that was linked (which was a great page, i also grabbed the southbridge driver off of there... too bad Diamond is not as informative)
I rebooted and than ran a driver cleaner pro and got rid of anything that had ATI on it.
Rebooted one more time... than installed the southbridge drivers.. than the Catalyst drivers from MSI's site, and than the lastest version of catalyst off ATI's site.

No VPU crash.

Civilization plays fine.

To anybody reading this post.... CLEAN THOSE DRIVERS!!!!!

BTW, you can run your games at 1680x1050 .. 1400x900 is the max option i have, Is this due to the monitor limitiations ? (Acer 19" wide)
!