Sign in with
Sign up | Sign in
Your question

Adaptec 5805 RAID and motherboard compatibility

Last response: in Storage
Share
May 31, 2008 7:41:21 AM

I have an Adaptec 5805 RAID controller that I want to use in a new system build. I have had my eye on an X48 Gigabyte motherboard, but an email to Gigabyte seems to indicate that the two PCIe x16 slots are for video cards only. WTF?

Maybe they are just covering their butts; I don't see why a PCIe x16 slot would only support video cards. That being said, I don't want to go down that path if it really won't work.

Anyone have this (or a similar model RAID card) and have it work ok on X38/X48 motherboards? What model board are you using?

Thanks!
June 4, 2008 6:34:29 AM

Just a quick followup. I went ahead and ordered the Gigabyte GA-X48T-DQ6 motherboard. Despite Gigabyte saying only video cards work in the x16 PCIe slots, the Adaptec 5805 does seem to work. At least I can get into the RAID BIOS. I have not yet received my drives so I haven't tested it further than that. Just in case anyone was wondering... :) 
June 5, 2008 1:55:55 AM

The video card only thing is a myth, as long as the are PCI-e slots they will work with any card , sound, raid whatever.

I have a 3805 in my P5K-e (P35) board which is in a PCI-e16x slot (although its electronically 4x) and it works perfectly fine.
Related resources
September 12, 2008 1:17:50 PM

Hello drwtsn32,
I would like to know if you have test your x48t-dq6 with the Adaptec 5805.Is everything ok? Did you have any problem with your SAS devices?
Regards,
Lucas
September 12, 2008 1:52:33 PM

No problems at all.. the card works great on my board! I am using SATA drives but that shouldn't matter.
Anonymous
a b V Motherboard
a b G Storage
December 12, 2008 11:17:08 AM

Please help i have a 5805 and cant get it to install and show up in windows.

I tried nLite and included the scsiport_win_x86_b16343 driver i downloaded.

I dont have a floppy drive and couldnt create the driver but the nLite from the download should work, but windows shows nothing on the install.

and it shows nothing on my single drive withinn windows.

please any one with advice?
April 6, 2009 2:37:28 AM

chookman said:
The video card only thing is a myth, as long as the are PCI-e slots they will work with any card , sound, raid whatever.

I have a 3805 in my P5K-e (P35) board which is in a PCI-e16x slot (although its electronically 4x) and it works perfectly fine.



FWIW

The video card only thing may not be a myth... I have an Asus M2N-SLI w/ 2 PCI-E x16 (one, I think wired at x8) and one of two things happen when I install my new Adaptec 5805 controller - no RAID BIOS posting, no device shown under Vista; or, POST hangs when the RAID BIOS presumably should be loading...

My 3ware 9690SA does the same thing...

ottembomb
April 6, 2009 4:32:33 AM

The "graphics" PCIe slots are connected directly to the northbridge instead of southbridge, thats the only technical difference. And your BIOS still needs interrupt 19 capture support to make the RAID controller work.
!