Sign in with
Sign up | Sign in
Your question

E-SATA not being nice

Last response: in Storage
Share
a b G Storage
May 31, 2008 10:51:46 PM

Ok, I have been reading here a long time, and love being helped and helping other people as well. I have a problem that I hope someone can help me with.

I recently purchased a Rosewill RX 358 E-SATA enclosure. I put in a Western Digital 640 GB hard drive into, ran it in USB to format it, then turned it off, and plugged in the E-SATA connector.

In the BIOS, the drive is detected through E-SATA. In windows, it finds nothing.

I go to Device manager and click on storage devices. I don't find it, so I have Windows try to detect new devices. It finds the new hard drive, but seems to "flicker" - almost like it's trying to determine if it is really there or not.

I go to administrative tools and go to the components manager and down to storage to find the new E-SATA device. At one time it showed up for ~ 1-2 minutes, but then disappeared.

The errors say that it times out with the LDM service (logical device manager) and the plug and play service. It even had a problem today with the ATAPI/IDE controller.

Does anyone else have any experience with a similar problem? I was reading that it could be a problem trying to get the full bandwith/speed through SATAII (3.0). I don't know how to downgrade it to SATAI (1.5).

I am really hoping someone can help. I don't really need another storage solution that is USB - what's the point of E-SATA if I can't utilize those connectors or even some of that speed?

Your help is greatly appreciated. Thanks

More about : sata nice

June 1, 2008 12:30:28 AM

whats your motherboard model?
a b G Storage
June 1, 2008 11:22:03 AM

I thought about this later and probably should list my specs

MSI p7n Diamond (780i)
E8400
2x2GB Crucial Memory DDR2 800
EVGA 8800GTS (G92)
WD 250 GB HD (OS)
WD 400 GB HD
OCZ Gamer Xtreme PSU (700W)
Samsung Burner w/ lightscribe.

I think the first post talked about the 640 GB HD in the Rosewill E-Sata case.

Almost forgot - OS - XP Pro x64
Related resources
a b G Storage
June 1, 2008 11:25:46 AM

I was thinking last night about this same problem.

I was thinking of updating the mobo drivers (to get the Jmicron drivers, that control the E-SATA ports, updated as well). I was hoping this could make a small difference.

I also have read somewhere that sometimes there isn't enough bandwidth to power the signal from the SATA controller, through the I/O connector, through the E-SATA cable, through the external case connector, through the hard drive, so some people have tried to set the drives at SATAI (1.5) instead of SATAII - I just was reading how to do this by changing the jumper settings.

I'm going to try those 2 solutions today.

If anyone has any suggestions, please send them along.
a b G Storage
June 1, 2008 12:33:43 PM

I always say start simple, then work your way up.
You have probably already done this, but double and triple check your SATA cable. I had a similar problem with a drive about a year ago. Drive was there, and then not, there, then not. Every other time I booted you never knew if you had a second drive or not. Finally figured out that the SATA cable for whatever reason simply would not make a good connection at the motherboard. I bought a new set of cables, problem solved.
a b G Storage
June 2, 2008 1:39:13 AM

I'll try that too jitpublisher. I have now spent a good part of the day battling back and forth with this.

I continue to get similar error messages. I even tried to set the jumpers to turn the HD back to SATAI (1.5). From checking out the tech threads through microsoft, the cable might be part of the problem.

Good suggestion jitpublisher.

I don't have an addition e-sata cable, but have one that has an SATA connector, and an e-sata connector on the other side. I'll probably just open up the case, plug in that way and see what happens.

If the disk shows up from SATA to E-SATA, then we know it's probably the cable, right? If it still doesn't work, then we can guess it's the circuit board/connectors on the external enclosure, I think.

The USB works like a charm, but that's not the point of buying E-SATA, right.

I'll battle more tomorrow after work.

Keep the responses coming. Thanks for letting me pick your brains and think out loud here.
a b G Storage
June 3, 2008 8:21:02 PM

Tried to go from SATA to E-SATA last night, but am not sure I actually got the thing connected all the way (didn't show a device in the BIOS).

I'll try again this weekend when I have some time to move things around better inside the case.

I might just pick up another E-SATA cable too to check that out as well (yay for Microcenter being pretty close).

Let me know if you have any other ideas.

Thanks
a b G Storage
June 9, 2008 12:44:33 AM

Alright...after doing much reading, I wonder if it's not hardware related, but OS/driver related.

I don't know if anyone has any experience with e-sata out there. If anyone can even partially answer these questions, it would be greatly appreciated.

1. Do I need to have AHCI set in the BIOS to et e-sata to work? (I think it may have huge impact on it being hot swappable)

2. Do I need special drivers for this?

3/ Do they need to be installed prior to changing settings in the BIOS?

4. Does AHCI even work on nVidia boards (like mine - 780i)?

5. Is there a workaround for nVidia chipsets? (media shield?) I heard nVidia chipsets could take advantage of many of the features offered by AHCI.

6. Do I need to reinstall XP x64 to try to get this to work - installing different drivers w/ F6 during the install, and making sure I change the settings in the BIOS?

7. I hear that Vista has built in AHCI support - should I just buck up and buy Vista x64?

Thanks in advance for anyone who has battled with this, or who has any knowledge that can help even a little bit. Thanks everyone for taking the time to read and respond.
a b G Storage
June 14, 2008 12:26:28 AM

OK...haven't heard back anything in a long time, so I'm going to try a few new things early tomorrow morning.

I'm going to try to put the 640 GB HD inside the computer (at least connect it internally to a SATA port) to see if it's OK.

I'm going to put another hard drive I own (500 GB) inside the e-sata case to see if it works.

I've had a few replies from Rosewill and they are attempting to diagnose the problem as well.

I will contact MSI about the P7N Diamond (780i) on Monday if I can't get it to work.

XP Pro x64 gives me this error:

Event ID 11 - Error on the IDE controller (IDE Port 2).

I tried to talk to a tech guy at microcenter and he suggested that it might be a power issue through the sata controller, so I'll check that as well.

I don't need another USB case - I really want the e-sata to work.

If anyone has an idea, I'd love to hear it.

Thanks
a b G Storage
June 18, 2008 9:23:05 PM

I'm still battling the problem. I don't know if anyone has another suggestion. I will be back this weekend with the next batch of attempted solutions.

Rosewill customer service is still getting back to me. Hopefully this will be fixed soon.

Thanks for any help in advance
a b G Storage
June 19, 2008 6:48:07 PM

I thought I would update everyone to my progress

Ok...I thought I would update you to the progress from this end.

I plugged the 640 GB hard drive into a sata port. It showed up and worked like it should.

I plugged in the hard drive, in the enclosure, via a sata-to-esata cable. It worked exactly like it should.

I plugged in the sata to esata bracket. I plugged the esata to esata cable that came with the enclosure. The hard drive opened up and worked like it should.

This leads me to believe that the esata ports on the motherboard are not working like they should. I assume that the problem lies in the fact that MSI does not support XP x64, and I used generic nVidia drivers. I will contact them to find out.

MSI has not been entirely friendly in regards to my using XP x64. Anyone have a workaround to make the drivers work on XP x64 (using vista x64?).

Should I dual boot XP x64 and XP 32 bit. Or should I just get vista 64 and dual boot with XP 32 bit?

Thanks for all the reads, suggestions, and help.
a b G Storage
June 21, 2008 8:23:10 PM

I know how many of you have had long sleepless nights worrying about this.

I finally contacted MSI about this, and they believed (and I had narrowed it down to that too) it may be a driver issue.

I installed the latest driver for the JMicron controller, and presto, it works.

Thanks for the help.

!