USB Ports / Printer vs Wireless Card

I have just spent 30 minutes with Charter tech support - 45 minutes with Epson tech support with no resolution for the following problem. When I am on the internet via my wireless card and try to turn on my printer it immediately knocks me offline. I am unable to have both running at the same time (like they are both using the same USB port??) I was told by Epson that under the printers properties that there should be a choice for USB001 or USB002 . . . but I do not have that option?? All I see is that my printer is connected to a USB virtual port. All I want to do is to be able to print from the internet - can anyone out there help me???
19 answers Last reply
More about ports printer wireless card
  1. The PC is connected via wireless USB adapter, and the printer is connected via USB port, correct?

    Is the printer also a wireless printer?
  2. The printer is not a wireless printer . . . connected to back of PC into a USB port. Will print a word doc offline just fine.
  3. Does it happen when other USB devices are plugged in?

    Have you tried reinstalling the printer?
  4. Don't really have anything else to plug in except my camera?? Never had the printer on while transferring pics??? I've deleted my printer and reconnected . . . do I need to do a complete uninstall???
  5. I would completely uninstall and reinstall it.

    I have a similar setup with no problem. My main computer is USB wireless, and I have a USB printer connected.

    Have you tried the printer in other USB ports? Maybe even try the front panel USB ports.
  6. I also have another computer with a similar setup . . . no problems?? But I did a complete uninstall and re-install of the printer and still have same problem. I even left my computer online hoping that it wouldn't "overtake" the USB port that the wireless was operating off of; but as soon as I attached the printer to the USB, it shut my wireless card down!!! I've also tried plugging both into other USB ports on the computer (even the front panel) . . . no difference. Even though I have 5-6 USB plug ins - my computer seems to think I only have one????
  7. Try uninstalling the USB hubs.
    Control panel-->system-->device manager-->under the USB section, right click and uninstall all of the USB root hubs-->restart.
    They will reinstall on startup. With the wireless adapter and printer both connected, and the printer powered on, it may resolve the conflict.
  8. I really thought that was gonna work . . . the computer went thru the whole process of recognizing both devices, searching for the drivers, and saying that I had unused hubs. I then tried to connect to the internet via my wireless and I got an error saying "unknown device" and that the device did not have any drivers installed. However, as soon as I turned off my printer . . . my wireless started working again!!!! I about to give up :(
  9. Double check in the BIOS to make sure the correct IRQ is assigned (normally is 9). If that is fine, you should look for a BIOS update. It could be a known problem that was fixed in an newer version.
    http://support.microsoft.com/kb/310575
  10. Not really computer savy . . . what do you mean by BIOS - IRQ??
  11. IRQs are interupt requests. The devices use interrupt requests when you perform actions.

    Changing IRQ assignments and flashing a BIOS, are serious actions. Each can have serious impacts on a system if done incorrectly. Proceed with caution.
  12. Before I get into anything more complicated than I can handle . . . want to make sure this is not a "power" issue. In Device Manager it lists a USB 2.0 Root Hub and (3) others that just say Root Hub. Checking the power on USB 2.0 Root Hub it has 500 mA, then under that 5 ports available - 0 mA. Also says "This hub is self powered. Total power available 500 mA per port". Looks to be ok - is it?
  13. Each hub has a certain number of available connections (most are 2). It also details how much power each can output. If any devices are connected, it'll display how much the devices are consuming.

    For example, I have 8 USB root hubs. 3 of them have devices connected to them. However, none of them exceed the available power output for the corresponding hub.

    Do you have service pack 3 installed?
  14. Find the hub that your devices are using. Go to the power management tab, and uncheck the box to allow the computer to turn off the device to save power.
  15. I checked earlier and the Service Pack 3 had already been installed. However, I think we might be getting closer to the cause of the problem . . . I went to the power management tab and unchecked the box for saving power. Then I turned on my printer so that the USB printer information would appear so I could uncheck it also, and what I discovered was that "USB Composite Device" suddenly was listed in the USB 2.0 Root Hub listed under my wireless connection - using 2 mA - with 4 ports available??
    In addition, information listed AFTER the USB 2.0 Root Hub were as follows:
    USB Composite Device
    USB Mass Storage Device
    USB Printing Support
    None of which had any power management options; and, of course, it knocked me offline.
  16. I think it's a step in the right direction. It's good that the composite device is showing up.

    Try uninstalling the USB root hubs again.
  17. Still not working . . . but what's interesting is that I can plug my GPS or my camera in the same port connections that I had my printer plugged in to, while I'm still online and I have no problem. :cry:
  18. This is an interesting one. If you don't mind, I'd like to one of our other members for some assistance.
  19. After talking to one of the other members, he thinks we're on the right track, and gave a few suggestions:
    -use a self powered USB hub, like this
    http://www.newegg.com/Product/Product.aspx?Item=N82E16817182174
    -dump the wireless USB adapter, and use a PCI network card, like this
    http://www.newegg.com/Product/Product.aspx?Item=N82E16833166021
Ask a new question

Read More

Wireless Support USB Printers Windows XP Product