Sign in with
Sign up | Sign in
Your question

Ipconfig not recognized in xp

Last response: in Windows XP
Share
March 27, 2010 6:31:16 PM

When I try to go to the ipconfig command line in xp, I get this message: is not recognized as an internal or external command, operable program or batch file.

I was trying to clean my DNS cache.

More about : ipconfig recognized

March 27, 2010 7:19:43 PM

Hi:give the following procedure a spin

1)right click on My Computer
2)properties Advaned System Settings.

3) Go to Advanced tab
4)click Environment Variables.

5)In text list under
system variables, double click variable named "Path".


6) Add text "C:\Windows;C:\Windows\system32"

in variable value.

7)Restart your computer after all done

If it still won't shows up then proceeds & follow what in (8)

8) Goto the Command Prompt ...
Start + Run cmd <Enter>
Change to System 32 sub-directory ...
CD C:\Windows\System32 <Enter>
Run IPConfig and direct the output to a text file ...
ipconfig /all > c:\ipconfig-all.txt <Enter>
Exit to close the Command Prompt window ...
exit <Enter>
Open Notepad

Open the output from IPConfig
Ctrl+O [O for Open - not Zero]
When the Open window pops up enter the fully qualified file name ...
c:\ipconfig-all.txt <Enter>
Carry on with whatever you were trying to accomplish ...

m
0
l
March 27, 2010 7:45:26 PM

Hi, thanks for you input.

I tried the first thing, and there was no change. I attempted the 2nd thing, but the response was that it was an invalid path.

If you can think of anything else, let me know.

Thanks
m
0
l
Related resources
March 27, 2010 8:19:27 PM

XP what?
XP Pro includes ipconfig (and other tools), XP Home doesn't.
It also depends on what (optional) network components you include when installing...
m
0
l
March 27, 2010 9:05:19 PM

lawsong said:
Hi, thanks for you input.

I tried the first thing, and there was no change. I attempted the 2nd thing, but the response was that it was an invalid path.

If you can think of anything else, let me know.

Thanks


Strange it worked on my WinXP pro
so what XP version do you have ?

Anyhow if you have the following version Microsoft v 5.1. 2600
copyright 1985-2001


1)right click on My Computer
2)properties Advaned System Settings.

3) Go to Advanced tab
4)click Environment Variables.

5)In text list under
system variables, double click variable named "Path".


6) Add text "C:\Windows;C:\Windows\system32" in variable value.

or c:\windows\system32\ipconfig in variable value.

7) Restart your system, it should work after Restart your PC


If you still got Error ipconfig is not recognized as an internal or external
command" you may need to approach a slightly different method: -
From the C: drive in DOS, type CD\WINDOWS\SYSTEM32 - Try the
IPCONFIG command from this location again

Star/Run/CMD
CD\WINDOWS\SYSTEM32 (Enter)
CD\windows\system32\ipconfig (Enter)


PS:make sure that you have version Microsoft XP pro v5.1. 2600
copyright 1985-2001

also make sure that Ipconfig.exe is located in your c:\windows\system32

you can search for start\search\Ipconfig.exe


later,G
m
0
l
March 27, 2010 10:46:34 PM

MrLinux said:
XP what?
XP Pro includes ipconfig (and other tools), XP Home doesn't.
It also depends on what (optional) network components you include when installing...


I have XP Pro. It was already installed on the computer when I purchased it off ebay. It is a legal copy.
m
0
l
June 28, 2011 7:24:52 PM

i had the same problem on my XP. it is a system setting. but to fix the problem and have DOS successfully bring up the ipconfig, all you have to do is run a hard line from your router. The problem with the setting is that it wont pull up on a wireless connection... just run a cat5, cat5e, or cat6 line directly to your computer. Hope this was helpful
m
0
l
August 5, 2013 4:07:58 PM

Same prob too, but I have a windows 8 HP pc and I did it. I did:
cd Microsoft Windows [Version 6.2.9200]
(c) 2012 Microsoft Corporation. All rights reserved.

C:\Users\user>cd C:\Windows\System32

C:\Windows\System32>ipconfig
m
0
l
August 5, 2013 4:09:32 PM

So basically, it's cd C:\Windows\System32
Then type ipconfig
m
0
l
!