Sign in with
Sign up | Sign in
Your question

vista x64 only shows 3.2GB

Last response: in Memory
Share
November 22, 2007 2:55:51 PM

hello,

i have a P5WDH- deluxe and in the bios it detects my full 4GB but allocates 800MB to other recources and said that only 3.2 is usable.

everest also says that the 4 banks are in use and it shows 1024MB on each bank.

as you see from the title i use vista ultimate x64

can someone please help as this drives me crazy.

i do not find other threads with this problem so sorry if i didn't found one.

i also tried google but it only gives me the x86 related 4GB problems(which i know does not work) but this is the reason i use vista 64 so i could use the full 4 GB

More about : vista x64 shows 2gb

November 22, 2007 3:31:40 PM

You need to enable memory remapping in your BIOS. In some BIOS's, you need to go to the advanced settings, sometimes via CTRL-F1. What motherboard do you have?

Note that you will want to make sure you have installed the vista-64 patch BEFORE changing your BIOS settings. I forget which one you are looking for but it's the one that prevents blue-screening when you have 4 GB or more of RAM in Vista-64.
November 22, 2007 3:32:09 PM

Where are you getting the amount of memory figure from?
Is it saying there is 3.2gb free, or do you mean you actually have about 2.7GB free in vista?
Related resources
November 22, 2007 3:49:18 PM

in vista i have 3.2GB available.
i have a asus P5WDH
my bios said that it allocates 800MB to other recources and i dont find this memory remapping.
i will also try the patch
November 22, 2007 4:03:59 PM

Look again, that motherboard definitely has a function to enable memory remapping. Take a look in Advanced - Chipset or something. If you can't find it, search Google. Vista64 won't show all 4 GB until you enable this and it is definitely there.
November 22, 2007 4:05:17 PM

Yes, I have this MB too. :)  Look at all possible places. Can't remember where too. :( 
November 22, 2007 4:29:50 PM

ok, installed the patch and enabled the remapping.

i have full 4GB now :) 

thank you all very much :hello: 
November 22, 2007 5:01:40 PM

You can also try to reduce your Virtual Memory (Swap File) to something like 512MB. It's what I did and working fine. No need to slowdown your experience by using the HD! :)  4GB is really great!
!