Sign in with
Sign up | Sign in
Your question

Scandisk runs even after proper shutdown

Last response: in Windows XP
Share
Anonymous
July 15, 2005 6:58:27 AM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

I am using windows xp with sp2 .. the problem is the system runs scandisk
everytime it boots even after proper shutdowns. Even "waittokillservice" in
registry is set to its default value 20000. Even tried increasing and
decresing the value, but of no help. The system is free of VIRUSes too.

Aditya Sinha
Anonymous
July 15, 2005 6:58:28 AM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

Scandisk has been retired. Use Error Checking in XP (chkdsk.exe).

Check Disk runs on every boot

Autochk.exe is a version of Chkdsk that runs only before Windows XP
starts. Autochk runs in the following situations:

Autochk runs if you try to run Chkdsk on the boot volume.
Autochk runs if Chkdsk cannot gain exclusive use of the volume.
Autochk runs if the volume is flagged as dirty.

This can happen if the drive's dirty bit is set.
When a drive's dirty bit is set, autochk automatically
checks the volume for errors the next time the computer is restarted.

Start | Run | Type: cmd | OK |

Type:

fsutil dirty query C:

Hit ENTER

This will report whether the dirty bit is set.
Volume C: is not dirty
Volume C: is dirty
[[If a volume's dirty bit is set, this indicates that the file system may be
in an inconsistent state. The dirty bit can be set because the volume is
online and has outstanding changes, because changes were made to the volume
and the computer shutdown before the changes were committed to disk, or
because corruption was detected on the volume. If the dirty bit is set when
the computer restarts, chkdsk runs to verify the consistency of the volume.

Every time Windows XP starts, Autochk.exe is called by the Kernel to scan
all volumes to check if the volume dirty bit is set. If the dirty bit is
set, autochk performs an immediate chkdsk /f on that volume. Chkdsk /f
verifies file system integrity and attempts to fix any problems with the
volume.]]
-----

If this is not the problem.....

Go here:
http://www.kellys-korner-xp.com/xp_tweaks.htm

Read the instructions at the top of the page.
Scroll down to:
82. Disable or Enable Check Disk Upon Boot
Click on Disable.

--
Hope this helps. Let us know.

Wes
MS-MVP Windows Shell/User

In news:%23gZS3rLiFHA.576@tk2msftngp13.phx.gbl,
Aditya Sinha <aditya_sinha@hotmail.com> hunted and pecked:
> I am using windows xp with sp2 .. the problem is the system runs scandisk
> everytime it boots even after proper shutdowns. Even "waittokillservice"
> in registry is set to its default value 20000. Even tried increasing and
> decresing the value, but of no help. The system is free of VIRUSes too.
>
> Aditya Sinha
Anonymous
July 15, 2005 6:58:28 AM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

Hi,

Start/run cmd, then run chkntfs /d from the prompt to clear the dirty bit.

--
Best of Luck,

Rick Rogers, aka "Nutcase" - Microsoft MVP
http://mvp.support.microsoft.com/
Associate Expert - WindowsXP Expert Zone
www.microsoft.com/windowsxp/expertzone
Windows help - www.rickrogers.org

"Aditya Sinha" <aditya_sinha@hotmail.com> wrote in message
news:%23gZS3rLiFHA.576@tk2msftngp13.phx.gbl...
>I am using windows xp with sp2 .. the problem is the system runs scandisk
> everytime it boots even after proper shutdowns. Even "waittokillservice"
> in
> registry is set to its default value 20000. Even tried increasing and
> decresing the value, but of no help. The system is free of VIRUSes too.
>
> Aditya Sinha
>
Related resources
Anonymous
July 15, 2005 7:53:41 PM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

Hey thanks it worked...
Anonymous
July 16, 2005 12:35:39 AM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

Glad to hear it. Keep having fun.

--
Hope this helps. Let us know.

Wes
MS-MVP Windows Shell/User

In news:o c5KDdSiFHA.708@TK2MSFTNGP09.phx.gbl,
Aditya Sinha <aditya_sinha@hotmail.com> hunted and pecked:
> Hey thanks it worked...
!