Sign in with
Sign up | Sign in
Your question

Need help dual-booting and partitioning RAID 1

Last response: in Storage
Share
June 24, 2008 4:18:17 AM

I figured with my first post I'd get right to business.

My newly built rig is currently running XP Pro on RAID 1. I plan to dual boot with Vista so before I attempted to install Vista, I tried to partition it using GParted 0.3.4-7 which didn't work. I'm guessing because GParted doesn't recognize RAID. I looked into other alternatives I can't seem to find any clear info on this except for a few vague explanations.

I also tried disconnecting one of the drives, disabling RAID, and then trying to partition to no avail, GParted gave me the the same error it did when I tried to partition as RAID 1. I'm open to suggestions for alternative programs.

Any help would be much appreciated.

Thanks in advance,

Zen

Current Rig Specs:

Core2Quad Q9450 w/ Thermalright IFX-14 Cooler
EVGA nForce 790i Ultra
300gb WD Velociraptor x2 in RAID 1, 500gb WD Caviar x1 for data
1gb Corsair XMS3 SLI DDR3 1600 x4
EVGA 9800GTX (For now)
ThermalTake 1200w Sli Power Supply
ThermalTake Armor+ Case
a b G Storage
June 25, 2008 5:56:23 AM

The Windows installer should allow you to partition a drive during the install process.
June 30, 2008 10:04:22 PM

Normally it should but it kept skipping that step and wanted to overwrite the XP files. But in any case, I solved the problem by loading Vista and hitting SHIFT F10 at the license key screen and going into the cmd prompt and running DISKPART. I should have done this the first time but people kept recommending against it claiming that it wouldn't recognize a raid array. Apparently it does and does it well. Thanks anyway.
Anonymous
a b G Storage
June 25, 2010 11:42:12 AM

Hi there

I'm currently experiencing the same problems as you did. The computer I received has used the entire RAID storage for one primary partition for XP. I want to reconfigure so that I give 200GB to XP, 500GB to ubuntu, and leave 300GB unallocated. I have the XP install disk and the ubuntu install disk, there is no data currently on the machine, so I am happy to reformat it. I tried reinstalling XP in the hope of re-partitioning the drive from the install disk, but I receive an error - it doesn't seem to be able to read the driver. I also tried using GParted from the Ubuntu live CD but that isn't working either. Any ideas?

!