Sign in with
Sign up | Sign in
Your question
Solved

Right mouse click menu does not appear

Last response: in Windows XP
Share
March 31, 2010 7:35:42 PM

In Windows XP using Excel 2007. I right click the mouse and nothing happens in Excel 2007 only. The right click menu works on the start menu, internet and other spreadsheet programs, it is just Excel 2007 that it doesn't work.

I've gone in the under Excel options and clicked the enable drag and drop button, which that function now works, but still no right click menu.

Appreciate any help.


More about : mouse click menu

April 1, 2010 5:08:52 AM

Just a thought. Excel macro programming allows the author to turn off the right-click menu using code such as Sub Disable_Shortcut() CommandBars(21).Enabled = False
End Sub

My question would be... is the right-click menu missing if you are creating a new spreadsheet, or is it missing only when using existing spreadsheets?
m
0
l
April 1, 2010 2:49:34 PM

I just tried it after creating a new spreadsheet and it still dosen't work either.
So should I write the macro above except to end it with True? Thanks for your help
m
0
l
Related resources

Best solution

April 1, 2010 3:40:31 PM

At least we are eliminating possible issues!

I wouldn't worry about creating the macro at this point.

The next thing to check is on the Tools menu option in Excel. Select Add-Ins and see what add-ins are installed. You can uncheck any add-ins to see if they are causing the problem. If more than one add-in is checked, you can turn them off one at a time to test. It is likely a good idea to exit and restart excel after each add-in unchecked.

For example there is an add-in called Essbase that is known to take over your right mouse click and has been known to cause your problem.

If you do have the Essbase add-in, try unchecking that one first. If this solves your problem and you want to still use the Essbase add-in you can regain control of your right mouse menu in Excel by:

Re-check the Essbase Add-in under Tools->Add-ins
Go to the Essbase menu and select Options....
Click on the global tab
Uncheck the "enable secondary button" under the "mouse actions" section

One other idea... Are you using a Wireless keyboard and mouse? If so, do they have separate receivers or do they use the same USB Receiver?

Let me know how you make out.
Share
April 8, 2010 2:08:48 PM

Hey Thanks for your help.

I do not have Essbase Add-in and I am using standard keyboard and a wheel-less mouse.

I did finally get this problem resolved thru iYogi. They fixed it, but I couldn't understand exactly what the prgrammer was saying. But I thought he said it had something to do with a certain file not opening properly. When I speak to them again I will relay any more details here.

Thanks for your help!
m
0
l
April 19, 2010 1:51:38 PM

Best answer selected by sobrien.
m
0
l
!