Wierd faulty folder on USB drive

First, I feel a need to apologize for two things, hopy you don't mind! :p

I'm sorry about the horribly uninformative topic-title...
I did not search for this, I don't know what to search for, and I'm very sleepy...terrible excuse...I know... :kaola:

I have a normal harddrive in an external box, that connects to my laptop/stationary through a USB 2.0 cable.

I've had this one for well over a year now, with no problems. Its a 160GB disk of some brand I don't remember right now. Unfortunately I don't have the tools at hand to see what harddrive it actually is, so lets assume the harddrive, as hardware, works alright.

There are several folders and files on this disk, I can access all of it, except one!!!
There is a folder where the computer just stalls when I try to access it. According to the LED on the box, the harddrive just starts working and working without end. After a couple of minutes the computer tells me that the drive is not formatted and it asks if I want to do that now. I say 'no' to that.

At this point I haven't had the luxury of testing if the program persists on another computer, but I assume the same will happen, since its 'only' a folder thats faulty.

Unfortunately I didn't see this problem earlier than today, I'm going on holiday and won't be back untill sunday. But if someone, eventhough that, knows whats wrong, and would help me, then I'm very grateful! :)

Jacob
3 answers Last reply
More about wierd faulty folder drive
  1. The drive may be going bad. Run the manufacturer's diagnostics on the drive and see if it reports any problem.

    If it checks out OK, run Windows chkdsk on the drive to rule out file system issues:

    chkdsk <drive letter>: /f
  2. Hmm...the Seatools for windows failed the 'long generic test', so I tried the chkdsk-command, it said that some filepostsegments where not readable...the test didn't present a log afterwards. I ran the seatools again...it still failed, I ran the chkdsk-command again, and there was no lines saying something like 'filepostsegment not readable'. However I did get my folder back!

    Neat trick! Thanks man!

    Jacob
  3. You still need to move your data off that drive. If the SeaTools test failed, the drive isn't going to last much longer.
Ask a new question

Read More

Hard Drives USB Drive Storage