Sign in with
Sign up | Sign in
Your question

SATA II Drive Not Recognized in WinXP

Last response: in Storage
Share
July 1, 2008 5:00:48 AM

I have a Western Digital 500GB SATA II RAID drive connected to a Silicon Image SiI 3512 SATARaid Controller. My motherboard is a ACPI Uniprocessor PC. The drive was formatted as a single partition with an NTFS file system. It is used to store all of my data files.

When I try to access the disk in Windows Explorer I get an error message:
"L:\ is not accessable.
The request could not be performed because of an I/O device error."

The drive and the controller show under Device Manager as working correctly. In Disk Manager the drive shows as having no file system.

Please advise how I can:
1) Get the drive to be accessable to XP, or, if that cannot be done
2) How I can recover the data from the drive.

I have an additional 500GB MY Book ProII that has 465 GB of free space.
July 1, 2008 10:52:48 AM

Does the drive show under Drive Manager? How did you format it? You should partition and format from Drive Manager. What Service pack installed? Try WD diagnostic program.

Mike
July 1, 2008 1:06:57 PM

Disk Manager shows the drive as Basic, Healthy and without a File System although it was formatted as an NTFS drive and it was used successfully for about one year. I had about 300GB of data on it. If I have to reformat the drive I want to recover the data from it first. Any advice on how I can do that? Might the issue be with the Controller?

I have Service Pack 2 installed on the XP Pro OS.

I tried the WD diagnostic program but it does not recognize the drive.

Ed S
Related resources
July 1, 2008 2:02:48 PM

Quote:
I tried the WD diagnostic program but it does not recognize the drive
.
The drive may have a damaged boot sector, or is now faulty, if not recognised by WD program. Google for drive repair utility to fix MBR.
If you right click on the drive in Disk Manager, is there any option to Take Ownership?

Mike.
July 1, 2008 3:50:45 PM

I have searched for a repair utility to fix the MBR. There are many - any suggestions as to which I should use?

Disk Manager right click with the offending drive selected does not give an option to Take Ownership.

Ed S
July 1, 2008 4:08:54 PM

You can do it by booting to your Windows XP disc and running the recovery console. There is a fixmbr tool. You will need to specify the device name or it will rebuild the mbr of your boot partition.

Read more about it here (search for fixmbr):
http://support.microsoft.com/kb/314058

And how to boot into the recovery console:
http://askbobrankin.com/fix_mbr.html

If this problem is due to a hardware failure, fixing the MBR may not help. A program like Spinrite may be your only hope:
http://www.grc.com/intro.htm
!