Sign in with
Sign up | Sign in
Your question

Dimension E520 will only load windows when boot cd is in cdrom?!?!?!?

Last response: in Windows XP
Share
April 1, 2010 8:16:00 PM

Ok, i have a dell dimension e520 with stock everything from dell ( P4, 512mb ram )

here are the specs:

http://www.dell.com/us/en/dfh/desktops/dimen_e520/pd.as...

First i had about 70 virus's on the hd, so i removed them when the drive was installed in another machine. So then windows was damaged from the removal, and so i did a clean install (after format), and everything was peachy, (installed windows, ran windows, installed programs etc.) well until i removed the xp installation cd, then it says "boot device not found, press f1 to continue, f2 to reboot". Here is the weird part, when i put the cd back in, reboot, and don't press a key when the " press any key to boot from cd" message comes up it will boot fine. Goes right into windows, etc.

In order to reinstall windows, i had to change an option in the bios from raid mode on the sata hd to ATA/autodetect option, because i was getting the bsod 0x0000007b error. The xp cd i used to reinstall was xp sp1 (one of the dell oem ones). I was able to install windows, install all drivers, install sp3 etc.. Everything was fine, until i removed the cd and rebooted. I attempted to change the raid option back to original setting in the bios, and reboot- and i got the same message.







The bottom line is- everything works fine when i boot with the xp install cd in the cdrom (and do not press a key when it asks to boot from cd). When i boot without the install cd, then acts like there is no os.



I have to admit, i have fixed many computers in my day, and this is the first time i have come across this. Could it be something wrong with the sata controller on the motherboard? What is going on? Any suggestions would be greatly appreciated, this one has got me stumped.
April 1, 2010 8:17:33 PM

I need to add that i had cleared the cmos before the reinstall because it had a password on it.
m
0
l
April 1, 2010 9:15:30 PM

Boot off the XP disc, and use the R option to get into the repair console. The default admin password is blank, so just hit enter there.

When you get to the C:\ prompt, type fixboot and hit enter. That will replace your boot files.

Then type bootcfg /rebuild and hit enter. This will recreate your boot.ini file.

When done, make sure the hard drive is the first boot device in the BIOS.

Your boot files and boot.ini should then all be correct. You should be able to boot normally.
m
0
l
Related resources
April 1, 2010 9:48:14 PM

Ok, i tried what you suggested, and i got the same thing. I checked the bios for boot priority settings. It displayed the hard drive but didn't assign it a number to even list it in the boot list. (weird right? it even said that unbootable drives will not be given a number) I am able to see the hd listed under drives in the bios, and it displays the size, label, serial number etc.. I have run diagnostics on the hd, and it came up with nothing.

I wonder if i need to flash the bios once inside windows with an executable since the pc didn't come with a floppy drive. Maybe it is something weird with sp3 and the bios version, although i haven't found any posts that describe the same symptoms.

Is it still possible it could be something weird with the disk controller on the mobo?

Thanks for the input. Any other suggestions?
m
0
l
April 1, 2010 9:51:56 PM

Some BIOSs have a hard drive priority as well as a boot device priority. Normally the first device is at the top.

I don't think there's anything wrong with the drive physically, or the motherboard, because it functions normally once you've booted into windows.
m
0
l
April 1, 2010 10:12:14 PM

I updated the bios, then turned the bios raid function back on, and now it does see the windows installation, only now the starting windows screen pops up, then a bsod, comes up too fast to read, then it reboots immediately.

Since i changed the way the bios is seeing the hd, do you think i should rebuild the boot files again?

Also in the bios, under the drives column, while selected on the hard drive, it says below that "this drive is controlled by the raid bios" does this mean i have to reinstall windows with a raid driver? Do you have to use a raid driver on an install if you aren't actually implementing any kind of raid function?
m
0
l
April 2, 2010 12:24:08 AM

Unless you want to set up a RAID array, you don't want the RAID controller. You should have another option, like AHCI.

m
0
l
April 2, 2010 2:40:28 AM

aford10, I appreciate all the help so far. I resorted to doing another fresh install after formatting- everything ran smoothly (install etc)- until i was in windows, removed the xp install cd, and rebooted- then the same error again " no boot device available". The bios is set to the "ata/raid autoselect" feature vs "Raid on" feature.

Is there anything else in the world this could be????!?!? I am ready to call in a priest to perform a exorcism.
m
0
l
April 2, 2010 3:45:13 AM

Is there another setting besides ATA and RAID? I'm looking for an AHCI setting.
m
0
l
April 2, 2010 4:29:41 AM

No. Under the "onboard drive" selection from the bios menu, it lists all of the sata ports, then underneath there is a selection for "sata operation". Inside there there is a selection between raid and ata/raid autodetect only. I have checked every menu in the bios thoroughly, and this is the only option even closely related.

I read on a different forum that the original oem windows media center sp2 discs have drivers for the sata drives that ealier versions like xpsp1 (that i have tried originally) didn't have. Apparently as sata drives became the norm, the manufacturers demanded the drivers with the install cds. I have used this same old dell install disc (xpsp1) many of times doing repairs, and never ran into this problem. I downloaded a torrent which i believe will work with my key on the box, i will let you know how it goes soon.

Thanks
m
0
l
April 2, 2010 4:52:57 AM

Well, it didn't work.

When i boot up, this is what it says:

Serial ATA AHCI BIOS, Version iSrc 1.02.23 11212006 copyright intel corporation

Controller Bus00, Device#1f, FunctionX02: 04 Ports, 02 devices
Port-00: Hard disc, WDC WD800JD-75MSA3
________________(this drive is controlled by the raid bios)
Port-01: cdrom, sony cd-rw/dvdrom CRX310S
Port-04: no device
Port-05: no device (note: there is no port 2 and 3 on this mobo: physically, and in the bios)
AHCI BIOS INSTALLED
Intel (r) Matrix Storage Manager option ROM v6.0.0.1022 ICH8r
Copywright intel blah blah blah



Now this screen only comes on when the raid on option is selected from the bios menu.(when i do this, it begins to load windows, and has a bsod, and reboots immediately. I cannot install xp in this mode without 0x0000007b errors)

When i have the ata/raid autodetect option selected i am able to install windows without bsod during setup process, but this is when i get the boot device not found error. There is no Floppy drive to install raid drivers from with this unit, and you can't install raid drivers from a cdrom in win xp setup. So frustrating.

It seems like when i leave an xp install cd in the cdrom, it acts like a boot disc or something, as long as i don't hit a key to invoke windows setup, everything works fine.
m
0
l
April 2, 2010 5:58:48 AM

Ok, so i thought i would just take a longshot...... i turned on the raid option in the bios, inserted my windows 7 x86 dvd, it installed, and rebooted without the dvd. WOW. I don't know why or how, but it works.
m
0
l
!