Sign in with
Sign up | Sign in
Your question

can't initialize sata hard disk (using pci controller)

Last response: in Storage
Share
July 14, 2008 5:37:55 AM

I am using an old motherboard, which uses SiS645DX chipset (motherboard is P4S533-E). I needed a new hard disk, so I bought a PCI controller card knowing that the motherboard doesn't have native SATA support. This is the card: http://www.dealextreme.com/details.dx/sku.4706

I bought a 320gb western digital hard disk - WD32 00AAKS, and connected everything. Under my computer there is no new drive registered. Under Disk management the disk is registered but it says not initialized. When I right click on it there is no initialize option.

I have searched the net and looked on the western digital website but there is no answer to my specific problem. I can't find any thread with the same problem. Everyone just says right click and click on initialize but that option is not there for me. what can I do? I've tried putting the hard disk in channel 0, and channel 1 but still no luck.

All my drivers are up to date. and under device manager it says the device is working properly.

July 14, 2008 5:51:57 AM

nevermind I wasn't right clicking on the correct place.
Anonymous
a b V Motherboard
a b G Storage
April 25, 2009 3:23:01 AM

would you happen to remember where exactly did you click, your response would be very much appreciated
Related resources
March 22, 2012 3:28:36 AM

Quote:
would you happen to remember where exactly did you click, your response would be very much appreciated





did you find out how to do it?
im having the same with an old wd drive 60g it wont initialize in disk management and doesnt matter where i right click it just tells me wrong parameters
November 24, 2012 1:48:42 AM

I had the same issue
November 24, 2012 1:54:36 AM

I had the same issue also ... at first i thought it was vista .. because i was able to format another 2gb hard drive from wd (which is now deceased) from my other computer which was running xp w/no problem .. now i have a 2gb seagate barrcuda ... and i guess like jeronz, i was not clicking the right spot .. i was clicking where it said unallocated ... but u actually have to click where it has the red arrow hovered over disk 2 as in the diagram above ... walla it worked .. formatting as i txt ... hopes this helps ...
November 24, 2012 1:57:12 AM

should have done a quick format .. only at 3secs .. 5mins
!