Sign in with
Sign up | Sign in
Your question

taking ownership of a my own files

Last response: in Storage
Share
July 22, 2008 4:10:58 AM

I had a motherboard go belly-up and after I replaced it, I screwed up the XP SP2 operating system to the point where I only get a reboot every time I try to startup. :pfff: 

I had some extra drives so I installed XP on one of them and connected up the old drive. I can see the directory where the files are located but XP will not allow me access.

I found a some info on “How to take ownership of a file or folder in Windows XP”, but it does not work. (MS Article ID : 308421)

For one thing, it wants me to go into safe mode and I can’t get it into safe mode. F8 dosent work. For XP Pro I need to disable “Simple File Sharing” (MS Article ID : 307874), which I can not find. :heink: 

Does anybody have any Ideas?

More about : taking ownership files

a c 130 V Motherboard
a c 160 G Storage
July 22, 2008 4:57:02 AM

Are you running XP home or pro(MCE is pro too)

IF XP Pro
Open any old explorer window and click Tools -> Folder Options
Once there select the View tab
Scroll down and turn OFF use simple file sharing at the bottom.

Now you should have the security tab on files.

IF Home
Read this and follow first

http://www.mydigitallife.info/2006/08/03/enable-and-dis...

_______________________________

Steps to take ownership of files.

Right click the drive you want to take ownership of and click properties.

Get over to the "Security" Tab and click on "Advanced".
Once there click on the "Owner" tab(Note the current owner of this item, if its all messed like in my screen, it's a user from the original computer).
Select your self from the list of owners(Change owner to).
Make sure you select "Replace owner on subcontainers and objects". hit "Apply"

You should get what looks like a file copy box but its called Security and it will take ownership of everything. This can take some time


Hope that helps some
Related resources
July 22, 2008 12:40:32 PM

Thanks for responding. I have XP Multi Media Center, but I can‘t see any security tabs, or at least as written in MS 307874. XP Professional appears on top of screen during certain command tasks. Your instructions look a little different.
I have to go to work now, so I’m going to check it out when I get back.
a c 130 V Motherboard
a c 160 G Storage
July 22, 2008 4:06:32 PM

Once you turn off simple file sharing it will look like the one on the ms site.

The screens above are from Windows Media Center Edition 2005. Its effectivly pro with the MCE parts added.
July 23, 2008 12:27:18 AM

nukemaster said:
Once you turn off simple file sharing it will look like the one on the ms site.

The screens above are from Windows Media Center Edition 2005. Its effectivly pro with the MCE parts added.


Ok, it worked! :bounce:  I Thank you, my wife thanks you, and kids thank you. My kids were about ready to string me up because I thought I lost all there stuff.

I did not realize that I needed to right click on the drive. I was trying to click on the folder itself. That was a great illustration , it made it so easy. Thanks again. :wahoo: 

This is a great forum, you can not believe the things that I read in other forums. I just knew it could not be true.


a c 130 V Motherboard
a c 160 G Storage
July 23, 2008 1:44:34 AM

You can also do it to folders and even files.

glad you got it working.
October 24, 2008 2:01:05 AM

I am having a similar problem. My computer is constantly disallowing things with a message that says the action requires administrator privileges. I am the only user and I do have admin privileges listed on my user account. In fact, I even disabled the guest account.

I'm using Vista Home Premium. I have already completed the steps suggested to the OP, but when it begins taking ownership, instead of taking ownership of all of it, it tells me that access is denied on many files, as in most of the registry files and the entire C:/windows folder. I have looked at some of the current security settings and nobody is listed as having full control. The items listed in most windows are Owner, Administrators, my user name, and then there is one that is labeled Trusted Installer. This Trusted Installer has Special Permissions, but I can't see what those are and I cannot find a way to take ownership of everything on my own C: drive.

It is causing me to be unable to correct issues with my DVD-RW, as well as to install Hijacker software and search for other issues.

HELP!
a c 130 V Motherboard
a c 160 G Storage
October 24, 2008 3:13:20 AM

Vista is a different story all together sometimes.

Did you turn off UAC? With UAC all accounts are non admin to prevent the user from damaging anything. This also causes a popup asking you to allow things to run when they want to be run as an admin.

If you want to turn UAC off(do so at your own risk), it can be done from the control panel under Control Panel->User Accounts and Family Safety->User Accounts->Turn User Account Control On or Off



As far as wanting to run your "hijacker" software(i assume hijack this?) you may want to right click the app and click run as administrator. That is only needed with UAC on.



Please tell me exactly what you are trying to take ownsership of. Is it files from an old install? do not take the full drive, just the folder or even files you need if it is on the same partition as windows.
October 24, 2008 4:39:19 AM

I already turned off UAC. No dice. It isn't about running HijackThis, it's about installing it. I gave up on that about a week ago, but my problems seem to be getting worse and worse. I have scanned over and over to see if I have a virus or malware and get nothing, but something wiggy is definitely going on.

Specifically, I want to take permission of the Windows folder on the C: drive. All the files and folders in it take permissions from the C: drive itself, to which I apparently do not have access, even when I try to run it as administrator. The reason I want permissions for that folder is to delete Windows/INF/Infcache.1 which may help with my one of my more irritating issues, the DVD-RW. The computer recognizes it as a generic CD drive only and I can't watch any DVDs; the system keeps ejecting the tray and asking me to insert a disk after running for several minutes. It reads CDs and CD-ROMs with no issues.

Since I posted earlier, I had Flash Player fail on me which I only discovered when I tried to watch something on YouTube. On the YouTube help page, they tell you to uninstall, restart, install newest Adobe Flash Player and then restart the web browser. It sounded easy enough. I uninstalled my old Flash Player and restarted. I went to the Adobe web site and now the new version will no load. I go to the download page and nothing happens. Nothing at all, not the hard drive working, not an error message, nothing! They have a link to a document that says it has Vista specific information. When I clicked that link, I got a blank page!!!!!!!!!!!!!!!!!!!!!

I'm not usually a cryer, but really, this is getting to be overwhelming a bit. I'm a student and I need my computer to work. Unfortunately, my husband lost the system CDs. Otherwise, I would have wiped the hard drive and reloaded already. I swear my next computer will be a Mac.

If you have any other suggestions at all, I would very much appreciate it. I'm not keen on buying a new computer right now, or paying to replace system CDs. Thanks!

Edited for typo in the file address.
October 24, 2008 4:49:11 AM

Oh, the DVD thing is fairly common from what I can gather. It seems everyone who has ever had a Toshiba laptop with a Pioneer DVD drive has had hardware recognition issues. The no-kidding fix-all suggested on most help forms was to try to update drives (no good) and failing that to go to the registry and delect the upper and lower filters. I did that and it didn't work, so the next option was to delete the INFcache.1 file. Since I have all of these permissions issues, I couldn't. I tried cutting and pasting it to the desktop and then deleting it, which had actually worked for something else, but I wasn't allowed to move it to the desktop either.

It's sort of convoluted and I suspect I have more than one issue at this point.

ETA: Lastly, my most recent issue is that I cannot load the standard view of Gmail even though I'm not having any sort of Internet connection issues. It will only load the basic view.

Again, I appreciate any help you can offer.
a c 130 V Motherboard
a c 160 G Storage
October 24, 2008 11:17:31 AM

I am going to have to try some stuff when i get home from work. It almost looks like some kind of lack of admin glitch the manufacturer put on the machine. This does not help MS's cause at all if manufacturers can not even get vista configured right on new machines.

Not being able to install flash would also be related to the non admin status that has somehow been given to your account.

If it was Vista home premium 64-bit(EDITED from 640 bit, SWEEEET) i would just give you a copy of mine as that would not be illegal(no cd key just windows) imo. I never could stand those preinstalled windows configs and always reinstalled anyway.

October 24, 2008 2:14:32 PM

For what it's worth, it turned out that I was able to take ownership of the INF folder inside the Windows folder. It took me three tries, but I finally got in there. I was able to delete the INFcache.1 file. Unfortunately, it did not help my DVD player issue. So, I kept the file in the Recycle bin just in case.

And, I agree that Vista does not help MS's cause at all, though my machine is not new. I've had it for a while and it worked relatively well for about a year. Of course, during that year, I never tried to play a DVD, so my DVD player may have been jacked up from the beginning. And, I wasn't trying to install much.

This whole thing is odd because it seems to be selective. Just a couple of weeks ago, I was able to uninstall my old McAfee AV program, and install an entirely new one with no admin warnings. And, the Adobe things seems very odd to me since I don't get any sort of message that says I don't have permission to install it, it is just that nothing happens.

I appreciate the thought that you would have sent me a copy of Vista. By the way, how could you tell I only have 32-bit? Just curious.
a c 130 V Motherboard
a c 160 G Storage
October 25, 2008 12:06:52 AM

At this time very few if any manufactures will use Vista 64 as they are worried about compatibility issues, not that i have had many(one TV card does not work with more then 4 gigs of ram.).

I have a pioneer DVD burner without issues(watching a DVD as I type this) on this desktop, but I have heard the same problem mentioned once before.
!