Sign in with
Sign up | Sign in
Your question

Missing DVD-RW/CD-ROM drive on mobo with P35+ICH9. Please Help

Last response: in Motherboards
Share
December 3, 2007 5:05:25 PM

Hello All,

Sorry to be cross posting this. I hoping some of the Gigabyte gurus here might have an answer. Thanks.

I just got a new Gigabyte GA-P35-DS3L P35+ICH9, and I'm putting together system as part of whole new build with all new components. I'm at the point where I want to backup the install, and here is where I ran into a problem.

I'm using Ghost(9.0/2003) but the the ghost CD-ROM bootdisk boots just fine, but when it comes to loading the OAKCDROM.SYS driver, the driver loads fine, but here is strange one, it can't find the IDE optical drive, the Liteon DVD-RW that is has been happily booting off of and loading all those nice drivers (ASPI, ATAPI, etc. etc.). This ghost boot disk is a trusted and true disk that works fine my AMD based Shuttle XPC, as well as the old P4 Dell at my work. At the moment I can work around it using a USB flash drive, but since this is a build for a friend, I'd rather be able create a set of backup DVDs. Without proper detection of the drive, MSCDEX is shot and I can't get to the .gho ghost image files.

Has something changed with the these new P35+ICH9 chipsets? Or should I suspect the Liteon DVD-RW drive? I'll be sticking in a old CD-ROM drive to see that is the case. Or is it and incompatibility with the old OAKCDROM.SYS and that I should use something more modern?

Thanks.

P.S. Quick update. I've tried a different CD-ROM drive and it still encounters the same problem.
a b V Motherboard
December 3, 2007 5:48:38 PM

OAKCDROM.SYS driver is a generic driver. If you can find it, replace it with a specific one.
Related resources
December 4, 2007 6:24:21 PM

Thanks for the quick reply.

I've tried is but it doesn't seem to work. BTW the drive works great in XP, just that I can't use it for Ghost which is essentiall running DOS. The same oakcdrom.sys with the same config.sys/autoexec.bat works on my other machines/motherboards (e.g. AMD64 nForce4 etc. or P4 520 i915P/G). And it is not like the oakcdrom.sys didn't load, rather it loaded but it can't find the IDE device. I also put the drive one of those other motherboards and it worked just time. It seems to be the P35+ICH9 chipset that is causing some sort of incompatibility. Anyone have success doing this?
December 4, 2007 6:28:23 PM

Can't you set your CD rom to a different IDE mode in the BIOS that will be compatible with the ghost drivers? It's a stab in the dark really....
December 7, 2007 1:24:08 PM

I believe I've tried all available IDE settings for the Gigabyte motherboard. I am suspecting that somewhere along the way, Intel ditched legacy IDE support in the ICH9 chipset. Can anyone confirm or deny?
December 7, 2007 2:09:51 PM

Hi,

try to build a Bart PE cd with Ghost 9 plugin.

Less problem that a dos cd.

Brad
December 10, 2007 5:22:12 PM

Pardon me for not understanding the lingo, what exactly is a Bart PE cd with Ghost 9? How do I construct such a CD? Any links to sites that give a step-by-step instructions for this? Thanks.
!