Sign in with
Sign up | Sign in
Your question

Using E-Sata ... not as a RAID connection..

Last response: in Storage
Share
July 23, 2008 8:48:19 AM

Hi guys,

real beginner question here, I have a Abit IP35 Pro (Socket 775) Motherboard and it has E-SATA connections on the back, great! I thought, I'll buy a MyBook II hard drive that has an E-sata connection and enjoying blistering transfer speeds. However, when I connect the hard drive, nothing happens, and in BIOS of the board, it only seems to mention E-SATA in a RAID context - thats not what I want to do with it, I just want to use it as a standard storage drive.


Any help mucho appreciated,


Cheers

Will

More about : sata raid connection

a b G Storage
July 23, 2008 12:16:38 PM

After you connect the drive, try rebooting. Check if the drive is showing in the bios. Set eSATA as IDE.
Check device manager for problems.
Install the JMicron driver.
a b G Storage
July 23, 2008 12:32:21 PM

If all that doesn't work you can buy a eSATA bracket for about $20.00 or an eSATA PCI or PCI-e card if you need the ports that you have.
July 23, 2008 12:48:48 PM

If you are using Vista, you need to go into hardware manager and search for hardware changes, but restarting should also work. Why these are not "hot-swappable" I have no idea.

I also have seen some motherboards, that although they have e-sata connectors on the back panels next to everything else, it is just a pass through, and you need to bring a cable from there over to the cluster of drive connections where you'd plug in your system hard drives.
July 23, 2008 1:09:48 PM

Thats ace guys cheers for your replies i'll post back tonight when i'm home and tried out your suggestions, cheers again

Will
July 23, 2008 6:03:25 PM

If you use an internal drive and have it in an enclosure and do it that way, you can choose any hard drive you like and are not limited to certain choices.

That is the main advantage, imho. I have a TB SATA drive in an enclosure and although I using a USB connection now, I have the option to connect via eSATA. I'll probably use eSATA eventually. I recommend trying an internal drive in an enclosure. Just make sure the enclosure you buy has both eSATA and USB options. I bought one of the NexStar 3 enclosures and it works fine.
a c 348 G Storage
July 24, 2008 3:04:59 PM

I examined the manual for your mobo and see that it does not clearly address the setup of the eSATA1 ports. That's like my mobo - few instructions, but it is hidden in there anyway.

On page 2-17 it starts Section 2-5 about the Integrated Peripherals. The third choice down is Onboard PCI DEvice, covered on page 2-19, and it includes the setup of the JMB363 Storage Controller involved here. From what little it says, within that menu you can enable or disable this controller which handles both IDE1 and eSATA1 functions, and you can configure the eSATA Controller Mode. Does not say anything more. BUT I suspect that, if you go into that, you will have an option for the eSATA1 controller to use or not use RAID. In fact, the "not use RAID" option is what you want, as you thought, and it could be labelled something else like "SATA" or "IDE" or some such. It might be as simple, though not obvious, as NOT checking a box to use RAID. Then as long as the eSATA controller is enabled but not set to RAID, it should work.

You will have to specifically Save and Reboot as you exit the BIOS Setup. Plug in your external drive on the eSATA port, make sure it is turned on, and reboot. Windows should find a new device and load its drivers. Then you can look for it in Disk Management. If your MyBook came partitioned and formatted already, you should be able to see it as a drive in My Computer. If not, you can use Disk Manager to do those tasks. In Disk Manager's right-hand panel at the bottom, right-click on the new unassigned drive and choose to Partition it. Split it up if you like, or make it one large volume using all the disk space. (Your OS must have support for "48-bit LBA" to make any volume greater than 127 GB.) Once the drive is partitioned, you right-click again on the partition(s) and choose to Format it (or them (one at a time), if you made more than one partition).

It's also possible that your MyBook came with a software CD with tools to do partitioning and formatting outside of Windows' Disk Management tools - I don't know because I have a different eSATA external drive. Either way, once the BIOS has been set to use the eSATA device WITHOUT RAID and Windows has loaded any necessary drivers, you must Partition and Format before Windows can see the device in My Computer and use it.
August 2, 2008 12:15:18 PM

Hi I found the setting in the bios and made sure it was on IDE, it is, and when i saved and rebooted, i get a nice bit of green text now that seems to recognize the 'western mybook 1000gb' is there but now when i get to windows nothing, i can switch on the HD (it switches off again during boot) but it just sits there doing its knight rider flashing light strip thing which usually means its doing something but its been like that for 20 minutes so i doubt it is. scan for hardware changes in device manager yields no results.. help!

ta

will
a c 348 G Storage
August 4, 2008 2:57:22 AM

When you say "in Windows, nothing", I'd like to know where in Windows. If you are just looking in My Computer and expecting to see a new 1TB drive, that may not work. Unless the MyBook came Partitioned and Formatted, you will need to do those things, as I said in previous. However, I wasn't clear on how to start.

Click on Start ... Control Panel ... Administrative Tools ... Computer Management. Under "Storage" in the left panel click on "Disk Management". Now on the right there is an upper panel showing all the drives ready for use, and below that is another panel with all the hardware in your system, ready or not. The list scrolls. Scroll down to the new drive and see what it says. The little bit on the left will call it "Disk3" or some such and give some stats. The white part to the right will show the proper disk name under Windows (like, "C:" for your main drive). If it already is partitioned and formatted it will tell you those things and show you stats, and then says some status message like "Healthy (Active)". However, if you don't have that showing, you probably need to Partition and Format.

If you have to do these, right-click on the drive, choose Partition from the menu, and set up the size you want. If your Windows is new (XP with SP1 or later) you can make the entire drive one volume. When that's done, another right-click and you can choose to Format it. If there's any choice, I highly recommend NTFS file system - not FAT32. If you choose fast format it is quick but does no checking of the disk. A Full Format will do that job, then test out the entire disk surface, taking hours. Notice that one of the right-click options, after you've done all this, is to change the Drive Letter Windows uses for this drive, in case you have some preference.

When you're done you may have to reboot, but My Computer should see your new empty drive.
August 4, 2008 6:31:01 AM

Paperdoc,

the drive is well and truly formatted and has been for some time! sorry I left out that detail, I was hoping for benefit of the doubt on that one. Anyway i've been using it for a while with usb since i gave up on e-sata ever working. Btw I had to go for FAT32 frustratingly due to macs I use for work being rubbish and unable to get on with NTFS.

Ok so in windows, nothing, means that I get nothing in my computer and it doesn't attempt to install drivers for a new device, nor can i find a new device using device manager by scanning for hardware changes - thats all I can think of trying. Since rebooting after my last post I no longer get the green text in bios quoting my hard drive, its switched back to describing my dvdrom drive like it used to :( 

Also when im in the bios, should I be able to scan for a new sata device and pick it up there? I tried all 6 sata channels but none of them pick up anything when scanned. My internal HDs are on channel 1 and 3.

Thank you for your help :) 

Cheers

Will
a c 348 G Storage
August 6, 2008 3:29:51 AM

Well, I'm running out of ideas. How about drivers? Maybe you need to load into Windows the driver necessary for it to recognize and deal with the existence of an eSATA port and device? Did the mobo's software CD say anything about how to set up drivers for that port?

Reaching further in desperation: I know that some earlier Windows would not partition a FAT32 volume to very large sizes, but I have seen it done, and I have read that partitions made that way by other utilities were recognized by Windows. However, any chance that Vista simply can't deal with a FAT32 volume of 1TB? On this line, though, you say you have been using it formatted that way using USB2 connections. Is that to your Mac only, or does it work on your Vista machine that way, too? That would eliminate any question of whether Windows can deal with such a partition.
Anonymous
a b G Storage
August 14, 2008 1:13:16 PM

Have you tried
http://support.wdc.com/product/download.asp?groupid=111... ?

You've received some really good advice already{pre 14Aug08}, but just to clarify my understanding of where you are now...

Your mbrd-bios CAN see the (e-)Sata drive - BUT that has been achieved by getting the bios to pretend it is an IDE
...so surely Windows is trying to use some kind of IDE drivers ?
[I've had this with some Sata PCs needing windows drivers and some don't by using that trick.
...Where that leaves any sata RAID functionality who knows!]

If you had managed to get the bios to see it as part of the Sata set, did you checkout the suggestion that the external interface might first need to be linked to the sata points on the m/brd ?

Both as Sata and as IDE, what was the result of exploring the device hierarchy in windows device manage (using the "by connection" option) ?

...and that device manager result is likely to change if you found Windows drivers as Sata (and maybe as IDE but I'm not so sure there) and installed them (from the WD site) and then re-attempted the search for new hardware.

IMO, it is always worth deleting a non-working controller (**NOT THE ONE WITH YOUR OPERATING SYSTEM RUNNING ON AT THE TIME OF COURSE! ** and be a bit circumspect with USB kbd and mouse control - don't lose both and be able to use keyboard navigation) and drive hierarchy from the device manager and letting Windows re-build its tables and use the latest drivers it can find. USB especially prone to this, but it is generically applicable.

Best of all, Start a correspondence with WD support
September 30, 2008 1:47:07 AM

I have the same mobo. At post, when you connects anything into the sata port(internal or external) it show the description. First list is the intel controller and 2nd is the JMicron controller(the ide and the 2 esata). If you cant see at the post screen-windows is not going to see it. Likely cause is bad esata cables.

Igores all other suggestion-first thing first: making sure you can detect it at post. Doesn't matter what setting the port is set to( RAID, or IDE); doesn't care if its formatted or not-the post menu will see it . If you eliminate the bad cable possibility then look toward the drive itself.

GOODLUCK

oh btw, RAID option in bios doesn't mean your drive is force into an array. It's just open the option for you to set it in a array. After you get out of the bios menu, you get another post screen telling you to press a series of buttons to go into the raid menu. There is where you assign what drive will be part of an array. Any drive that is not set up in an array will just function as a regular drive.
Anonymous
a b G Storage
November 22, 2008 8:08:44 PM

Question?

Can you connect some sort of device" which has CPU" through eSATA, to be able to use that CPU.

My goal is to be able to add another cpu to my motherboard, but the port i have is not new and I can not change my cpu to quadcore. So I thought of a ceeper solution instead of changing motherboard, simply install eSATA addapter into PCI port, then connect device to it through eSATA cable, the device which would have nothing inthere exept for chipest motherboard housing quad CPU or better several quad CPU's ???? ANYONE????
March 16, 2011 9:50:39 PM

1748269,1,299838 said:


i know this sounds obvious but have you pluged both a usb and a esata cable in if you haven't got a external power supply the esata port cant handle it :) 
!